summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--amarok_mariadb.patch22
3 files changed, 7 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98bd35d0dffd..6f0baba0eb67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = amarok
pkgdesc = The powerful music player for KDE
- pkgver = 2.9.0.r476.ce93fb34c3
+ pkgver = 2.9.0.r482.c272ca62ca
pkgrel = 1
url = http://amarok.kde.org/
arch = x86_64
@@ -28,10 +28,8 @@ pkgbase = amarok
depends = threadweaver
optdepends = ifuse: support for Apple iPod Touch and iPhone
optdepends = loudmouth: backend needed by mp3tunes for syncing
- source = amarok-2.9.0.r476.ce93fb34c3.tar.gz::https://github.com/KDE/amarok/archive/ce93fb34c396f1b7766daaf43669d82f949ff091.tar.gz
- source = amarok_mariadb.patch
- sha256sums = a7c9854bc644260907c91fa555734475fe24bbdc3d5d62b249a71ea0e0b472c2
- sha256sums = d6540427b3a4e81d87c761b5e8ac918b035af8f92b30778f735f6be449889091
+ source = amarok-2.9.0.r482.c272ca62ca.tar.gz::https://github.com/KDE/amarok/archive/c272ca62cac01488c8e9e5730a815dbb01cd69ac.tar.gz
+ sha256sums = feeaf11b5f5ea4ee11dcceb32214d6f574980c258d29ac875b6d4026b21690c5
pkgname = amarok
diff --git a/PKGBUILD b/PKGBUILD
index 4c726555be75..43dea9c334ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: damir <damir@archlinux.org>
pkgname=amarok
-pkgver=2.9.0.r476.ce93fb34c3
+pkgver=2.9.0.r482.c272ca62ca
pkgrel=1
pkgdesc="The powerful music player for KDE"
arch=("x86_64")
@@ -17,15 +17,9 @@ optdepends=(
"ifuse: support for Apple iPod Touch and iPhone"
"loudmouth: backend needed by mp3tunes for syncing"
)
-_commit="ce93fb34c396f1b7766daaf43669d82f949ff091"
-source=(
- "${pkgname}-${pkgver}.tar.gz::https://github.com/KDE/${pkgname}/archive/${_commit}.tar.gz"
- "${pkgname}_mariadb.patch"
-)
-sha256sums=(
- "a7c9854bc644260907c91fa555734475fe24bbdc3d5d62b249a71ea0e0b472c2"
- "d6540427b3a4e81d87c761b5e8ac918b035af8f92b30778f735f6be449889091"
-)
+_commit="c272ca62cac01488c8e9e5730a815dbb01cd69ac"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/KDE/${pkgname}/archive/${_commit}.tar.gz")
+sha256sums=("feeaf11b5f5ea4ee11dcceb32214d6f574980c258d29ac875b6d4026b21690c5")
#git describe --long --tags 2> /dev/null | sed "s/^[A-Za-z\.\-]*//;s/\([^-]*-\)g/r\1/;s/-/./g"
#git rev-parse HEAD
@@ -34,7 +28,6 @@ sha256sums=(
prepare() {
cd "${srcdir}/${pkgname}-${_commit}"
- patch -Np1 -i "${srcdir}/amarok_mariadb.patch"
mkdir -p "${srcdir}/${pkgname}-${_commit}/build"
}
diff --git a/amarok_mariadb.patch b/amarok_mariadb.patch
deleted file mode 100644
index fbc04cbc882d..000000000000
--- a/amarok_mariadb.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/cmake/modules/FindMySQL.cmake b/cmake/modules/FindMySQL.cmake
-index 0bd7fdfd07..0216668731 100644
---- a/cmake/modules/FindMySQL.cmake
-+++ b/cmake/modules/FindMySQL.cmake
-@@ -42,7 +42,16 @@ if(MYSQLCONFIG_EXECUTABLE)
- # At least on OpenSUSE and FreeBSD --libmysql-libs doesn't exist, so we just use
- # MYSQL_LIBRARIES for that. We'll see if that's enough when testing
- # below.
-- set(MYSQL_EMBEDDED_LIBRARIES ${MYSQL_LIBRARIES})
-+ # mysql-config removed --libmysql-libs, but amarok need libmysqld other
-+ # than libmysqlclient to run mysql embedded server.
-+ find_library(MYSQL_EMBEDDED_LIBRARIES NAMES mysqld libmysqld
-+ PATHS
-+ $ENV{MYSQL_DIR}/libmysql_r/.libs
-+ $ENV{MYSQL_DIR}/lib
-+ $ENV{MYSQL_DIR}/lib/mysql
-+ PATH_SUFFIXES
-+ mysql
-+ )
- else()
- set(MYSQL_EMBEDDED_LIBRARIES ${MC_MYSQL_EMBEDDED_LIBRARIES})
- endif()