summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7597652d08db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = amazon-workspaces-bin
+ pkgdesc = Amazon Workspace Client
+ pkgver = latest
+ pkgrel = 1
+ url = https://clients.amazonworkspaces.com/
+ arch = i686
+ arch = x86_64
+ license = non-free
+ makedepends = binutils
+ makedepends = tar
+ options = staticlibs
+ source = workspaces-client.deb::https://d3nt0h4h6pmmc4.cloudfront.net/ubuntu/dists/bionic/main/binary-amd64/workspacesclient_3.0.0.200_amd64.deb
+ sha1sums = SKIP
+
+pkgname = amazon-workspaces-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d3e1c844bed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Steve Engledow <steve@engledow.me>
+pkgname=amazon-workspaces-bin
+pkgver=latest
+pkgrel=1
+pkgdesc="Amazon Workspace Client"
+arch=('i686' 'x86_64')
+url="https://clients.amazonworkspaces.com/"
+license=('non-free')
+depends=(
+)
+options=('staticlibs')
+makedepends=(
+ 'binutils'
+ 'tar'
+)
+source=("workspaces-client.deb::https://d3nt0h4h6pmmc4.cloudfront.net/ubuntu/dists/bionic/main/binary-amd64/workspacesclient_3.0.0.200_amd64.deb")
+sha1sums=("SKIP")
+
+build() {
+ cd "$srcdir"
+ ar x workspaces-client.deb
+ tar axvf data.tar.xz
+}
+
+package() {
+ mkdir -p $pkgdir/usr/share/amazon-workspaces
+ mkdir -p $pkgdir/usr/bin
+
+ # Icons
+ cp -a $srcdir/usr/share/* $pkgdir/usr/share/
+
+ # Binary
+ cp -a $srcdir/opt/workspacesclient/* $pkgdir/usr/share/amazon-workspaces/
+
+ # Launcher
+ ln -s $pkgdir/usr/share/amazon-workspaces/workspacesclient $pkgdir/usr/bin/amazon-workspaces
+}