summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
-rw-r--r--amdtfset-git.install8
-rw-r--r--amdtfset.desktop9
-rw-r--r--amdtfset.pngbin0 -> 3012 bytes
5 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97d5a2a9a95b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = amdtfset-git
+ pkgdesc = Small command-line utility to set and query the tear free desktop option present in the AMD Catalyst. Uses AMD ADL
+ pkgver = v1.0
+ pkgrel = 1
+ url = https://github.com/sebth/amdtfset
+ install = amdtfset-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = sed
+ depends = catalyst-utils
+ provides = amdtfset
+ conflicts = amdtfset
+ source = amdtfset::git+https://github.com/sebth/amdtfset.git
+ source = amdtfset.png
+ source = amdtfset.desktop
+ md5sums = SKIP
+ md5sums = ef868543996c642350b7487d1b6b90e0
+ md5sums = 25173396024bd34fa98161b864c8a2a1
+
+pkgname = amdtfset-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f20ff72d4acf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Vi0L0 <vi0l093@gmail.com>
+
+_pkgname=amdtfset
+pkgname=$_pkgname-git
+pkgver=v1.0
+pkgrel=1
+pkgdesc="Small command-line utility to set and query the tear free desktop option present in the AMD Catalyst. Uses AMD ADL"
+arch=('i686' 'x86_64')
+url="https://github.com/sebth/amdtfset"
+license=('GPL3')
+groups=()
+depends=('catalyst-utils')
+makedepends=('git' 'sed')
+optdepends=()
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+#backup=("etc/$_pkgname/$_pkgname.conf")
+install=${pkgname}.install
+source=("$_pkgname::git+https://github.com/sebth/amdtfset.git"
+ 'amdtfset.png'
+ 'amdtfset.desktop')
+md5sums=('SKIP'
+ 'ef868543996c642350b7487d1b6b90e0'
+ '25173396024bd34fa98161b864c8a2a1')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --tags | sed 's|-|.|g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make install PREFIX="$pkgdir/usr"
+
+ install -D -m755 "$srcdir/amdtfset.png" "$pkgdir/usr/share/pixmaps/amdtfset.png"
+ install -D -m755 "$srcdir/amdtfset.desktop" "$pkgdir/usr/share/applications/amdtfset.desktop"
+}
diff --git a/amdtfset-git.install b/amdtfset-git.install
new file mode 100644
index 000000000000..efeafd423ff8
--- /dev/null
+++ b/amdtfset-git.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo " Desktop endtry seems to work fine on KDE:"
+ echo " /usr/share/applications/amdtfset.desktop "
+}
+
+post_upgrade() {
+ post_install
+} \ No newline at end of file
diff --git a/amdtfset.desktop b/amdtfset.desktop
new file mode 100644
index 000000000000..5a678bd89ff6
--- /dev/null
+++ b/amdtfset.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=amdtfset
+GenericName=AMD Tear Free Set
+Comment=set and query the tear free desktop option
+Icon=amdtfset
+Exec=test $(amdtfset | grep -c dis) == 1 && amdtfset on || amdtfset off ; amdtfset; echo "Terminal will close in 2 seconds..."; sleep 2
+Terminal=true
+Categories=Settings
diff --git a/amdtfset.png b/amdtfset.png
new file mode 100644
index 000000000000..6c1b7ff5ff7d
--- /dev/null
+++ b/amdtfset.png
Binary files differ