summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0001-fix-compile-error-on-clang.patch27
-rw-r--r--0001-remove-linking-with-whole-archive-v2.patch28
-rw-r--r--0001-remove-linking-with-whole-archive.patch46
-rw-r--r--0001-workaround-remove-invalid-constexpr-modifier.patch43
-rw-r--r--PKGBUILD16
-rw-r--r--amd_icd64.json8
7 files changed, 9 insertions, 169 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e59c90231263..ac6866a8f31b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Feb 27 12:42:48 UTC 2018
pkgbase = amdvlk-git
pkgdesc = AMD's standalone Vulkan driver
- pkgver = r18.0eb7396
+ pkgver = r20.d62dbcc
pkgrel = 1
url = https://github.com/GPUOpen-Drivers
arch = x86_64
@@ -15,20 +13,16 @@ pkgbase = amdvlk-git
depends = vulkan-icd-loader
provides = vulkan-amdvlk
conflicts = vulkan-amdvlk
- source = llvm::git+https://github.com/GPUOpen-Drivers/llvm.git#branch=amd-vulkan-master
+ source = llvm::git+https://github.com/GPUOpen-Drivers/llvm.git#branch=amd-vulkan-dev
source = git+https://github.com/GPUOpen-Drivers/xgl.git#branch=dev
source = git+https://github.com/GPUOpen-Drivers/pal.git#branch=dev
source = git+https://github.com/GPUOpen-Drivers/AMDVLK.git#branch=dev
- source = 0001-remove-linking-with-whole-archive-v2.patch
source = amdPalSettings.cfg
- source = amd_icd64.json
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 268528bf2c6e855707635e65ece19b179135fa8823c1a9cc01746fd9235b8139
sha256sums = 5f798911bf1cbbe5a83f5ae4886107ef0d02be5753450753ae2d3fc6f80e7012
- sha256sums = 39c26b6d91a8c5b42818a6cc3529b3803aba8f3a759d8eb6b682ecb027f4762c
pkgname = amdvlk-git
diff --git a/0001-fix-compile-error-on-clang.patch b/0001-fix-compile-error-on-clang.patch
deleted file mode 100644
index 1065b2eea4f1..000000000000
--- a/0001-fix-compile-error-on-clang.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From d51507637e29281152b47ef30a3488c29c2a0955 Mon Sep 17 00:00:00 2001
-From: Christoph Haag <haagch@frickel.club>
-Date: Fri, 22 Dec 2017 13:03:43 +0100
-Subject: [PATCH] fix compile error on clang
-
-xgl/icd/api/llpc/util/llpcDebug.cpp:116:10: error: reference to scoped enumeration must use 'enum' not 'enum class'
- enum class ResourceMappingNodeType type) // Resource map node type
----
- icd/api/llpc/util/llpcDebug.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/icd/api/llpc/util/llpcDebug.cpp b/icd/api/llpc/util/llpcDebug.cpp
-index 1273cd6..847786e 100644
---- a/icd/api/llpc/util/llpcDebug.cpp
-+++ b/icd/api/llpc/util/llpcDebug.cpp
-@@ -113,7 +113,7 @@ bool EnableErrs()
- // Translates enum "ResourceMappingNodeType" to string and output to ostream.
- raw_ostream& operator<<(
- raw_ostream& out, // [out] Output stream
-- enum class ResourceMappingNodeType type) // Resource map node type
-+ enum ResourceMappingNodeType type) // Resource map node type
- {
- const char* pString = nullptr;
- switch (type)
---
-2.15.1
-
diff --git a/0001-remove-linking-with-whole-archive-v2.patch b/0001-remove-linking-with-whole-archive-v2.patch
deleted file mode 100644
index 92d0aea0205a..000000000000
--- a/0001-remove-linking-with-whole-archive-v2.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From ab357c76493b0285f3fca0502085b3766e8e9be1 Mon Sep 17 00:00:00 2001
-From: Laurent Carlier <lordheavym@gmail.com>
-Date: Thu, 28 Dec 2017 13:23:36 +0100
-Subject: [PATCH] remove linking with --whole-archive (v2)
-
-it breaks the build by linking pal twice and duplicating its symbols
-
-v2: update the patch
----
- icd/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/icd/CMakeLists.txt b/icd/CMakeLists.txt
-index fbc125e..0384859 100644
---- a/icd/CMakeLists.txt
-+++ b/icd/CMakeLists.txt
-@@ -293,7 +293,7 @@ if (UNIX)
-
- if(CMAKE_BUILD_TYPE_RELEASE)
- execute_process(COMMAND ${CMAKE_C_COMPILER} -dumpversion OUTPUT_VARIABLE GCC_VERSION)
-- if (GCC_VERSION VERSION_GREATER 5.3 OR GCC_VERSION VERSION_EQUAL 5.3)
-+ if ((GCC_VERSION VERSION_GREATER 5.3 OR GCC_VERSION VERSION_EQUAL 5.3) AND GCC_VERSION VERSION_LESS 7.0)
- target_link_libraries(xgl PRIVATE -Wl,--whole-archive ${PROJECT_BINARY_DIR}/pal/src/libpal.a -Wl,--no-whole-archive)
- target_link_libraries(xgl PUBLIC -Wl,--whole-archive ${PROJECT_BINARY_DIR}/pal/metrohash/libmetrohash.a -Wl,--no-whole-archive)
- target_link_libraries(xgl PUBLIC -Wl,--whole-archive ${PROJECT_BINARY_DIR}/pal/gpuopen/libgpuopen.a -Wl,--no-whole-archive)
---
-2.15.1
-
diff --git a/0001-remove-linking-with-whole-archive.patch b/0001-remove-linking-with-whole-archive.patch
deleted file mode 100644
index be99d0061bc2..000000000000
--- a/0001-remove-linking-with-whole-archive.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From d56190445766f1b8ff7ddeb46f88c3609bd6dea7 Mon Sep 17 00:00:00 2001
-From: Christoph Haag <haagch@frickel.club>
-Date: Fri, 22 Dec 2017 13:46:09 +0100
-Subject: [PATCH] remove linking with --whole-archive
-
-it breaks the build by linking pal twice and duplicating its symbols
----
- icd/CMakeLists.txt | 22 +++++++++++-----------
- 1 file changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/icd/CMakeLists.txt b/icd/CMakeLists.txt
-index 4e4d669..372783a 100644
---- a/icd/CMakeLists.txt
-+++ b/icd/CMakeLists.txt
-@@ -530,17 +530,17 @@ if (UNIX)
-
- # CMAKE-TODO: What is whole-archive used for?
- #target_link_libraries(xgl -Wl,--whole-archive ${ICD_LIBS} -Wl,--no-whole-archive)
-- if(CMAKE_BUILD_TYPE_RELEASE)
-- execute_process(COMMAND ${CMAKE_C_COMPILER} -dumpversion OUTPUT_VARIABLE GCC_VERSION)
-- if (GCC_VERSION VERSION_GREATER 5.3 OR GCC_VERSION VERSION_EQUAL 5.3)
-- target_link_libraries(xgl PRIVATE -Wl,--whole-archive ${PROJECT_BINARY_DIR}/pal/src/libpal.a -Wl,--no-whole-archive)
-- target_link_libraries(xgl PUBLIC -Wl,--whole-archive ${PROJECT_BINARY_DIR}/pal/metrohash/libmetrohash.a -Wl,--no-whole-archive)
-- target_link_libraries(xgl PUBLIC -Wl,--whole-archive ${PROJECT_BINARY_DIR}/pal/gpuopen/libgpuopen.a -Wl,--no-whole-archive)
-- target_link_libraries(xgl PUBLIC -Wl,--whole-archive ${PROJECT_BINARY_DIR}/pal/vam/libvam.a -Wl,--no-whole-archive)
-- target_link_libraries(xgl PUBLIC -Wl,--whole-archive ${PROJECT_BINARY_DIR}/pal/addrlib/libaddrlib.a -Wl,--no-whole-archive)
-- target_link_libraries(xgl PUBLIC -Wl,--whole-archive ${PROJECT_BINARY_DIR}/pal/jemalloc/libjemalloc.a -Wl,--no-whole-archive)
-- endif()
-- endif()
-+# if(CMAKE_BUILD_TYPE_RELEASE)
-+# execute_process(COMMAND ${CMAKE_C_COMPILER} -dumpversion OUTPUT_VARIABLE GCC_VERSION)
-+# if (GCC_VERSION VERSION_GREATER 5.3 OR GCC_VERSION VERSION_EQUAL 5.3)
-+# target_link_libraries(xgl PRIVATE -Wl,--whole-archive ${PROJECT_BINARY_DIR}/pal/src/libpal.a -Wl,--no-whole-archive)
-+# target_link_libraries(xgl PUBLIC -Wl,--whole-archive ${PROJECT_BINARY_DIR}/pal/metrohash/libmetrohash.a -Wl,--no-whole-archive)
-+# target_link_libraries(xgl PUBLIC -Wl,--whole-archive ${PROJECT_BINARY_DIR}/pal/gpuopen/libgpuopen.a -Wl,--no-whole-archive)
-+# target_link_libraries(xgl PUBLIC -Wl,--whole-archive ${PROJECT_BINARY_DIR}/pal/vam/libvam.a -Wl,--no-whole-archive)
-+# target_link_libraries(xgl PUBLIC -Wl,--whole-archive ${PROJECT_BINARY_DIR}/pal/addrlib/libaddrlib.a -Wl,--no-whole-archive)
-+# target_link_libraries(xgl PUBLIC -Wl,--whole-archive ${PROJECT_BINARY_DIR}/pal/jemalloc/libjemalloc.a -Wl,--no-whole-archive)
-+# endif()
-+# endif()
-
- #${ICD_TARGET}.so${SO_VERSION_NUMBER} : ${filter-out -Wl%,$(LLLIBS})
-
---
-2.15.1
-
diff --git a/0001-workaround-remove-invalid-constexpr-modifier.patch b/0001-workaround-remove-invalid-constexpr-modifier.patch
deleted file mode 100644
index 8bebe73e6163..000000000000
--- a/0001-workaround-remove-invalid-constexpr-modifier.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From f6eeea01b0f25c887fab451af151e43a4c1c65d0 Mon Sep 17 00:00:00 2001
-From: Christoph Haag <haagch@frickel.club>
-Date: Fri, 22 Dec 2017 12:56:32 +0100
-Subject: [PATCH] workaround: remove invalid constexpr modifier
-
----
- src/util/math.cpp | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/util/math.cpp b/src/util/math.cpp
-index 46e9ede..3af4259 100644
---- a/src/util/math.cpp
-+++ b/src/util/math.cpp
-@@ -54,7 +54,7 @@ static uint32 Float32ToFloatN(float f, const NBitFloatInfo& info);
- static float FloatNToFloat32(uint32 fBits, const NBitFloatInfo& info);
-
- // Initialize the descriptors for various N-bit floating point representations:
--static constexpr NBitFloatInfo Float16Info =
-+static NBitFloatInfo Float16Info =
- {
- 16, // numBits
- 10, // numFracBits
-@@ -72,7 +72,7 @@ static constexpr NBitFloatInfo Float16Info =
- (23 - 10), // fracBitsDiff
- };
-
--static constexpr NBitFloatInfo Float11Info =
-+static NBitFloatInfo Float11Info =
- {
- 11, // numBits
- 6, // numFracBits
-@@ -90,7 +90,7 @@ static constexpr NBitFloatInfo Float11Info =
- 23 - 6, // fracBitsDiff
- };
-
--static constexpr NBitFloatInfo Float10Info =
-+static NBitFloatInfo Float10Info =
- {
- 10, // numBits
- 5, // numFracBits
---
-2.15.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 09d385947f26..8af9107a4297 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Christoph Haag <haagch@studi.informatik.uni-stuttgart.de>
# Maintainer: Laurent Carlier <lordheavym@gmail.com>
+# Maintainer: AdriƠ Cereto i MassaguƩ <ssorgatem at gmail.com>
pkgname=amdvlk-git
-pkgver=r18.0eb7396
+pkgver=r20.d62dbcc
pkgrel=1
pkgdesc="AMD's standalone Vulkan driver"
arch=(x86_64)
@@ -12,20 +13,18 @@ depends=('vulkan-icd-loader')
provides=('vulkan-amdvlk')
conflicts=('vulkan-amdvlk')
makedepends=('dri2proto' 'xorg-server-devel' 'cmake' 'python' 'git')
-source=('llvm::git+https://github.com/GPUOpen-Drivers/llvm.git#branch=amd-vulkan-master'
+source=('llvm::git+https://github.com/GPUOpen-Drivers/llvm.git#branch=amd-vulkan-dev'
'git+https://github.com/GPUOpen-Drivers/xgl.git#branch=dev'
'git+https://github.com/GPUOpen-Drivers/pal.git#branch=dev'
'git+https://github.com/GPUOpen-Drivers/AMDVLK.git#branch=dev'
- '0001-remove-linking-with-whole-archive-v2.patch'
'amdPalSettings.cfg'
- 'amd_icd64.json')
+ )
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '268528bf2c6e855707635e65ece19b179135fa8823c1a9cc01746fd9235b8139'
'5f798911bf1cbbe5a83f5ae4886107ef0d02be5753450753ae2d3fc6f80e7012'
- '39c26b6d91a8c5b42818a6cc3529b3803aba8f3a759d8eb6b682ecb027f4762c')
+ )
pkgver() {
XGL_VER=$(cd xgl; printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)")
@@ -35,7 +34,6 @@ pkgver() {
prepare() {
cd xgl
- #patch -Np1 -i ${srcdir}/0001-remove-linking-with-whole-archive-v2.patch
}
build() {
@@ -44,7 +42,7 @@ build() {
cmake -H. -Bbuilds/Release64 -DCMAKE_BUILD_TYPE=Release
cd builds/Release64
make
- msg "bulding xgl finished!"
+ msg "building xgl finished!"
}
package() {
@@ -54,7 +52,7 @@ package() {
install -m755 -d "${pkgdir}"/etc/amd
install xgl/builds/Release64/icd/amdvlk64.so "${pkgdir}"/usr/lib/
- install amd_icd64.json "${pkgdir}"/usr/share/vulkan/icd.d/
+ install AMDVLK/json/Redhat/amd_icd64.json "${pkgdir}"/usr/share/vulkan/icd.d/
install AMDVLK/LICENSE.txt "${pkgdir}"/usr/share/licenses/amdvlk-git/
install amdPalSettings.cfg "${pkgdir}"/etc/amd/
}
diff --git a/amd_icd64.json b/amd_icd64.json
deleted file mode 100644
index 4af6b89a6920..000000000000
--- a/amd_icd64.json
+++ /dev/null
@@ -1,8 +0,0 @@
-{
- "file_format_version": "1.0.0",
- "ICD": {
- "library_path": "/usr/lib/amdvlk64.so",
- "abi_versions": "0.9.0"
- }
-}
-