summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD8
-rw-r--r--crypto++.patch2
2 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28c9ad3a082e..6a22fa5765e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
# Contributor: Dario 'Dax' Vilardi <dax [at] deelab [dot] org>
# Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
pkgname=amule-dlp-git
-pkgver=2.3.2.r10451.df46c833b
-pkgrel=3
+pkgver=2.3.2.r10453.4f2254308
+pkgrel=1
pkgdesc="An eMule-like client for ed2k p2p network with DLP patch"
arch=('i686' 'x86_64')
url="https://github.com/persmule/amule-dlp"
@@ -18,14 +18,14 @@ makedepends=('git' 'boost')
optdepends=('antileech')
install=amule.install
provides=('amule' 'amule-dlp')
-source=("git+https://github.com/persmule/amule-dlp.git#commit=df46c833b41d4821129d83cf11e03ace104fc2ed"
+source=("git+https://github.com/persmule/amule-dlp.git#commit=4f22543087008d29a58a579aff2aab1262b5a5fa"
'amuled.systemd'
'amuleweb.systemd'
'crypto++.patch')
sha256sums=('SKIP'
'6dbdd1ad1c3c3d8637b8f4cbd5416f39c8e4277a2f8498577b08bf6cda8dbca9'
'f4f43b1154ddccc9036a4291a58c6715f097b171fec62ea7aead0c9d9fa654f2'
- '5627ec0fc6fcb80ad9b730a8a6a3c3279305bdd04d8f522c15f163d889f93922')
+ 'de425a5763a90d2b4302a22299a8d57e2a32bd83c6c427a012a42deaac9378a2')
pkgver() {
cd "${srcdir}/amule-dlp"
diff --git a/crypto++.patch b/crypto++.patch
index 2834630d5267..b51fee3a473b 100644
--- a/crypto++.patch
+++ b/crypto++.patch
@@ -7,7 +7,7 @@ index 3bea9fe2d..a7ae1e34c 100644
CryptoPP::RSASSA_PKCS1v15_SHA_Verifier pubkey(*static_cast<CryptoPP::RSASSA_PKCS1v15_SHA_Signer *>(m_pSignkey));
CryptoPP::ArraySink asink(m_abyMyPublicKey, 80);
- pubkey.DEREncode(asink);
-+ pubkey.AccessMaterial().Save(asink);
++ pubkey.GetMaterial().Save(asink);
m_nMyPublicKeyLen = asink.TotalPutLength();
asink.MessageEnd();
} catch (const CryptoPP::Exception& e) {