summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD82
-rw-r--r--amule.sysusers1
-rw-r--r--amule.tmpfiles1
-rw-r--r--amuled.systemd12
-rw-r--r--amuleweb.systemd13
6 files changed, 84 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce48282a2d8d..995731e1bdf8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,29 @@
-# Generated by mksrcinfo v8
-# Tue Aug 7 02:37:26 UTC 2018
pkgbase = amule-git
pkgdesc = Client for the eD2k and Kad networks
- pkgver = 2.3.2.r49.dc0f6c6f7
- pkgrel = 1
- url = http://amule.org/
- arch = i686
+ pkgver = 2.3.3.r42.e26d06a6e
+ pkgrel = 3
+ url = https://amule.org/
arch = x86_64
- license = GPL
- makedepends = autoconf
- makedepends = automake
- makedepends = boost
+ license = GPL2
makedepends = git
- makedepends = pkg-config
- depends = boost-libs
+ makedepends = boost
+ makedepends = cmake
depends = crypto++
depends = geoip
depends = libupnp
- depends = wxgtk2
+ depends = wxwidgets-gtk3
+ depends = gd
+ provides = amule
conflicts = amule
source = git+https://github.com/amule-project/amule.git
- source = https://gitlab.com/palopezv/aur-amule-git-patches/raw/master/amuled@.service
- source = https://gitlab.com/palopezv/aur-amule-git-patches/raw/master/use_xdg-open_as_preview_default.diff
- source = https://gitlab.com/palopezv/aur-amule-git-patches/raw/master/version_check.diff
+ source = amuled.systemd
+ source = amuleweb.systemd
+ source = amule.sysusers
+ source = amule.tmpfiles
sha256sums = SKIP
- sha256sums = b8ade9930c00c411958758a2f8267c0a56320270fc06b2ee15243a027795745d
- sha256sums = 902f8f719c1c02335880621717f23c683da8edbb31add75d3e1267b190e03b9c
- sha256sums = 7bf39a64a723ab3e55ccfef93df2ec9cdd8108e56aa0733a4412755931cb3244
+ sha256sums = 20ac6b60c5f3bf49c0b080dfc02409da3c9d01b154344188008c6a75ca69681e
+ sha256sums = f4f43b1154ddccc9036a4291a58c6715f097b171fec62ea7aead0c9d9fa654f2
+ sha256sums = c4ca658ab4105b3b90e0bb3efcc8121eca1c4d873787db1ed4f637925c16d502
+ sha256sums = e9d1b7019c7075b0f8616c6507a767b87de8f899936680e9ff5829d8cbba224d
pkgname = amule-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 48318ff88754..3ca6ea41f732 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,56 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: LIN Ruoshui <lin dot ruohshoei plus archlinux at gmail dot com>
+# Contributor: lukpod
+
pkgname=amule-git
-pkgver=2.3.2.r49.dc0f6c6f7
-pkgrel=1
+pkgver=2.3.3.r42.e26d06a6e
+pkgrel=3
pkgdesc="Client for the eD2k and Kad networks"
-arch=(i686 x86_64)
-url=http://amule.org/
-license=(GPL)
-depends=(boost-libs crypto++ geoip libupnp wxgtk2)
-makedepends=(autoconf automake boost git pkg-config)
+arch=(x86_64)
+url="https://amule.org/"
+license=(GPL2)
+depends=(crypto++ geoip libupnp wxwidgets-gtk3 gd)
+makedepends=(git boost cmake)
+provides=(amule)
conflicts=(amule)
-source=(
-git+https://github.com/amule-project/amule.git
-#https://anonscm.debian.org/cgit/pkg-amule/amule.git/plain/debian/patches/use_xdg-open_as_preview_default.diff
-#https://anonscm.debian.org/cgit/pkg-amule/amule.git/plain/debian/patches/version_check.diff
-https://gitlab.com/palopezv/aur-amule-git-patches/raw/master/amuled@.service
-https://gitlab.com/palopezv/aur-amule-git-patches/raw/master/use_xdg-open_as_preview_default.diff
-https://gitlab.com/palopezv/aur-amule-git-patches/raw/master/version_check.diff
-)
+source=("git+https://github.com/amule-project/amule.git"
+ #git+https://repo.or.cz/amule.git
+ amuled.systemd amuleweb.systemd amule.sysusers amule.tmpfiles)
sha256sums=('SKIP'
- 'b8ade9930c00c411958758a2f8267c0a56320270fc06b2ee15243a027795745d'
- '902f8f719c1c02335880621717f23c683da8edbb31add75d3e1267b190e03b9c'
- '7bf39a64a723ab3e55ccfef93df2ec9cdd8108e56aa0733a4412755931cb3244')
+ '20ac6b60c5f3bf49c0b080dfc02409da3c9d01b154344188008c6a75ca69681e'
+ 'f4f43b1154ddccc9036a4291a58c6715f097b171fec62ea7aead0c9d9fa654f2'
+ 'c4ca658ab4105b3b90e0bb3efcc8121eca1c4d873787db1ed4f637925c16d502'
+ 'e9d1b7019c7075b0f8616c6507a767b87de8f899936680e9ff5829d8cbba224d')
pkgver() {
- cd amule/
- git describe | sed 's/-/.r/; s/-g/./'
-}
-
-prepare() {
- cd amule/
- patch -Np1 <$srcdir/use_xdg-open_as_preview_default.diff
- patch -Np1 <$srcdir/version_check.diff
+ cd amule
+ git describe --tags | sed 's/-/.r/; s/-g/./'
}
build() {
- cd amule/
- ./autogen.sh
- local confargs=(
- --disable-debug
- --disable-rpath
- --enable-alcc
- --enable-geoip
- --enable-mmap
- --enable-optimize
- --prefix=/usr
- --with-boost
- )
- ./configure ${confargs[@]}
- make
+ cmake -B build -S amule \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_ALC=ON \
+ -DBUILD_ALCC=ON \
+ -DBUILD_AMULECMD=ON \
+ -DBUILD_CAS=ON \
+ -DBUILD_DAEMON=ON \
+ -DBUILD_REMOTEGUI=ON \
+ -DBUILD_WEBSERVER=ON \
+ -DBUILD_WXCAS=ON \
+ -DBUILD_FILEVIEW=ON \
+ -DENABLE_NLS=ON
+ cmake --build build
}
check() {
- make -C amule/ check
+ make -C build test
}
package() {
- make -C amule/ DESTDIR=$pkgdir install
+ DESTDIR="$pkgdir" cmake --install build
+ install -Dm644 "$srcdir"/amuled.systemd "$pkgdir"/usr/lib/systemd/system/amuled.service
+ install -Dm644 "$srcdir"/amuleweb.systemd "$pkgdir"/usr/lib/systemd/system/amuleweb.service
+ install -Dm644 "$srcdir"/amule.sysusers "$pkgdir"/usr/lib/sysusers.d/amule.conf
+ install -Dm644 "$srcdir"/amule.tmpfiles "$pkgdir"/usr/lib/tmpfiles.d/amule.conf
}
diff --git a/amule.sysusers b/amule.sysusers
new file mode 100644
index 000000000000..4f46b42f258a
--- /dev/null
+++ b/amule.sysusers
@@ -0,0 +1 @@
+u amule - "aMule Client" /var/lib/amule
diff --git a/amule.tmpfiles b/amule.tmpfiles
new file mode 100644
index 000000000000..7f74ba8c4416
--- /dev/null
+++ b/amule.tmpfiles
@@ -0,0 +1 @@
+d /var/lib/amule 0750 amule amule
diff --git a/amuled.systemd b/amuled.systemd
new file mode 100644
index 000000000000..e4ac5713b9b7
--- /dev/null
+++ b/amuled.systemd
@@ -0,0 +1,12 @@
+[Unit]
+Description=aMule Daemon
+After=network.target
+
+# This assumes that a user 'amule' exists, with a writeable home directory
+[Service]
+User=amule
+ExecStart=/usr/bin/amuled
+NoNewPrivileges=true
+
+[Install]
+WantedBy=multi-user.target
diff --git a/amuleweb.systemd b/amuleweb.systemd
new file mode 100644
index 000000000000..1799f4ae88c0
--- /dev/null
+++ b/amuleweb.systemd
@@ -0,0 +1,13 @@
+[Unit]
+Description=aMule Webserver
+Requires=amuled.service
+
+[Service]
+User=amule
+ExecStart=/usr/bin/amuleweb --quiet
+# If amuled still starting then amuleweb exits, restart until amuleweb is up
+Restart=on-success
+RestartSec=3s
+
+[Install]
+WantedBy=multi-user.target