summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD14
3 files changed, 28 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 971ae31ba13e..e8ffe552402d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,22 @@
pkgbase = amxb-inspect-git
pkgdesc = Ambiorix Backend inspector/validation tool
- pkgver = v0.1.3.r0.g649600c
+ pkgver = 1.2.0.r0.gc244343
pkgrel = 1
url = https://gitlab.com/soft.at.home/ambiorix/applications/amxb-inspect.git
- arch = any
- license = MIT
+ arch = x86_64
+ arch = i686
+ arch = i486
+ arch = pentium4
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = BSD
+ makedepends = git
depends = lib_amxb
provides = amxb-inspect
conflicts = amxb-inspect
- source = amxb-inspect-git::git+https://gitlab.com/soft.at.home/ambiorix/applications/amxb-inspect.git#branch=master
+ source = amxb-inspect-git::git+https://gitlab.com/soft.at.home/ambiorix/applications/amxb-inspect.git#branch=main
md5sums = SKIP
pkgname = amxb-inspect-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c5db8d949c6b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Ignore everything
+*
+# Allow PKGBUILD
+!PKGBUILD
+# Allow .SRCINFO
+!.SRCINFO
+# allow .gitignore
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index afe0b7e7d70b..7fe272befaec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: fenrig <fenrig.linux at outlook.com>
pkgname=amxb-inspect-git
-pkgver=v0.1.3.r0.g649600c
+pkgver=1.2.0.r0.gc244343
pkgrel=1
pkgdesc="Ambiorix Backend inspector/validation tool"
-arch=('any')
+arch=("x86_64" "i686" "i486" "pentium4" "arm" "armv6h" "armv7h" "aarch64")
url="https://gitlab.com/soft.at.home/ambiorix/applications/amxb-inspect.git"
-license=('MIT')
+license=(BSD)
depends=(
'lib_amxb'
)
makedepends=(
+ 'git'
)
provides=(
'amxb-inspect'
@@ -19,14 +20,14 @@ conflicts=(
'amxb-inspect'
)
-gitbranch="master"
+gitbranch="main"
source=("${pkgname}::git+https://gitlab.com/soft.at.home/ambiorix/applications/amxb-inspect.git#branch=${gitbranch}")
md5sums=('SKIP')
pkgver() {
cd "${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -36,5 +37,6 @@ build() {
package() {
cd "${pkgname}"
- make DEST="${pkgdir}/" install
+ make DEST="${pkgdir}/" LIBDIR="/usr/lib" install
+ install -D LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}