summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f689d9394a1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = amxb-inspect-git
+ pkgdesc = Generic C-implementation for Ambiorix Backend library
+ pkgver = v0.1.0.r0.g7d71696
+ pkgrel = 1
+ url = https://gitlab.com/soft.at.home/ambiorix/applications/amxb-inspect.git
+ arch = any
+ license = MIT
+ depends = lib_amxb
+ provides = amxb-inspect
+ conflicts = amxb-inspect
+ source = amxb-inspect-git::git+https://gitlab.com/soft.at.home/ambiorix/applications/amxb-inspect.git#branch=master
+ md5sums = SKIP
+
+pkgname = amxb-inspect-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d8d3cc5bf0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: fenrig <fenrig.linux at outlook.com>
+pkgname=amxb-inspect-git
+pkgver=v0.1.0.r0.g7d71696
+pkgrel=1
+pkgdesc="Generic C-implementation for Ambiorix Backend library"
+arch=('any')
+url="https://gitlab.com/soft.at.home/ambiorix/applications/amxb-inspect.git"
+license=('MIT')
+
+depends=(
+ 'lib_amxb'
+)
+makedepends=(
+)
+provides=(
+ 'amxb-inspect'
+)
+conflicts=(
+ 'amxb-inspect'
+)
+
+gitbranch="master"
+
+source=("${pkgname}::git+https://gitlab.com/soft.at.home/ambiorix/applications/amxb-inspect.git#branch=${gitbranch}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DEST="${pkgdir}/" install
+}