summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD12
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c172d4d5c4c..0c7be4e4843d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,24 @@
pkgbase = amxb_pcb-git
pkgdesc = PCB baapi back-end
- pkgver = v2.1.3.r0.g83c7d92
+ pkgver = 2.1.4.r0.g5c6b8a8
pkgrel = 1
url = https://gitlab.com/soft.at.home/ambiorix/modules/amxb_backends/amxb_pcb.git
- arch = any
- license = MIT
+ arch = x86_64
+ arch = i686
+ arch = i486
+ arch = pentium4
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = BSD
+ makedepends = git
depends = lib_amxc
depends = lib_amxp
depends = lib_amxd
depends = libpcb
provides = amxb_pcb
- provides = amxb_pcb-git
conflicts = amxb_pcb
- conflicts = amxb_pcb-git
source = amxb_pcb-git::git+https://gitlab.com/soft.at.home/ambiorix/modules/amxb_backends/amxb_pcb.git#branch=main
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 812256aa41ab..a045ed5188d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: fenrig <fenrig.linux at outlook.com>
pkgname=amxb_pcb-git
-pkgver=v2.1.3.r0.g83c7d92
+pkgver=2.1.4.r0.g5c6b8a8
pkgrel=1
pkgdesc="PCB baapi back-end"
-arch=('any')
+arch=("x86_64" "i686" "i486" "pentium4" "arm" "armv6h" "armv7h" "aarch64")
url="https://gitlab.com/soft.at.home/ambiorix/modules/amxb_backends/amxb_pcb.git"
-license=('MIT')
+license=(BSD)
depends=(
'lib_amxc'
@@ -14,14 +14,13 @@ depends=(
'libpcb'
)
makedepends=(
+ 'git'
)
provides=(
'amxb_pcb'
- 'amxb_pcb-git'
)
conflicts=(
'amxb_pcb'
- 'amxb_pcb-git'
)
gitbranch="main"
@@ -31,7 +30,7 @@ md5sums=('SKIP')
pkgver() {
cd "${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -42,4 +41,5 @@ build() {
package() {
cd "${pkgname}"
make DEST="${pkgdir}/" LIBDIR="/usr/lib" install
+ install -D LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}