summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD58
-rw-r--r--an-anime-game-launcher.desktop9
-rw-r--r--icon.pngbin77748 -> 76665 bytes
-rw-r--r--moe.launcher.an-anime-game-launcher.desktop8
5 files changed, 61 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd47034e55d9..8d6c0b01cffd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,27 @@
pkgbase = an-anime-game-launcher-bin
- pkgdesc = An Launcher for a specific anime game with auto-patching, discord rpc and time tracking
- pkgver = 2.3.7
- pkgrel = 1
- url = https://gitlab.com/an-anime-team/an-anime-game-launcher
+ pkgdesc = A Launcher for a specific anime game with auto-patching, discord rpc and time tracking
+ pkgver = 3.9.5
+ pkgrel = 2
+ url = https://github.com/an-anime-team/an-anime-game-launcher
arch = x86_64
license = GPL3
- depends = libayatana-appindicator
- depends = tar
- depends = unzip
+ depends = libadwaita
+ depends = xdg-desktop-portal
depends = xdelta3
- depends = cabextract
+ depends = p7zip
depends = git
- depends = curl
- depends = iputils
- depends = webkit2gtk
+ depends = gtk4
+ depends = glibc
optdepends = mangohud: FPS Hud/GUI
optdepends = gamemode: Game Optimizations
- optdepends = vkbasalt: Required to use custom shaders (install this and reshade-shaders-git)
- optdepends = reshade-shaders-git: Required by vkBasalt config files (install this and vkbasalt)
- conflicts = an-anime-game-launcher
- source = An_Anime_Game_Launcher_2.3.7.AppImage::https://gitlab.com/an-anime-team/an-anime-game-launcher/uploads/176cc0d61a94658533bb1e73bdfb7201/an-anime-game-launcher-2.3.7.AppImage
+ optdepends = gamescope: a tool from Valve that allows for games to run in an isolated Xwayland instance
+ provides = an-anime-game-launcher
+ conflicts = an-anime-game-launcher-git
+ source = an-anime-game-launcher_3.9.5::https://github.com/an-anime-team/an-anime-game-launcher/releases/download/3.9.5/anime-game-launcher
source = icon.png
- source = an-anime-game-launcher-bin.desktop
- source = an-anime-game-launcher-bin.sh
- md5sums = c7eb1782733d5032671d7e7e7b8d5b72
- md5sums = 82d75ad72aed6c6962f203f9c6f329d3
- md5sums = acb9fecb5d938c4fb8e5facb0511bc23
- md5sums = aa1d36e938b47b1f9fcff6aa5cec588b
+ source = an-anime-game-launcher.desktop
+ md5sums = 52346086d3f58474161f7a8f22be9c6e
+ md5sums = c1a5499b80a55d3d238ef5c5d2c93c99
+ md5sums = f0cfe73897e8f49e92e0dfc41326fb0b
pkgname = an-anime-game-launcher-bin
diff --git a/PKGBUILD b/PKGBUILD
index 567e14c53afc..bd249a6ab3bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,56 @@
-# Maintainer: Marie Piontek <marie@kaifa.ch>
+# Maintainer: Maxim Korotkov <maximkorotkov4@gmail.com>
+# Contributor: Marie Piontek <marie@kaifa.ch>
pkgname=an-anime-game-launcher-bin
-pkgver=2.3.7
-pkgrel=1
-pkgdesc="An Launcher for a specific anime game with auto-patching, discord rpc and time tracking"
-url="https://gitlab.com/an-anime-team/an-anime-game-launcher"
-conflicts=("an-anime-game-launcher")
+pkgver=3.9.5
+pkgrel=2
+pkgdesc="A Launcher for a specific anime game with auto-patching, discord rpc and time tracking"
+url="https://github.com/an-anime-team/an-anime-game-launcher"
+conflicts=("an-anime-game-launcher-git")
+provides=("an-anime-game-launcher")
arch=("x86_64")
license=("GPL3")
depends=(
- "libayatana-appindicator"
- "tar"
- "unzip"
+ "libadwaita"
+ "xdg-desktop-portal"
"xdelta3"
- "cabextract"
+ "p7zip"
"git"
- "curl"
- "iputils"
- "webkit2gtk"
+ "gtk4"
+ "glibc"
)
optdepends=(
"mangohud: FPS Hud/GUI"
"gamemode: Game Optimizations"
- "vkbasalt: Required to use custom shaders (install this and reshade-shaders-git)"
- "reshade-shaders-git: Required by vkBasalt config files (install this and vkbasalt)"
+ "gamescope: a tool from Valve that allows for games to run in an isolated Xwayland instance"
)
source=(
- "An_Anime_Game_Launcher_${pkgver}.AppImage::https://gitlab.com/an-anime-team/an-anime-game-launcher/uploads/176cc0d61a94658533bb1e73bdfb7201/an-anime-game-launcher-2.3.7.AppImage"
+ "an-anime-game-launcher_${pkgver}::https://github.com/an-anime-team/an-anime-game-launcher/releases/download/${pkgver}/anime-game-launcher"
"icon.png"
- "an-anime-game-launcher-bin.desktop"
- "an-anime-game-launcher-bin.sh"
+ "an-anime-game-launcher.desktop"
)
md5sums=(
- 'c7eb1782733d5032671d7e7e7b8d5b72'
- '82d75ad72aed6c6962f203f9c6f329d3'
- 'acb9fecb5d938c4fb8e5facb0511bc23'
- 'aa1d36e938b47b1f9fcff6aa5cec588b'
+ '52346086d3f58474161f7a8f22be9c6e'
+ 'c1a5499b80a55d3d238ef5c5d2c93c99'
+ 'f0cfe73897e8f49e92e0dfc41326fb0b'
)
prepare() {
- chmod +x "${srcdir}/An_Anime_Game_Launcher_${pkgver}.AppImage"
- "${srcdir}/An_Anime_Game_Launcher_${pkgver}.AppImage" --appimage-extract
+ chmod +x "${srcdir}/an-anime-game-launcher_${pkgver}"
}
package() {
- cd "squashfs-root"
install -dm755 "${pkgdir}/usr/lib/${pkgname}"
- cp -dr --no-preserve=ownership resources.neu "${pkgdir}/usr/lib/${pkgname}/"
- cp -dr --no-preserve=ownership an-anime-game-launcher "${pkgdir}/usr/lib/${pkgname}/"
- cp -dr --no-preserve=ownership public "${pkgdir}/usr/lib/${pkgname}/"
+ install -dm755 "${pkgdir}/usr/bin/"
+ cp an-anime-game-launcher_${pkgver} "${pkgdir}/usr/lib/${pkgname}/"
- install -Dm644 "${srcdir}/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- install -Dm755 "${srcdir}/an-anime-game-launcher-bin.sh" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "${srcdir}/an-anime-game-launcher-bin.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/icon.png" "${pkgdir}/usr/share/pixmaps/an-anime-game-launcher.png"
+ ln -s "/usr/lib/${pkgname}/an-anime-game-launcher_${pkgver}" "${pkgdir}/usr/bin/an-anime-game-launcher"
+ install -Dm644 "${srcdir}/an-anime-game-launcher.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/icon.png" "${pkgdir}/usr/share/icons/moe.launcher.an-anime-game-launcher.png"
}
+
diff --git a/an-anime-game-launcher.desktop b/an-anime-game-launcher.desktop
new file mode 100644
index 000000000000..034408612114
--- /dev/null
+++ b/an-anime-game-launcher.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=An Anime Game Launcher
+Comment=An Launcher for a specific anime game with auto-patching, discord rpc and time tracking
+Exec=an-anime-game-launcher
+Terminal=false
+Type=Application
+Icon=an-anime-game-launcher
+StartupWMClass=moe.launcher.an-anime-game-launcher
+Categories=Game
diff --git a/icon.png b/icon.png
index 89738cd2787e..3beaa2b46b73 100644
--- a/icon.png
+++ b/icon.png
Binary files differ
diff --git a/moe.launcher.an-anime-game-launcher.desktop b/moe.launcher.an-anime-game-launcher.desktop
new file mode 100644
index 000000000000..2cf3afb79677
--- /dev/null
+++ b/moe.launcher.an-anime-game-launcher.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=An Anime Game Launcher
+Comment=An Launcher for a specific anime game with auto-patching, discord rpc and time tracking
+Exec=an-anime-game-launcher
+Terminal=false
+Type=Application
+Icon=an-anime-game-launcher
+Categories=Game