summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD49
-rw-r--r--an9wer-slstatus.install9
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a4be519a434
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = an9wer-slstatus
+ pkgdesc = A status monitor for window managers that use WM_NAME or stdin to fill the status bar
+ pkgver = r552.gb14e039
+ pkgrel = 1
+ url = https://tools.suckless.org/slstatus/
+ install = an9wer-slstatus.install
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = libx11
+ depends = an9wer-suckless-rebuild>=0.1.1
+ source = slstatus::git://git.suckless.org/slstatus
+ md5sums = SKIP
+
+pkgname = an9wer-slstatus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b145295b7cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Runney Wu <an9wer@gmail.com>
+
+_commit=b14e039
+_pkgname=slstatus
+pkgname=an9wer-$_pkgname
+pkgver=r552.gb14e039
+pkgrel=1
+pkgdesc="A status monitor for window managers that use WM_NAME or stdin to fill the status bar"
+url="https://tools.suckless.org/slstatus/"
+arch=('x86_64')
+license=('MIT')
+makedepends=('git')
+depends=('libx11' 'an9wer-suckless-rebuild>=0.1.1')
+install=$pkgname.install
+source=("$_pkgname::git://git.suckless.org/slstatus")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$_pkgname"
+ cp config.def.h config.h
+}
+
+pkgver() {
+ cd "$_pkgname"
+ git checkout "$_commit" &> /dev/null
+ printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -m644 -D LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -m644 -D README "$pkgdir/usr/share/doc/$_pkgname/README"
+ # Source codes
+ install -m644 -D -t "$pkgdir/usr/src/$_pkgname" \
+ arg.h config.def.h config.mk LICENSE Makefile \
+ README slstatus.1 slstatus.c slstatus.h util.c util.h
+ cd components
+ install -m644 -D -t "$pkgdir/usr/src/$_pkgname/components" \
+ battery.c datetime.c entropy.c ip.c keyboard_indicators.c \
+ load_avg.c num_files.c run_command.c temperature.c user.c \
+ wifi.c cpu.c disk.c hostname.c kernel_release.c keymap.c \
+ netspeeds.c ram.c swap.c uptime.c volume.c
+}
diff --git a/an9wer-slstatus.install b/an9wer-slstatus.install
new file mode 100644
index 000000000000..ea0dfb18d1d5
--- /dev/null
+++ b/an9wer-slstatus.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "-- 'slstatus' has been builded with default config.h file"
+ echo "-- and after that you can rebuild it by using 'suckless-rebuild' command with any other config.h file."
+}
+
+post_upgrade() {
+ echo "-- 'slstatus' has been builded with default config.h file"
+ echo "-- and after that you can rebuild it by using 'suckless-rebuild' command with any other config.h file."
+}