summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26c3f57e2c3b..3e987bb432a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = ananicy-cpp
pkgdesc = Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage.
- pkgver = 0.2.1
+ pkgver = 0.3.1
pkgrel = 1
+ url = https://gitlab.com/aviallon/ananicy-cpp/
arch = x86_64
arch = i386
arch = armv7h
+ license = GPLv3
makedepends = cmake
makedepends = git
depends = ananicy
depends = fmt
depends = spdlog
depends = nlohmann-json
- source = git+https://gitlab.com/aviallon/ananicy-cpp.git#tag=v0.2.1
- md5sums = SKIP
+ depends = systemd
+ source = https://gitlab.com/aviallon/ananicy-cpp/-/archive/v0.3.1/ananicy-cpp-v0.3.1.tar.gz
+ md5sums = 55da67ba131d138242f10c708a69bcd6
pkgname = ananicy-cpp
diff --git a/PKGBUILD b/PKGBUILD
index f130dd859832..cd89eeafcc62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
pkgname=ananicy-cpp
-pkgver=0.2.1
+pkgver=0.3.1
pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
+url="https://gitlab.com/aviallon/ananicy-cpp/"
+license=(GPLv3)
source=(
- "git+https://gitlab.com/aviallon/ananicy-cpp.git#tag=v${pkgver}"
+ "https://gitlab.com/aviallon/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz"
)
-md5sums=(SKIP)
+md5sums=('55da67ba131d138242f10c708a69bcd6')
arch=(x86_64 i386 armv7h)
-depends=(ananicy fmt spdlog nlohmann-json)
+depends=(ananicy fmt spdlog nlohmann-json systemd)
makedepends=(cmake git)
prepare() {
- cd "$pkgname"
+ cd "$pkgname-v${pkgver}"
mkdir -p build
cd build
@@ -20,17 +22,18 @@ prepare() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_EXTERNAL_SPDLOG=ON \
-DUSE_EXTERNAL_JSON=ON \
- -DUSE_EXTERNAL_FMTLIB=ON
+ -DUSE_EXTERNAL_FMTLIB=ON \
+ -DVERSION=${pkgver}
}
build() {
- cd "$pkgname/build"
+ cd "$pkgname-v${pkgver}/build"
cmake --build .
}
package() {
- cd "$pkgname/build"
+ cd "$pkgname-v${pkgver}/build"
export DESTDIR="$pkgdir"
cmake --install .