summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b383d3522a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ananicy-cpp
+ pkgdesc = Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage.
+ pkgver = 0.1.1.1
+ pkgrel = 1
+ arch = x86_64
+ arch = i386
+ arch = armv7h
+ depends = ananicy
+ depends = fmt
+ depends = spdlog
+ depends = nlohmann-json
+ source = git+https://gitlab.com/aviallon/ananicy-cpp.git#tag=v0.1.1.1
+ md5sums = SKIP
+
+pkgname = ananicy-cpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc12643157ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=ananicy-cpp
+pkgver=0.1.1.1
+pkgrel=1
+pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
+source=(
+ "git+https://gitlab.com/aviallon/ananicy-cpp.git#tag=v${pkgver}"
+ )
+md5sums=(SKIP)
+arch=(x86_64 i386 armv7h)
+depends=(ananicy fmt spdlog nlohmann-json)
+
+prepare() {
+ cd "$pkgname"
+
+ mkdir -p build
+ cd build
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_EXTERNAL_SPDLOG=ON \
+ -DUSE_EXTERNAL_JSON=ON
+}
+
+build() {
+ cd "$pkgname/build"
+
+ cmake --build .
+}
+
+package() {
+ cd "$pkgname/build"
+
+ export DESTDIR="$pkgdir"
+ cmake --install .
+}
+