summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfdec6330f37..7562a32982f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ananicy-cpp
pkgdesc = Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage.
- pkgver = 0.4.0
+ pkgver = 0.5.0
pkgrel = 1
url = https://gitlab.com/aviallon/ananicy-cpp/
arch = x86_64
@@ -9,13 +9,13 @@ pkgbase = ananicy-cpp
license = GPLv3
makedepends = cmake
makedepends = git
- depends = ananicy
depends = fmt
depends = spdlog
depends = nlohmann-json
depends = systemd
- source = https://gitlab.com/aviallon/ananicy-cpp/-/archive/v0.4.0/ananicy-cpp-v0.4.0.tar.gz
- md5sums = 9b7c04e1881c8e60b5474d3a916d6f56
+ optdepends = ananicy
+ source = https://gitlab.com/aviallon/ananicy-cpp/-/archive/v0.5.0/ananicy-cpp-v0.5.0.tar.gz
+ md5sums = a1a3a551f8e0ce8a3b70bcd32804ec70
pkgname = ananicy-cpp
diff --git a/PKGBUILD b/PKGBUILD
index 55096c09d1af..1792ef329aa8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=ananicy-cpp
-pkgver=0.4.0
+pkgver=0.5.0
pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
url="https://gitlab.com/aviallon/ananicy-cpp/"
@@ -7,10 +7,11 @@ license=(GPLv3)
source=(
"https://gitlab.com/aviallon/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz"
)
-md5sums=('9b7c04e1881c8e60b5474d3a916d6f56')
+md5sums=('a1a3a551f8e0ce8a3b70bcd32804ec70')
arch=(x86_64 i386 armv7h)
-depends=(ananicy fmt spdlog nlohmann-json systemd)
+depends=(fmt spdlog nlohmann-json systemd)
makedepends=(cmake git)
+optdepends=(ananicy)
prepare() {
cd "$pkgname-v${pkgver}"