summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD71
2 files changed, 47 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b28bf4f5144e..6a97fd101761 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,28 @@
pkgbase = ananicy-cpp-git
pkgdesc = Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage.
- pkgver = 1.0.0.rc7.r33.g9a6987e
+ pkgver = 1.1.0.r5.gddbb795
pkgrel = 1
url = https://gitlab.com/ananicy-cpp/ananicy-cpp.git
arch = x86_64
arch = i386
arch = armv7h
+ license = GPL3
makedepends = cmake
+ makedepends = ninja
+ makedepends = clang
makedepends = git
- makedepends = gcc
+ makedepends = nlohmann-json
+ makedepends = bpf
depends = fmt
- depends = spdlog
- depends = nlohmann-json
depends = systemd
+ depends = libelf
+ depends = zlib
+ depends = libbpf
optdepends = ananicy-rules-git: community rules
optdepends = ananicy-rules: Rules based for ananicy-cpp
provides = ananicy-cpp
conflicts = ananicy-cpp
- source = git+https://gitlab.com/ananicy-cpp/ananicy-cpp.git
- source = git+https://gitlab.com/vnepogodin/std-format.git
- md5sums = SKIP
- md5sums = SKIP
+ source = ananicy-cpp::git+https://gitlab.com/ananicy-cpp/ananicy-cpp.git
+ sha512sums = SKIP
pkgname = ananicy-cpp-git
diff --git a/PKGBUILD b/PKGBUILD
index 22015204a0b3..c992ea5950fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,57 @@
# Maintainer: dr460nf1r3 <dr460nf1r3 at garudalinux dot org>
# Maintainer: Antoine Viallon <antoine@lesviallon.fr>
-pkgname=ananicy-cpp-git
_pkgname=ananicy-cpp
-pkgver=1.0.0.rc7.r33.g9a6987e
+pkgname=ananicy-cpp-git
+pkgver=1.1.0.r5.gddbb795
pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
-url="https://gitlab.com/ananicy-cpp/ananicy-cpp.git"
-source=(
- "git+https://gitlab.com/ananicy-cpp/ananicy-cpp.git"
- "git+https://gitlab.com/vnepogodin/std-format.git"
-)
-md5sums=('SKIP'
- 'SKIP')
arch=(x86_64 i386 armv7h)
-depends=(fmt spdlog nlohmann-json systemd)
-makedepends=(cmake git gcc)
-conflicts=(ananicy-cpp)
-provides=(ananicy-cpp)
+url="https://gitlab.com/ananicy-cpp/ananicy-cpp.git"
+license=('GPL3')
+depends=(fmt systemd libelf zlib libbpf)
+makedepends=(cmake ninja clang git nlohmann-json bpf)
optdepends=("ananicy-rules-git: community rules"
"ananicy-rules: Rules based for ananicy-cpp")
+source=("${_pkgname}::git+https://gitlab.com/ananicy-cpp/ananicy-cpp.git")
+sha512sums=('SKIP')
+provides=('ananicy-cpp')
+conflicts=('ananicy-cpp')
pkgver() {
- cd "$_pkgname"
- git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd "$_pkgname"
+ cd "${srcdir}/${_pkgname}"
- git submodule init
- git config submodule."external/std-format".url "${srcdir}/std-format"
- git -c protocol.file.allow=always submodule update
-
- cmake -B build -S . \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DUSE_EXTERNAL_SPDLOG=ON \
- -DUSE_EXTERNAL_JSON=ON \
- -DUSE_EXTERNAL_FMTLIB=ON
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$_pkgname"
- cmake --build build --target ananicy-cpp
+ cd "${srcdir}/${_pkgname}"
+
+ _cpuCount=$(grep -c -w ^processor /proc/cpuinfo)
+
+ export CFLAGS="${CFLAGS}"
+ export CXXFLAGS="${CXXFLAGS}"
+ export LDFLAGS="${LDFLAGS}"
+
+ # disable system spdlog
+ cmake -S . -Bbuild \
+ -GNinja \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_EXTERNAL_SPDLOG=OFF \
+ -DUSE_EXTERNAL_JSON=ON \
+ -DUSE_BPF_PROC_IMPL=ON \
+ -DBPF_BUILD_LIBBPF=OFF \
+ -DUSE_EXTERNAL_FMTLIB=ON
+
+ cmake --build build --target ananicy-cpp --parallel $_cpuCount
}
package() {
- cd "$_pkgname"
- export DESTDIR="$pkgdir"
- cmake --install build --component Runtime
+ cd "${srcdir}/${_pkgname}"
+ DESTDIR="${pkgdir}" cmake --install build --component Runtime
- install -m755 -d "$pkgdir/etc/ananicy.d"
+ install -m755 -d "${pkgdir}/etc/ananicy.d"
}
+# vim:set sw=2 sts=2 et: