summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8149bbfadabb..72c935d2a911 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ananicy-cpp-git
pkgdesc = Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage.
- pkgver = 1.0.0.rc5.r0.g3ae336b
+ pkgver = 1.0.0.rc5.r10.g0adc86c
pkgrel = 1
arch = x86_64
arch = i386
@@ -16,6 +16,8 @@ pkgbase = ananicy-cpp-git
provides = ananicy-cpp
conflicts = ananicy-cpp
source = git+https://gitlab.com/ananicy-cpp/ananicy-cpp.git
+ source = git+https://gitlab.com/ananicy-cpp/stl-polyfills/std-format.git
+ md5sums = SKIP
md5sums = SKIP
pkgname = ananicy-cpp-git
diff --git a/PKGBUILD b/PKGBUILD
index df4c7d814cb2..ffa804f87bff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,14 @@
pkgname=ananicy-cpp-git
_pkgname=ananicy-cpp
-pkgver=1.0.0.rc5.r0.g3ae336b
+pkgver=1.0.0.rc5.r10.g0adc86c
pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
-source=("git+https://gitlab.com/ananicy-cpp/ananicy-cpp.git")
-md5sums=('SKIP')
+source=(
+ "git+https://gitlab.com/ananicy-cpp/ananicy-cpp.git"
+ "git+https://gitlab.com/ananicy-cpp/stl-polyfills/std-format.git"
+)
+md5sums=('SKIP' 'SKIP')
arch=(x86_64 i386 armv7h)
depends=(fmt spdlog nlohmann-json systemd)
makedepends=(cmake git gcc)
@@ -22,6 +25,11 @@ pkgver() {
prepare() {
cd "$_pkgname"
+
+ git submodule init
+ git config submodule."external/std-format".url "${srcdir}/std-format"
+ git submodule update
+
mkdir -p build
cd build
@@ -35,13 +43,13 @@ prepare() {
build() {
cd "$_pkgname/build"
- cmake --build .
+ cmake --build . --target ananicy-cpp
}
package() {
cd "$_pkgname/build"
export DESTDIR="$pkgdir"
- cmake --install .
+ cmake --install . --component Runtime
install -m755 -d "$pkgdir/etc/ananicy.d"
}