summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f34218523e1a..84c75bc32fe1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ananicy-cpp-git
pkgdesc = Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage.
- pkgver = v0.2.1.r17.g5d8f1b6
+ pkgver = 0.2.1.r18.g6e494a4
pkgrel = 1
arch = x86_64
arch = i386
diff --git a/PKGBUILD b/PKGBUILD
index 669ddb18c25f..ff184af03ea1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ananicy-cpp-git
_pkgname=ananicy-cpp
-pkgver=v0.2.1.r17.g5d8f1b6
+pkgver=0.2.1.r18.g6e494a4
pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
source=("git+https://gitlab.com/aviallon/ananicy-cpp.git")
@@ -13,10 +13,10 @@ makedepends=(cmake git gcc)
conflicts=(ananicy-cpp)
provides=(ananicy-cpp)
-pkgver() {
- cd "${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/^v-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
prepare() {
cd "$_pkgname"