summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD82
-rw-r--r--ancestris.desktop8
-rw-r--r--ancestris.install35
-rw-r--r--ancestris.pngbin2679 -> 69122 bytes
5 files changed, 40 insertions, 116 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2993f8a24495..222fb932418d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,17 @@
-# Generated by mksrcinfo v7
-# Mon Oct 12 17:08:54 UTC 2015
pkgbase = ancestris
- pkgdesc = Ancestris is a genealogy program written in Java
- pkgver = 0.8
+ pkgdesc = Unlimited family tree freeware
+ pkgver = 12
pkgrel = 1
- url = http://ancestris.org/
- install = ancestris.install
+ url = https://www.ancestris.org
arch = any
- license = CDDL
- license = GPL
- depends = java-environment
- depends = ttf-font
- depends = libxtst
- depends = giflib
- depends = atk
- provides = ancestris
- source = http://www.ancestris.org/mw/mw-base/compteur_dl.php?/dl/pub/ancestris/releases/ancestris_0.8-0-20150521.zip
- source = ancestris.install
+ license = GPL3
+ optdepends = java-runtime
+ options = !strip
+ source = https://www.ancestris.org/compteur_dl.php?/dl/pub/ancestris/dev/ancestris-latest.zip
source = ancestris.desktop
source = ancestris.png
- md5sums = 4307e7badb913ae304793043a791230a
- md5sums = 4252d135a228c77f49a651225c037e07
- md5sums = 2d23096eea04659d55dc6d45fb57cc37
- md5sums = bae346ed409e57d174386cd7db583ff5
+ sha256sums = SKIP
+ sha256sums = 1f6cba5d8edf2787fd6ed74c84d18dadfcf1969598ea9fe20616da82bf81a07a
+ sha256sums = 70d8af54533990c66543574aff0657383349275464dc9804b15ca94c5e50142d
pkgname = ancestris
-
diff --git a/PKGBUILD b/PKGBUILD
index efd042aa14ec..e30eb50a9781 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,29 @@
-# Maintainer : Ste74 <capitani74atgmaildotcom>
-# Maintainer : lemovice <lemovice-at-ancestris-dot-org>
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+# Contributor : Stefano Capitani <stefanoatmanjarodotorg>
+# Contributor : lemovice <lemovice-at-ancestris-dot-org>
-pkgname=ancestris
-pkgver=0.9
+pkgname="ancestris"
+pkgver=12
pkgrel=1
-_date=20161221
-pkgdesc='Ancestris is a genealogy program written in Java'
-arch=('any')
-url='http://ancestris.org/'
-license=('CDDL' 'GPL')
-
-depends=('java-environment' 'ttf-font' 'libxtst' 'giflib' 'atk')
-#options=('!strip')
-source=("$url/mw/mw-base/compteur_dl.php?/dl/pub/$pkgname/releases/${pkgname}_${pkgver}-0-${_date}.zip"
-'ancestris.desktop'
-'ancestris.png')
-
-md5sums=('b0e31a340bebb676f6f6679a055c1185'
- '2d23096eea04659d55dc6d45fb57cc37'
- 'bae346ed409e57d174386cd7db583ff5')
-DLAGENTS=('ftp::/usr/bin/curl -fC - --ftp-pasv --retry 3 --retry-delay 3 -o %o %u'
- 'http::/usr/bin/curl -A "Mozilla/4.0" -fLC - --retry 3 --retry-delay 3 -o %o %u'
- 'https::/usr/bin/curl -A "Mozilla/4.0" -fLC - --retry 3 --retry-delay 3 -o %o %u'
- 'rsync::/usr/bin/rsync --no-motd -z %u %o'
- 'scp::/usr/bin/scp -C %u %o')
-
-
-build() {
- # cleanup OS specific files
- rm $(find -name '*\.exe' -or -name '*\.bat')
-# rm -r $(find -name 'MacOSX*' -or -name 'Windows*' -or -name 'SunOS*')
-# rm -r $(find -name 'hpux*' -or -name 'mac*' -or -name 'solaris*' -or -name 'windows*')
- # Remove 64 bits files on an i686 system else stripping fails
- if [ `uname -m` = 'i686' ]; then
- rm -rf $(find -name '*64*')
- rm -rf $(find -name '*x64*')
- rm -rf $(find -name 'Linux-x86_64')
- fi
- if [ `uname -m` = 'x86_64' ]; then
- rm -rf $(find -name '*86*')
- fi
+pkgdesc="Unlimited family tree freeware"
+url="https://www.ancestris.org"
+license=("GPL3")
+arch=("any")
+optdepends=("java-runtime")
+source=("$url/compteur_dl.php?/dl/pub/ancestris/dev/ancestris-latest.zip"
+ "ancestris.desktop"
+ "ancestris.png")
+sha256sums=("SKIP" # rolling release
+ "1f6cba5d8edf2787fd6ed74c84d18dadfcf1969598ea9fe20616da82bf81a07a"
+ "70d8af54533990c66543574aff0657383349275464dc9804b15ca94c5e50142d")
+options=("!strip")
+
+package(){
+ # create missing directories
+ install -d -m 755 "$pkgdir/opt" "$pkgdir/usr/share/"{applications,pixmaps}
+ # copy program files
+ cp -r "ancestris" "$pkgdir/opt"
+ # copy desktop entry files
+ install -D -m 644 "ancestris.desktop" "$pkgdir/usr/share/applications/ancestris.desktop"
+ install -D -m 644 "ancestris.png" "$pkgdir/usr/share/pixmaps/ancestris.png"
}
-
-package() {
- install -d ${pkgdir}/usr/share/java
- cp -r ${pkgname} ${pkgdir}/usr/share/java
-
- install -d ${pkgdir}/usr/bin
- ln -s /usr/share/java/${pkgname}/bin/${pkgname} ${pkgdir}/usr/bin/${pkgname}
-
- install -d ${pkgdir}/usr/share/applications
- install -m644 /$srcdir/${pkgname}.desktop ${pkgdir}/usr/share/applications
-
- install -d ${pkgdir}/usr/share/pixmaps
- install -m644 $srcdir/${pkgname}.png ${pkgdir}/usr/share/pixmaps
-}
-
-# vim:set ts=2 sw=2 et:
diff --git a/ancestris.desktop b/ancestris.desktop
index 485994fb0aff..803365f2841c 100644
--- a/ancestris.desktop
+++ b/ancestris.desktop
@@ -1,9 +1,9 @@
[Desktop Entry]
+Encoding=UTF-8
Name=Ancestris
-Comment=Ancestris
+Comment=Unlimited family tree freeware
+Exec=/opt/ancestris/bin/ancestris
Icon=ancestris
-Exec=ancestris
Terminal=false
Type=Application
-Categories=Office;
-StartupNotify=true
+Categories=Office;X-Genealogy;
diff --git a/ancestris.install b/ancestris.install
deleted file mode 100644
index e986c260b89f..000000000000
--- a/ancestris.install
+++ /dev/null
@@ -1,35 +0,0 @@
-# This is a default template for a post-install scriptlet. You can
-# remove any functions you don't need (and this header).
-
-# arg 1: the new package version
-pre_install() {
- /bin/true
-}
-
-# arg 1: the new package version
-post_install() {
- update-desktop-database >/dev/null 2>&1
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-pre_upgrade() {
- /bin/true
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- update-desktop-database >/dev/null 2>&1
-}
-
-# arg 1: the old package version
-pre_remove() {
- /bin/true
-}
-
-# arg 1: the old package version
-post_remove() {
- update-desktop-database >/dev/null 2>&1
-}
-
diff --git a/ancestris.png b/ancestris.png
index 2be0e280aa12..8005d88064fd 100644
--- a/ancestris.png
+++ b/ancestris.png
Binary files differ