summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Exclude-qmltime-when-cross-compiling.patch12
-rw-r--r--PKGBUILD6
-rw-r--r--PKGBUILD.sh.ep2
-rw-r--r--qtdeclarative-sha256.txt2
5 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a646770a6bf6..ac92f8cbc386 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = android-aarch64-qt6-declarative
pkgdesc = Classes for QML and JavaScript languages (android)
- pkgver = 6.3.0
+ pkgver = 6.3.1
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -24,9 +24,9 @@ pkgbase = android-aarch64-qt6-declarative
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.3/6.3.0/submodules/qtdeclarative-everywhere-src-6.3.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/6.3/6.3.1/submodules/qtdeclarative-everywhere-src-6.3.1.tar.xz
source = 0001-Exclude-qmltime-when-cross-compiling.patch
- sha256sums = d294b029dc2b2d4f65da516fdc3b8088d32643eb7ff77db135a8b9ce904caa37
- sha256sums = d10e2d89c38460d9f356aeca7033e510f5110885207283a1934dfbd7d1b5aebf
+ sha256sums = 03e7694123820fcca397f95ce312e0b7f3039493c8754c836da098a1a04346e8
+ sha256sums = 572cf6af00c733aa7e7c5ec72ce522b5a640e89e27ab3f6c93debcaf335fa31c
pkgname = android-aarch64-qt6-declarative
diff --git a/0001-Exclude-qmltime-when-cross-compiling.patch b/0001-Exclude-qmltime-when-cross-compiling.patch
index 84dd4abd2923..5f263d3fe6bb 100644
--- a/0001-Exclude-qmltime-when-cross-compiling.patch
+++ b/0001-Exclude-qmltime-when-cross-compiling.patch
@@ -1,4 +1,4 @@
-From 45eccd359a9a11e87e8cc627bef27b8501490f49 Mon Sep 17 00:00:00 2001
+From 306826507f0814b1da3e119dde347ca9086a0571 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 5 Feb 2021 02:22:45 +0100
Subject: [PATCH] Exclude qmltime when cross compiling
@@ -14,10 +14,10 @@ That's likely also why upstream did not notice this problem so far.
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
-index c12152343d..88b7c33e83 100644
+index 48545ff2d2..dafcad8a2e 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
-@@ -35,7 +35,9 @@ if(QT_FEATURE_qml_preview AND QT_FEATURE_thread AND NOT ANDROID AND NOT WASM AND
+@@ -33,7 +33,9 @@ if(QT_FEATURE_qml_preview AND QT_FEATURE_thread AND NOT ANDROID AND NOT WASM AND
endif()
if(QT_BUILD_SHARED_LIBS AND QT_FEATURE_thread AND TARGET Qt::Quick AND NOT ANDROID AND NOT WASM AND NOT IOS AND NOT rtems)
add_subdirectory(qmlscene)
@@ -26,8 +26,8 @@ index c12152343d..88b7c33e83 100644
+ add_subdirectory(qmltime)
+ endif()
endif()
- if(QT_BUILD_SHARED_LIBS AND QT_FEATURE_process AND QT_FEATURE_regularexpression AND QT_FEATURE_thread AND TARGET Qt::Quick AND NOT ANDROID AND NOT WASM AND NOT rtems)
- add_subdirectory(qmlplugindump)
+ if(QT_BUILD_SHARED_LIBS
+ AND QT_FEATURE_process
--
-2.35.1
+2.36.1
diff --git a/PKGBUILD b/PKGBUILD
index 0e9a587c0904..845501c1ce7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_android_arch=aarch64
pkgname=android-$_android_arch-qt6-declarative
-_qtver=6.3.0
+_qtver=6.3.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -23,8 +23,8 @@ groups=(android-${_android_arch}-qt6)
_pkgfqn="qtdeclarative-everywhere-src-${_qtver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
'0001-Exclude-qmltime-when-cross-compiling.patch')
-sha256sums=('d294b029dc2b2d4f65da516fdc3b8088d32643eb7ff77db135a8b9ce904caa37'
- 'd10e2d89c38460d9f356aeca7033e510f5110885207283a1934dfbd7d1b5aebf')
+sha256sums=('03e7694123820fcca397f95ce312e0b7f3039493c8754c836da098a1a04346e8'
+ '572cf6af00c733aa7e7c5ec72ce522b5a640e89e27ab3f6c93debcaf335fa31c')
prepare () {
cd $_pkgfqn
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 76df7d214c7a..ac16e24e2ddc 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -1,6 +1,6 @@
% layout 'android-qt6-module', has_binaries => 1;
\
-_qtver=6.3.0
+_qtver=6.3.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
diff --git a/qtdeclarative-sha256.txt b/qtdeclarative-sha256.txt
index 71fcdccfb010..f0f33fa284e4 100644
--- a/qtdeclarative-sha256.txt
+++ b/qtdeclarative-sha256.txt
@@ -1 +1 @@
-d294b029dc2b2d4f65da516fdc3b8088d32643eb7ff77db135a8b9ce904caa37
+03e7694123820fcca397f95ce312e0b7f3039493c8754c836da098a1a04346e8