summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--0001-Exclude-qmltime-when-cross-compiling.patch33
-rw-r--r--PKGBUILD18
-rw-r--r--PKGBUILD.sh.ep2
-rw-r--r--qtdeclarative-sha256.txt2
5 files changed, 55 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25539e4cb04b..47af942b4c37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = android-aarch64-qt6-declarative
pkgdesc = Classes for QML and JavaScript languages (android)
- pkgver = 6.1.0
+ pkgver = 6.1.1
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -20,8 +20,9 @@ pkgbase = android-aarch64-qt6-declarative
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.1/6.1.0/submodules/qtdeclarative-everywhere-src-6.1.0.tar.xz
- sha256sums = e6f64314b8d54d7b541f52827b4e795317b17c3b7f39ad5210b8dbf343b75bda
+ source = https://download.qt.io/official_releases/qt/6.1/6.1.1/submodules/qtdeclarative-everywhere-src-6.1.1.tar.xz
+ source = 0001-Exclude-qmltime-when-cross-compiling.patch
+ sha256sums = 805394307479ebca9899996af8357037c4f1ff8b783162ade0c5a05cea7ee2d2
+ sha256sums = ea1049987eb2c00190e794c678781e20c95cbff03eba698875de35258894a3a7
pkgname = android-aarch64-qt6-declarative
-
diff --git a/0001-Exclude-qmltime-when-cross-compiling.patch b/0001-Exclude-qmltime-when-cross-compiling.patch
new file mode 100644
index 000000000000..4215bd2f1960
--- /dev/null
+++ b/0001-Exclude-qmltime-when-cross-compiling.patch
@@ -0,0 +1,33 @@
+From 09f7c0b03aa26e1e7862f57bf9cc4105665ce879 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Fri, 5 Feb 2021 02:22:45 +0100
+Subject: [PATCH] Exclude qmltime when cross compiling
+
+as the build script would attempt to set the property of a target
+which does not exist (leading to a configuration error).
+
+This tool seems not really requird and is already disabled when
+compiling for Android or when compiling static libraries anyways.
+That's likely also why upstream did not notice this problem so far.
+---
+ tools/CMakeLists.txt | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
+index 8438e8c6fa..23753dd0dc 100644
+--- a/tools/CMakeLists.txt
++++ b/tools/CMakeLists.txt
+@@ -30,7 +30,9 @@ if(QT_FEATURE_qml_preview AND QT_FEATURE_thread AND NOT ANDROID AND NOT WASM AND
+ endif()
+ if(QT_BUILD_SHARED_LIBS AND QT_FEATURE_thread AND TARGET Qt::Quick AND NOT ANDROID AND NOT WASM AND NOT rtems)
+ add_subdirectory(qmlscene)
+- add_subdirectory(qmltime)
++ if(NOT CMAKE_CROSSCOMPILING)
++ add_subdirectory(qmltime)
++ endif()
+ endif()
+ if(QT_BUILD_SHARED_LIBS AND QT_FEATURE_process AND QT_FEATURE_regularexpression AND QT_FEATURE_thread AND TARGET Qt::Quick AND NOT ANDROID AND NOT WASM AND NOT rtems)
+ add_subdirectory(qmlplugindump)
+--
+2.32.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 8949506371cd..59d3486e116b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_android_arch=aarch64
pkgname=android-$_android_arch-qt6-declarative
-_qtver=6.1.0
+_qtver=6.1.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -18,8 +18,20 @@ optdepends=('qt6-declarative: development tools')
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(android-${_android_arch}-qt6)
_pkgfqn="qtdeclarative-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('e6f64314b8d54d7b541f52827b4e795317b17c3b7f39ad5210b8dbf343b75bda')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Exclude-qmltime-when-cross-compiling.patch')
+sha256sums=('805394307479ebca9899996af8357037c4f1ff8b783162ade0c5a05cea7ee2d2'
+ 'ea1049987eb2c00190e794c678781e20c95cbff03eba698875de35258894a3a7')
+
+prepare () {
+ cd $_pkgfqn
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ msg2 "Applying patch $patch"
+ patch -p1 -i "$patch"
+ done
+}
build() {
source android-env ${_android_arch}
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index bcbfe04652ea..bca06351e6c3 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -1,6 +1,6 @@
% layout 'android-qt6-module', has_binaries => 1;
\
-_qtver=6.1.0
+_qtver=6.1.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
diff --git a/qtdeclarative-sha256.txt b/qtdeclarative-sha256.txt
index 7a994d190955..7d9ef17ac2f4 100644
--- a/qtdeclarative-sha256.txt
+++ b/qtdeclarative-sha256.txt
@@ -1 +1 @@
-e6f64314b8d54d7b541f52827b4e795317b17c3b7f39ad5210b8dbf343b75bda
+805394307479ebca9899996af8357037c4f1ff8b783162ade0c5a05cea7ee2d2