summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--PKGBUILD.sh.ep2
3 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67a5315bb883..c50d1f53fed0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = android-aarch64-qt6-svg
makedepends = android-cmake
makedepends = qt6-base
makedepends = ninja
- makedepends = java-environment-openjdk>=11
+ makedepends = java-environment-openjdk=17
depends = android-aarch64-qt6-base
options = !strip
options = !buildflags
diff --git a/PKGBUILD b/PKGBUILD
index 3de2af7893a6..96dda2cd3c10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='Classes for displaying the contents of SVG files (android)'
depends=('android-aarch64-qt6-base')
-makedepends=('android-cmake' 'qt6-base' 'ninja' 'java-environment-openjdk>=11')
+makedepends=('android-cmake' 'qt6-base' 'ninja' 'java-environment-openjdk=17')
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(android-${_android_arch}-qt6)
_pkgfqn="qtsvg-everywhere-src-${_qtver}"
@@ -21,6 +21,7 @@ source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/subm
sha256sums=('5a231d59ef1b42bfbaa5174d4ff39f8e1b4ba070ef984a70b069b4b2576d8181')
build() {
+ export PATH=/usr/lib/jvm/java-17-openjdk/bin:$PATH
source android-env ${_android_arch}
android-${_android_arch}-cmake -G Ninja -B build-$_android_arch -S $_pkgfqn \
-DCMAKE_FIND_ROOT_PATH="${ANDROID_PREFIX}" \
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 98c9c99cec77..67a32aa50db3 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -8,4 +8,4 @@ url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='Classes for displaying the contents of SVG files (android)'
depends=(<%== qt6deps qw(base) %>)
-makedepends=('android-cmake<%== $static_suffix %>' 'qt6-base' 'ninja' 'java-environment-openjdk>=11')
+makedepends=('android-cmake<%== $static_suffix %>' 'qt6-base' 'ninja' 'java-environment-openjdk=17')