summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9400af06eb74..d17b09923245 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = android-aarch64-xz
- pkgdesc = Library and command line tools for XZ and LZMA compressed files (android)
- pkgver = 5.2.4
+ pkgdesc = Library and command line tools for XZ and LZMA compressed files (Android aarch64)
+ pkgver = 5.6.1
pkgrel = 3
url = https://tukaani.org/xz
arch = any
@@ -8,13 +8,15 @@ pkgbase = android-aarch64-xz
license = GPL
license = LGPL
makedepends = android-configure
+ makedepends = android-sdk-build-tools
+ makedepends = po4a
+ makedepends = doxygen
depends = android-ndk
options = !strip
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://tukaani.org/xz/xz-5.2.4.tar.gz
- sha256sums = b512f3b726d3b37b6dc4c8570e137b9311e7552e8ccbab4d39d47ce5f4177145
+ source = https://github.com/tukaani-project/xz/archive/refs/tags/v5.6.1.tar.gz
+ md5sums = b873d65db3e66157bf382a0fa9f90b7e
pkgname = android-aarch64-xz
-
diff --git a/PKGBUILD b/PKGBUILD
index 63c529dbcbbb..161a2fd721c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,31 @@
_android_arch=aarch64
pkgname=android-${_android_arch}-xz
-pkgver=5.2.4
+pkgver=5.6.1
pkgrel=3
-pkgdesc="Library and command line tools for XZ and LZMA compressed files (android)"
arch=('any')
+pkgdesc="Library and command line tools for XZ and LZMA compressed files (Android ${_android_arch})"
url="https://tukaani.org/xz"
license=('custom' 'GPL' 'LGPL')
depends=('android-ndk')
+makedepends=('android-configure'
+ 'android-sdk-build-tools'
+ 'po4a'
+ 'doxygen')
options=(!strip !buildflags staticlibs !emptydirs)
-makedepends=('android-configure')
-source=("${url}/xz-${pkgver}.tar.gz")
-sha256sums=('b512f3b726d3b37b6dc4c8570e137b9311e7552e8ccbab4d39d47ce5f4177145')
+source=("https://github.com/tukaani-project/xz/archive/refs/tags/v${pkgver}.tar.gz")
+md5sums=('b873d65db3e66157bf382a0fa9f90b7e')
prepare() {
+ cd "${srcdir}/xz-${pkgver}"
source android-env ${_android_arch}
+
check_ndk_version_ge_than 18.0
+ ./autogen.sh
}
build() {
- cd "${srcdir}"/xz-${pkgver}
+ cd "${srcdir}/xz-${pkgver}"
source android-env ${_android_arch}
android-${_android_arch}-configure \
@@ -32,12 +38,11 @@ build() {
--disable-lzma-links \
--disable-scripts \
--disable-doc
-
make $MAKEFLAGS
}
package() {
- cd "${srcdir}"/xz-${pkgver}
+ cd "${srcdir}/xz-${pkgver}"
source android-env ${_android_arch}
make DESTDIR="$pkgdir" install