summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD15
2 files changed, 21 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20a1188c8fe9..d958185eb304 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = android-ndk-beta
pkgdesc = Android C/C++ developer kit (beta)
- pkgver = r24_beta2
+ pkgver = r26_beta1
pkgrel = 1
url = https://developer.android.com/ndk/
install = android-ndk-beta.install
@@ -8,19 +8,24 @@ pkgbase = android-ndk-beta
license = GPL
license = LGPL
license = custom
- depends = glibc
depends = bash
- optdepends = ncurses5-compat-libs: for using gdb
- optdepends = python2: various helper scripts
+ depends = glibc
+ depends = gcc-libs
+ depends = zlib
+ optdepends = ncurses5-compat-libs: for curses module in bundled Python
+ optdepends = bzip2: for bz2 module in bundled Python
+ optdepends = libxcrypt-compat: for crypt module in bundled Python
optdepends = python: various helper scripts
+ optdepends = perl: various helper scripts
+ optdepends = libc++: for some LLVM components
options = !strip
options = staticlibs
backup = etc/profile.d/android-ndk-beta.sh
- source = android-ndk-beta-r24_beta2.zip::https://dl.google.com/android/repository/android-ndk-r24-beta2-linux.zip
+ source = android-ndk-beta-r26_beta1.zip::https://dl.google.com/android/repository/android-ndk-r26-beta1-linux.zip
source = android-ndk-beta.sh
- sha1sums = 78f3006243c0bc051c7c7bfb939689032e7c41ba
+ sha1sums = fb5e34313766764d9654b04603e69af813b18799
sha1sums = b0a3c3d4e148c1049f9c8b12f2632840630ea4db
- sha256sums = 379c862f23f9d6a4c475ea54cb2fef67bdeacd4de20749892bd3bf2494b3f790
+ sha256sums = 0d5591dbcc6f5435b6dc4145f5a3c7db832007dede15aba9991bd81ad2324491
sha256sums = a39422d48174302e1ee27f07031f20adc78224d12c17a5451129a88b47c901c1
pkgname = android-ndk-beta
diff --git a/PKGBUILD b/PKGBUILD
index 571eeb7588da..e7d030f6912d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=android-ndk-beta
_pkgname=${pkgname/-beta*/}
-pkgver=r24_beta2
+pkgver=r26_beta1
pkgrel=1
pkgdesc='Android C/C++ developer kit (beta)'
arch=('x86_64')
@@ -14,18 +14,21 @@ license=('GPL' 'LGPL' 'custom')
options=('!strip' 'staticlibs')
backup=("etc/profile.d/$pkgname.sh")
install="$pkgname.install"
-depends=('glibc' 'bash')
+depends=('bash' 'glibc' 'gcc-libs' 'zlib')
optdepends=(
- 'ncurses5-compat-libs: for using gdb'
- 'python2: various helper scripts'
+ 'ncurses5-compat-libs: for curses module in bundled Python'
+ 'bzip2: for bz2 module in bundled Python'
+ 'libxcrypt-compat: for crypt module in bundled Python'
'python: various helper scripts'
+ 'perl: various helper scripts'
+ 'libc++: for some LLVM components'
)
source=("$pkgname-$pkgver.zip"::"https://dl.google.com/android/repository/${_pkgname}-${pkgver/_/-}-linux.zip"
"$pkgname.sh")
# SHA1 sums is kept to follow upstream releases https://github.com/android-ndk/ndk/issues/673
-sha1sums=('78f3006243c0bc051c7c7bfb939689032e7c41ba'
+sha1sums=('fb5e34313766764d9654b04603e69af813b18799'
'b0a3c3d4e148c1049f9c8b12f2632840630ea4db')
-sha256sums=('379c862f23f9d6a4c475ea54cb2fef67bdeacd4de20749892bd3bf2494b3f790'
+sha256sums=('0d5591dbcc6f5435b6dc4145f5a3c7db832007dede15aba9991bd81ad2324491'
'a39422d48174302e1ee27f07031f20adc78224d12c17a5451129a88b47c901c1')
package() {