summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD45
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25f386839578
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = android-riscv64-libnghttp3
+ pkgdesc = HTTP/3 library written in C (Android riscv64)
+ pkgver = 1.8.0
+ pkgrel = 1
+ url = https://github.com/ngtcp2/nghttp3
+ arch = any
+ groups = android-libnghttp3
+ license = MIT
+ makedepends = android-cmake
+ depends = android-ndk
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://github.com/ngtcp2/nghttp3/releases/download/v1.8.0/nghttp3-1.8.0.tar.xz
+ md5sums = febaa2d6d1bf9105a4804df2db29becc
+
+pkgname = android-riscv64-libnghttp3
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5b03b115225
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
+*.tar.bz2
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1b04be1e518
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: kpcyrd <kpcyrd[at]archlinux[dot]org>
+# Contributor: Christian Hesse <eworm@archlinux.org>
+
+_android_arch=riscv64
+
+pkgname=android-${_android_arch}-libnghttp3
+pkgver=1.8.0
+pkgrel=1
+arch=('any')
+pkgdesc="HTTP/3 library written in C (Android ${_android_arch})"
+url='https://github.com/ngtcp2/nghttp3'
+license=('MIT')
+groups=('android-libnghttp3')
+depends=('android-ndk')
+makedepends=('android-cmake')
+options=(!strip !buildflags staticlibs !emptydirs)
+source=("https://github.com/ngtcp2/nghttp3/releases/download/v${pkgver}/nghttp3-${pkgver}.tar.xz")
+md5sums=('febaa2d6d1bf9105a4804df2db29becc')
+
+prepare() {
+ cd "${srcdir}/nghttp3-${pkgver}"
+ source android-env ${_android_arch}
+
+ autoreconf -i
+}
+
+build() {
+ cd "${srcdir}/nghttp3-${pkgver}"
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-configure \
+ --enable-lib-only
+ make $MAKEFLAGS
+}
+
+package() {
+ cd "${srcdir}/nghttp3-${pkgver}"
+ source android-env ${_android_arch}
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/${ANDROID_PREFIX_SHARE}"
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}/${ANDROID_PREFIX_LIB}"/*.so
+ ${ANDROID_STRIP} -g "${pkgdir}/${ANDROID_PREFIX_LIB}"/*.a
+}