summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce1bb762b0fe..c6e8f975f00e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Oct 11 00:28:59 UTC 2017
+# Thu Oct 19 23:41:32 UTC 2017
pkgbase = android-sdk-ant
pkgdesc = Apache Ant build scripts and libraries for the Android SDK
pkgver = 25.2.5
- pkgrel = 1
+ pkgrel = 2
url = https://developer.android.com/studio/releases/sdk-tools.html
arch = any
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index fdcf0e7dafef..17c87d324d60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
pkgname=android-sdk-ant
pkgver=25.2.5
-pkgrel=1
+pkgrel=2
pkgdesc='Apache Ant build scripts and libraries for the Android SDK'
arch=('any')
url='https://developer.android.com/studio/releases/sdk-tools.html'
license=('custom')
depends=('android-sdk>=25.3.0')
-source=(
- "https://dl.google.com/android/repository/tools_r${pkgver}-linux.zip"
- 'LICENSE')
-sha256sums=(
- '577516819c8b5fae680f049d39014ff1ba4af870b687cab10595783e6f22d33e'
- 'b9ee34b4522a15c244a7f90d269bde1414f1064eba9d500f8a24ba22ead0446f')
+source=("https://dl.google.com/android/repository/tools_r${pkgver}-linux.zip"
+ 'LICENSE')
+sha256sums=('577516819c8b5fae680f049d39014ff1ba4af870b687cab10595783e6f22d33e'
+ 'b9ee34b4522a15c244a7f90d269bde1414f1064eba9d500f8a24ba22ead0446f')
package() {
- LIBS=(
+ cd "${srcdir}"
+
+ local LIBS=(
'ant-tasks.jar'
'common.jar'
'emma_ant.jar'
@@ -28,13 +28,13 @@ package() {
'manifest-merger.jar'
'sdklib.jar')
- for FILE in "${srcdir}/tools/ant"/*; do
+ for FILE in "tools/ant"/*; do
install -Dm644 "$FILE" "${pkgdir}/opt/android-sdk/tools/ant/$(basename $FILE)"
done
for LIB in ${LIBS[@]}; do
- install -Dm644 "${srcdir}/tools/lib/${LIB}" "${pkgdir}/opt/android-sdk/tools/lib/${LIB}"
+ install -Dm644 "tools/lib/${LIB}" "${pkgdir}/opt/android-sdk/tools/lib/${LIB}"
done
- install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}