aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD28
-rw-r--r--android-studio.desktop2
3 files changed, 27 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd4f1e98a781..603768450309 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,23 @@
pkgbase = android-studio
- pkgdesc = A new Android development environment based on IntelliJ IDEA.
- pkgver = 2.2.0.12
+ pkgdesc = The official Android IDE (Stable branch)
+ pkgver = 2.2.1
pkgrel = 1
- url = http://developer.android.com/sdk/installing/studio.html
+ url = http://tools.android.com/
arch = i686
arch = x86_64
license = APACHE
makedepends = unzip
- depends = java-environment
- depends = python
- depends = ttf-font
- depends = lib32-fontconfig
- depends = lib32-libxrender
- depends = lib32-mesa
- optdepends = android-google-repository
- optdepends = android-platform
- optdepends = android-sdk
- optdepends = android-sdk-platform-tools
- optdepends = android-sdk-build-tools
- optdepends = android-sources
- optdepends = android-support
- optdepends = android-support-repository
- optdepends = gtk2
- optdepends = libgl
+ depends = alsa-lib
+ depends = freetype2
+ depends = libxrender
+ depends = libxtst
+ optdepends = gtk2: GTK+ look and feel
+ optdepends = libgl: emulator support
options = !strip
- source = https://dl.google.com/dl/android/studio/ide-zips/2.2.0.12/android-studio-ide-145.3276617-linux.zip
+ source = https://dl.google.com/dl/android/studio/ide-zips/2.2.1.0/android-studio-ide-145.3330264-linux.zip
source = android-studio.desktop
- sha512sums = 71310d6b9fb071fc6b9810765389a2311a62cc706cbe71b2fe466167fb2ded7ebcc2441fe49d34a2942bb79d516f6acfcba5e214e1af42c9e2bc988a28c6fb79
- sha512sums = 7c1ab152b3f26a0a4796c085bb7bf66aa4711a010910636c0c82a37609155c819b21a732fc3874b55e7d443c989c46f29d51ed54538795829c8eb835308b5aaa
+ sha1sums = 1afb54c3ba7716246ef2cd248bdddd248d1442d4
+ sha1sums = 357845775f3e2eb53c03ba96757c6b1e2c8baeb6
pkgname = android-studio
diff --git a/PKGBUILD b/PKGBUILD
index 01f5e7814db3..7e0d6092e999 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,29 @@
# Contributor: Jakub Schmidtke <sjakub-at-gmail-dot-com>
# Contributor: Christoph Brill <egore911-at-gmail-dot-com>
# Contributor: Lubomir 'Kuci' Kucera <kuci24-at-gmail-dot-com>
+# Contributor: Tad Fisher <tadfisher at gmail dot com>
pkgname=android-studio
-pkgver=2.2.0.12
+pkgver=2.2.1
+_pkgver=2.2.1.0
pkgrel=1
-_build=145.3276617
-pkgdesc="A new Android development environment based on IntelliJ IDEA."
+_build=145.3330264
+pkgdesc="The official Android IDE (Stable branch)"
arch=('i686' 'x86_64')
-url="http://developer.android.com/sdk/installing/studio.html"
+url="http://tools.android.com/"
license=('APACHE')
-depends=('java-environment' 'python' 'ttf-font')
makedepends=('unzip')
-optdepends=('android-google-repository' 'android-platform' 'android-sdk' 'android-sdk-platform-tools' 'android-sdk-build-tools' 'android-sources' 'android-support'
-'android-support-repository' 'gtk2' 'libgl')
+depends=('alsa-lib' 'freetype2' 'libxrender' 'libxtst')
+optdepends=('gtk2: GTK+ look and feel'
+ 'libgl: emulator support')
options=('!strip')
-source=("https://dl.google.com/dl/android/studio/ide-zips/$pkgver/android-studio-ide-$_build-linux.zip"
+source=("https://dl.google.com/dl/android/studio/ide-zips/$_pkgver/android-studio-ide-$_build-linux.zip"
"$pkgname.desktop")
-sha512sums=('71310d6b9fb071fc6b9810765389a2311a62cc706cbe71b2fe466167fb2ded7ebcc2441fe49d34a2942bb79d516f6acfcba5e214e1af42c9e2bc988a28c6fb79'
- '7c1ab152b3f26a0a4796c085bb7bf66aa4711a010910636c0c82a37609155c819b21a732fc3874b55e7d443c989c46f29d51ed54538795829c8eb835308b5aaa')
+sha1sums=('1afb54c3ba7716246ef2cd248bdddd248d1442d4'
+ '357845775f3e2eb53c03ba96757c6b1e2c8baeb6')
-if [[ $CARCH == "x86_64" ]]; then
- depends+=('lib32-fontconfig' 'lib32-libxrender' 'lib32-mesa')
-else
- depends+=('fontconfig' 'libxrender' 'mesa')
+if [ "$CARCH" = "i686" ]; then
+ depends+=('java-environment')
fi
package() {
diff --git a/android-studio.desktop b/android-studio.desktop
index 6468ea296896..8667d480096b 100644
--- a/android-studio.desktop
+++ b/android-studio.desktop
@@ -4,7 +4,7 @@ Type=Application
Name=Android Studio
Exec=android-studio %f
Icon=android-studio
-Comment=Develop with pleasure!
+Comment=The official Android IDE
Categories=Development;IDE;
Terminal=false
StartupNotify=true