summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD45
-rw-r--r--android-studio-beta.desktop12
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a932314cb698
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = android-studio-beta
+ pkgdesc = The Official Android IDE (Beta branch)
+ pkgver = 2.2.0b1
+ pkgrel = 1
+ url = http://tools.android.com/
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ makedepends = unzip
+ depends = alsa-lib
+ depends = freetype2
+ depends = libxrender
+ depends = libxtst
+ optdepends = gtk2: GTK+ look and feel
+ optdepends = libgl: emulator support
+ options = !strip
+ source = https://dl.google.com/dl/android/studio/ide-zips/2.2.0.7/android-studio-ide-145.3128856-linux.zip
+ source = android-studio-beta.desktop
+ sha1sums = bafb5d7029d2678e8274e24da1c7ce0a00f3a644
+ sha1sums = b61f3bf3449f79f8b15aea93414398848e5a6614
+
+pkgname = android-studio-beta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..374e90ba93d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Tad Fisher <tadfisher at gmail dot com>
+# Contributor: tilal6991 <lalitmaganti@gmail.com>
+# Contributor: danyf90 <daniele.formichelli@gmail.com>
+# Contributor: Philipp 'TamCore' B. <philipp [at] tamcore [dot] eu>
+# Contributor: Jakub Schmidtke <sjakub-at-gmail-dot-com>
+# Contributor: Christoph Brill <egore911-at-gmail-dot-com>
+# Contributor: Lubomir 'Kuci' Kucera <kuci24-at-gmail-dot-com>
+
+pkgname=android-studio-beta
+pkgver=2.2.0b1
+_pkgver=2.2.0.7
+pkgrel=1
+_build=145.3128856
+pkgdesc="The Official Android IDE (Beta branch)"
+arch=('i686' 'x86_64')
+url="http://tools.android.com/"
+license=('APACHE')
+makedepends=('unzip')
+depends=('alsa-lib' 'freetype2' 'libxrender' 'libxtst')
+optdepends=('gtk2: GTK+ look and feel'
+ 'libgl: emulator support')
+options=('!strip')
+source=("https://dl.google.com/dl/android/studio/ide-zips/$_pkgver/android-studio-ide-$_build-linux.zip"
+ "$pkgname.desktop")
+
+if [ "$CARCH" = "i686" ]; then
+ depends+=('java-environment')
+fi
+sha1sums=('bafb5d7029d2678e8274e24da1c7ce0a00f3a644'
+ 'b61f3bf3449f79f8b15aea93414398848e5a6614')
+
+package() {
+ cd $srcdir/android-studio
+
+ # application stuff
+ install -d $pkgdir/{opt/$pkgname,usr/bin}
+ cp -a bin gradle lib jre plugins $pkgdir/opt/$pkgname
+ ln -s /opt/$pkgname/bin/studio.sh $pkgdir/usr/bin/$pkgname
+
+ # starter stuff
+ install -Dm655 bin/studio.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ install -Dm655 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+
+ chmod -R ugo+rX $pkgdir/opt
+}
diff --git a/android-studio-beta.desktop b/android-studio-beta.desktop
new file mode 100644
index 000000000000..eef9adda3ebe
--- /dev/null
+++ b/android-studio-beta.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Android Studio (Beta)
+Exec=android-studio-beta %f
+Icon=android-studio-beta
+Comment=The Official Android IDE (Beta branch)
+Categories=Development;IDE;
+Terminal=false
+StartupNotify=true
+StartupWMClass=jetbrains-studio
+MimeType=application/x-extension-iml;