summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79beded9ebf6..71d2269d8721 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = android-x86-64-libsodium
- pkgdesc = P(ortable|ackageable) NaCl-based crypto library (android)
+ pkgdesc = P(ortable|ackageable) NaCl-based crypto library (Android x86-64)
pkgver = 1.0.19
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jedisct1/libsodium
arch = any
license = custom:ISC
@@ -11,7 +11,7 @@ pkgbase = android-x86-64-libsodium
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.libsodium.org/libsodium/releases/libsodium-1.0.19.tar.gz
- sha512sums = 8e9b6d796f6330e00921ce37f1b43545966094250938626ae227deef5fd1279f2fc18b5cd55e23484732a27df4d919cf0d2f07b9c2f1aa0c0ef689e668b0d439
+ source = https://github.com/jedisct1/libsodium/releases/download/1.0.19-RELEASE/libsodium-1.0.19.tar.gz
+ md5sums = 0d8e2233fc41be6d4c7ee36d5dfe9416
pkgname = android-x86-64-libsodium
diff --git a/PKGBUILD b/PKGBUILD
index 1d2a1b22400d..402819922490 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,23 +7,23 @@ _android_arch=x86-64
pkgname=android-${_android_arch}-libsodium
pkgver=1.0.19
-pkgrel=1
+pkgrel=2
arch=('any')
-pkgdesc="P(ortable|ackageable) NaCl-based crypto library (android)"
+pkgdesc="P(ortable|ackageable) NaCl-based crypto library (Android ${_android_arch})"
url="https://github.com/jedisct1/libsodium"
license=('custom:ISC')
depends=('android-ndk')
makedepends=('android-configure')
options=(!strip !buildflags staticlibs !emptydirs)
-source=("https://download.libsodium.org/libsodium/releases/libsodium-$pkgver.tar.gz")
-sha512sums=('8e9b6d796f6330e00921ce37f1b43545966094250938626ae227deef5fd1279f2fc18b5cd55e23484732a27df4d919cf0d2f07b9c2f1aa0c0ef689e668b0d439')
+source=("https://github.com/jedisct1/libsodium/releases/download/1.0.19-RELEASE/libsodium-${pkgver}.tar.gz")
+md5sums=('0d8e2233fc41be6d4c7ee36d5dfe9416')
build() {
cd "${srcdir}/libsodium-stable"
source android-env ${_android_arch}
# Platform specific patches
- case "$_android_arch" in
+ case "${_android_arch}" in
aarch64)
export CFLAGS="${CFLAGS} -march=armv8-a+crypto"
;;
@@ -40,6 +40,6 @@ package() {
source android-env ${_android_arch}
make DESTDIR="$pkgdir" install
- ${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a
- ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+ ${ANDROID_STRIP} -g "$pkgdir/${ANDROID_PREFIX_LIB}"/*.a
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}/${ANDROID_PREFIX_LIB}"/*.so
}