summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD40
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe7804730702
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = android-x86-highway
+ pkgdesc = A C++ library that provides portable SIMD/vector intrinsics (Android x86)
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/google/highway/
+ arch = any
+ license = Apache-2.0
+ license = BSD-3-Clause
+ makedepends = android-cmake
+ depends = android-ndk
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://github.com/google/highway/archive/1.1.0/highway-1.1.0.tar.gz
+ sha256sums = 354a8b4539b588e70b98ec70844273e3f2741302c4c377bcc4e81b3d1866f7c9
+
+pkgname = android-x86-highway
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5b03b115225
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
+*.tar.bz2
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa99ff728908
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Daniel Bermond <dbermond@archlinux.org>
+
+_android_arch=x86
+
+pkgname=android-${_android_arch}-highway
+pkgver=1.1.0
+pkgrel=1
+arch=('any')
+pkgdesc="A C++ library that provides portable SIMD/vector intrinsics (Android ${_android_arch})"
+url='https://github.com/google/highway/'
+license=('Apache-2.0'
+ 'BSD-3-Clause')
+depends=('android-ndk')
+makedepends=('android-cmake')
+options=(!strip !buildflags staticlibs !emptydirs)
+source=("https://github.com/google/highway/archive/${pkgver}/highway-${pkgver}.tar.gz")
+sha256sums=('354a8b4539b588e70b98ec70844273e3f2741302c4c377bcc4e81b3d1866f7c9')
+
+build() {
+ cd "${srcdir}/highway-${pkgver}"
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-cmake \
+ -S . \
+ -B build \
+ -Wno-dev \
+ -DBUILD_TESTING=OFF \
+ -DHWY_ENABLE_EXAMPLES=OFF \
+ -DHWY_ENABLE_TESTS=OFF
+ make -C build $MAKEFLAGS
+}
+
+package() {
+ cd "${srcdir}/highway-${pkgver}"
+ source android-env ${_android_arch}
+
+ make -C build DESTDIR="$pkgdir" install
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+}