summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
-rw-r--r--android-x86-pie.install17
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0d8627d5d07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = android-x86-pie
+ pkgdesc = This is a project to port Android open source project to x86 platform.
+ pkgver = r2
+ pkgrel = 1
+ url = https://www.android-x86.org/
+ install = android-x86-pie.install
+ arch = any
+ license = Apache
+ backup = android-9.0-r2/initrd.img
+ backup = android-9.0-r2/kernel
+ backup = android-9.0-r2/ramdisk.img
+ backup = android-9.0-r2/system.sfs
+
+pkgname = android-x86-pie
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..40a6e14c03b9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.*
+pkg
+src
+*.rpm
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22e1a664daa4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintaoner: Yamada Hayao <development@fascode.net>
+
+android_ver="9.0"
+android_codename="pie"
+android_revision="r2"
+pkgrel=1
+
+pkgname="android-x86-${android_codename}"
+pkgver="${android_revision}"
+pkgdesc="This is a project to port Android open source project to x86 platform."
+arch=('any')
+url="https://www.android-x86.org/"
+license=('Apache')
+depends=()
+makedepends=()
+
+install="${pkgname}.install"
+
+backup=(
+ "android-${android_ver}-${android_revision}/initrd.img"
+ "android-${android_ver}-${android_revision}/kernel"
+ "android-${android_ver}-${android_revision}/ramdisk.img"
+ "android-${android_ver}-${android_revision}/system.sfs"
+)
+
+# i686
+source_i686=(
+ "android-x86-9.0-r2.i686.rpm::https://osdn.net/projects/android-x86/downloads/71931/android-x86-9.0-r2.i686.rpm/"
+)
+md5sums_i686=('SKIP')
+
+#x86_64
+source_x86_64=(
+ "android-x86-9.0-r2.x86_64.rpm::https://osdn.net/projects/android-x86/downloads/71931/android-x86-9.0-r2.x86_64.rpm/"
+)
+md5sums_x86_64=('SKIP')
+
+
+package() {
+ install -D -m 755 "${srcdir}/usr/bin/qemu-android" "${pkgdir}/usr/bin/qemu-android-${android_codename}"
+
+ local file
+ for file in "${srcdir}/android-${android_ver}-${android_revision}/"*; do
+ install -D -m 755 "${file}" "${pkgdir}/android-${android_ver}-${android_revision}/$(basename "${file}")"
+ done
+}
diff --git a/android-x86-pie.install b/android-x86-pie.install
new file mode 100644
index 000000000000..15f1202d219f
--- /dev/null
+++ b/android-x86-pie.install
@@ -0,0 +1,17 @@
+post_install(){
+ echo -e "\n"
+ echo "===NOTE==="
+ echo "1. Please run qemu-android-pie to run from Qemu."
+ echo "2. Even if you remove this package, files such as the kernel and file system remain. Please delete it manually."
+ echo "3. Even if you update this package, files such as the kernel and file system will not be updated and new one will be installed as pacnew."
+ echo "4. We recommend that you exclude this package from upgrades in pacman.conf."
+ echo -e "\n"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}