summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--0002-Force-64-bit-atomics-usage.patch33
-rw-r--r--0002-Use-pkg-config-to-find-external-libraries.patch29
-rw-r--r--0003-Fix-neon.patch44
-rw-r--r--0003-Remove-undeclared-method-in-QtNative.patch11
-rw-r--r--PKGBUILD28
6 files changed, 69 insertions, 90 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1310ee019468..077360ff82fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = android-x86-qt5
pkgdesc = Qt 5 for Android
- pkgver = 5.14.0
+ pkgver = 5.15.2
pkgrel = 2
url = https://www.qt.io
install = android-x86-qt5.install
@@ -38,14 +38,14 @@ pkgbase = android-x86-qt5
options = !buildflags
options = staticlibs
options = !emptydirs
- source = http://download.qt-project.org/official_releases/qt/5.14/5.14.0/single/qt-everywhere-src-5.14.0.tar.xz
+ source = http://download.qt-project.org/official_releases/qt/5.15/5.15.2/single/qt-everywhere-src-5.15.2.tar.xz
source = 0001-Support-pkg-config-under-Android.patch
- source = 0002-Use-pkg-config-to-find-external-libraries.patch
- source = 0003-Fix-neon.patch
- md5sums = e7ea948ab99a2ef0726db5eac8e4fd8e
+ source = 0002-Force-64-bit-atomics-usage.patch
+ source = 0003-Remove-undeclared-method-in-QtNative.patch
+ md5sums = e1447db4f06c841d8947f0a6ce83a7b5
md5sums = 6af9dcc450ae6c69d8fddccf0680d84a
- md5sums = f0f5dda8352a675566a08fa0f863a08b
- md5sums = 656c7eec7d37854cef1763c163c1ca98
+ md5sums = f17efcb3d46afefd9d2c011301fd53c5
+ md5sums = b5e5c0d979b0f6a4dd90f32ce999965b
pkgname = android-x86-qt5
diff --git a/0002-Force-64-bit-atomics-usage.patch b/0002-Force-64-bit-atomics-usage.patch
new file mode 100644
index 000000000000..6231b8f3ce3b
--- /dev/null
+++ b/0002-Force-64-bit-atomics-usage.patch
@@ -0,0 +1,33 @@
+--- a/qtbase/src/corelib/configure.json 2020-03-27 06:49:31.000000000 -0300
++++ b/qtbase/src/corelib/configure.json 2020-04-24 19:15:38.820283504 -0300
+@@ -135,27 +135,17 @@
+ "label": "64 bit atomics",
+ "test": {
+ "tail": [
+- "void test(volatile std::atomic<std::int64_t> &a)",
++ "void test()",
+ "{",
+- " std::int64_t v = a.load(std::memory_order_acquire);",
+- " while (!a.compare_exchange_strong(v, v + 1,",
+- " std::memory_order_acq_rel,",
+- " std::memory_order_acquire)) {",
+- " v = a.exchange(v - 1);",
+- " }",
+- " a.store(v + 1, std::memory_order_release);",
+ "}"
+ ],
+ "main": [
+- "void *ptr = (void*)0xffffffc0; // any random pointer",
+- "test(*reinterpret_cast<std::atomic<std::int64_t> *>(ptr));"
++ "test();"
+ ],
+ "qmake": "CONFIG += c++11"
+ },
+- "headers": [ "atomic", "cstdint" ],
+ "sources": [
+- "",
+- "-latomic"
++ ""
+ ]
+ },
+ "librt": {
diff --git a/0002-Use-pkg-config-to-find-external-libraries.patch b/0002-Use-pkg-config-to-find-external-libraries.patch
deleted file mode 100644
index c7425333726e..000000000000
--- a/0002-Use-pkg-config-to-find-external-libraries.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/qtbase/src/gui/configure.json
-+++ b/qtbase/src/gui/configure.json
-@@ -373,6 +373,7 @@
- },
- "headers": "jpeglib.h",
- "sources": [
-+ { "type": "pkgConfig", "args": "libjpeg" },
- { "libs": "-llibjpeg", "condition": "config.msvc" },
- "-ljpeg"
- ]
-
---- a/qtimageformats/src/imageformats/configure.json 2019-11-19 11:47:49.000000000 -0300
-+++ b/qtimageformats/src/imageformats/configure.json 2019-12-19 13:32:34.905053167 -0300
-@@ -82,6 +82,7 @@
- ]
- },
- "sources": [
-+ { "type": "pkgConfig", "args": "libtiff-4" },
- "-ltiff"
- ]
- },
-@@ -112,6 +113,7 @@
- ]
- },
- "sources": [
-+ { "type": "pkgConfig", "args": "libwebp libwebpdemux libwebpmux" },
- "-lwebp -lwebpdemux -lwebpmux"
- ]
- }
diff --git a/0003-Fix-neon.patch b/0003-Fix-neon.patch
deleted file mode 100644
index 069aae3f4de6..000000000000
--- a/0003-Fix-neon.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/qtbase/src/corelib/global/qfloat16.cpp 2020-01-19 09:49:52.130475297 -0300
-+++ b/qtbase/src/corelib/global/qfloat16.cpp 2020-01-19 09:47:33.000000000 -0300
-@@ -204,7 +204,7 @@
-
- #undef f16cextern
- }
--
-+/*
- #elif defined(__ARM_FP16_FORMAT_IEEE) && defined(__ARM_NEON__)
- static inline bool hasFastF16()
- {
-@@ -229,7 +229,7 @@
- vst1q_f32(out + i, vcvt_f32_f16(vld1_f16(in_f16 + i)));
- SIMD_EPILOGUE(i, len, 3)
- out[i] = float(in_f16[i]);
--}
-+}*/
- #else
- static inline bool hasFastF16()
- {
-
---- a/qtbase/src/gui/painting/painting.pri 2019-12-07 03:27:07.000000000 -0300
-+++ b/qtbase/src/gui/painting/painting.pri 2020-01-19 10:07:08.307871293 -0300
-@@ -166,7 +166,7 @@
- DEFINES += QT_COMPILER_SUPPORTS_SSE4_1 QT_COMPILER_SUPPORTS_SSE4_2
- SOURCES += painting/qdrawhelper_sse4.cpp painting/qimagescale_sse4.cpp
- }
-- arm64-v8a {
-+ arm64-v8a | armeabi-v7a {
- SOURCES += painting/qdrawhelper_neon.cpp painting/qimagescale_neon.cpp
- HEADERS += painting/qdrawhelper_neon_p.h
- }
-
---- a/qtbase/src/gui/image/image.pri 2019-12-07 03:27:07.000000000 -0300
-+++ b/qtbase/src/gui/image/image.pri 2020-01-19 11:14:07.704965297 -0300
-@@ -97,7 +97,7 @@
- MIPS_DSPR2_ASM += image/qimage_mips_dspr2_asm.S
- } else {
- # see https://developer.android.com/ndk/guides/abis
-- arm64-v8a {
-+ arm64-v8a | armeabi-v7a {
- SOURCES += image/qimage_neon.cpp
- }
- x86 | x86_64 {
diff --git a/0003-Remove-undeclared-method-in-QtNative.patch b/0003-Remove-undeclared-method-in-QtNative.patch
new file mode 100644
index 000000000000..e67823b1f72c
--- /dev/null
+++ b/0003-Remove-undeclared-method-in-QtNative.patch
@@ -0,0 +1,11 @@
+--- a/qtbase/src/android/jar/src/org/qtproject/qt5/android/QtNative.java 2020-09-02 07:15:07.000000000 -0300
++++ b/qtbase/src/android/jar/src/org/qtproject/qt5/android/QtNative.java 2020-09-21 11:51:56.726695150 -0300
+@@ -949,8 +949,6 @@
+
+ private static void clearClipData()
+ {
+- if (Build.VERSION.SDK_INT >= 28 && m_clipboardManager != null && m_usePrimaryClip)
+- m_clipboardManager.clearPrimaryClip();
+ m_usePrimaryClip = false;
+ }
+ private static void setClipboardText(String text)
diff --git a/PKGBUILD b/PKGBUILD
index b9f3988c94f1..e3a1c2e9dd4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_android_arch=x86
pkgname=android-${_android_arch}-qt5
-pkgver=5.14.0
+pkgver=5.15.2
pkgrel=2
pkgdesc="Qt 5 for Android"
arch=('any')
@@ -65,12 +65,12 @@ _pkgfqn="qt-everywhere-src-${pkgver}"
install="${pkgname}.install"
source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:4}/${pkgver}/single/${_pkgfqn}.tar.xz"
"0001-Support-pkg-config-under-Android.patch"
- "0002-Use-pkg-config-to-find-external-libraries.patch"
- "0003-Fix-neon.patch")
-md5sums=('e7ea948ab99a2ef0726db5eac8e4fd8e'
+ "0002-Force-64-bit-atomics-usage.patch"
+ "0003-Remove-undeclared-method-in-QtNative.patch")
+md5sums=('e1447db4f06c841d8947f0a6ce83a7b5'
'6af9dcc450ae6c69d8fddccf0680d84a'
- 'f0f5dda8352a675566a08fa0f863a08b'
- '656c7eec7d37854cef1763c163c1ca98')
+ 'f17efcb3d46afefd9d2c011301fd53c5'
+ 'b5e5c0d979b0f6a4dd90f32ce999965b')
prepare() {
cd ${_pkgfqn}
@@ -80,16 +80,16 @@ prepare() {
check_android_platform
patch -Np1 -i "../0001-Support-pkg-config-under-Android.patch"
- patch -Np1 -i "../0002-Use-pkg-config-to-find-external-libraries.patch"
case "$_android_arch" in
- armv7a-eabi)
- patch -Np1 -i "../0003-Fix-neon.patch"
+ aarch64 | x86-64)
+ patch -Np1 -i "../0002-Force-64-bit-atomics-usage.patch"
;;
*)
;;
esac
+ patch -Np1 -i "../0003-Remove-undeclared-method-in-QtNative.patch"
sed -i "s/android-21/android-$ANDROID_MINIMUM_PLATFORM/g" qtbase/configure.pri
}
@@ -118,6 +118,7 @@ build() {
-examplesdir ${ANDROID_PREFIX_SHARE}/qt5/examples
-testsdir ${ANDROID_PREFIX_SHARE}/qt5/tests
-xplatform android-clang
+ --disable-rpath
-nomake tests
-nomake examples
-skip qtserialport
@@ -148,11 +149,17 @@ build() {
# Platform specific patches
case "$_android_arch" in
- x86*)
+ x86)
configue_opts+="
-no-sql-mysql
-no-sql-psql"
;;
+ x86-64)
+ configue_opts+="
+ -no-avx2
+ -no-sql-mysql
+ -no-sql-psql"
+ ;;
*)
;;
esac
@@ -174,4 +181,5 @@ package() {
find ${pkgdir}/${ANDROID_PREFIX}/plugins -type f -name 'lib*.so' -exec ${ANDROID_STRIP} -g --strip-unneeded {} \;
find ${pkgdir}/${ANDROID_PREFIX}/qml -type f -name 'lib*.so' -exec ${ANDROID_STRIP} -g --strip-unneeded {} \;
sed -i '/QMAKE_PRL_BUILD_DIR/d' ${pkgdir}/${ANDROID_PREFIX_LIB}/lib*.prl
+ cp -rvf qtbase/src/android/jar/src/org/qtproject/qt5/android/* ${pkgdir}/${ANDROID_PREFIX}/src/android/java/src/org/qtproject/qt5/android/
}