summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--0003-Fix-neon.patch44
-rw-r--r--PKGBUILD16
3 files changed, 60 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf85532bb4ae..1310ee019468 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = android-x86-qt5
pkgdesc = Qt 5 for Android
pkgver = 5.14.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.qt.io
install = android-x86-qt5.install
arch = any
@@ -41,9 +41,11 @@ pkgbase = android-x86-qt5
source = http://download.qt-project.org/official_releases/qt/5.14/5.14.0/single/qt-everywhere-src-5.14.0.tar.xz
source = 0001-Support-pkg-config-under-Android.patch
source = 0002-Use-pkg-config-to-find-external-libraries.patch
+ source = 0003-Fix-neon.patch
md5sums = e7ea948ab99a2ef0726db5eac8e4fd8e
md5sums = 6af9dcc450ae6c69d8fddccf0680d84a
md5sums = f0f5dda8352a675566a08fa0f863a08b
+ md5sums = 656c7eec7d37854cef1763c163c1ca98
pkgname = android-x86-qt5
diff --git a/0003-Fix-neon.patch b/0003-Fix-neon.patch
new file mode 100644
index 000000000000..069aae3f4de6
--- /dev/null
+++ b/0003-Fix-neon.patch
@@ -0,0 +1,44 @@
+--- a/qtbase/src/corelib/global/qfloat16.cpp 2020-01-19 09:49:52.130475297 -0300
++++ b/qtbase/src/corelib/global/qfloat16.cpp 2020-01-19 09:47:33.000000000 -0300
+@@ -204,7 +204,7 @@
+
+ #undef f16cextern
+ }
+-
++/*
+ #elif defined(__ARM_FP16_FORMAT_IEEE) && defined(__ARM_NEON__)
+ static inline bool hasFastF16()
+ {
+@@ -229,7 +229,7 @@
+ vst1q_f32(out + i, vcvt_f32_f16(vld1_f16(in_f16 + i)));
+ SIMD_EPILOGUE(i, len, 3)
+ out[i] = float(in_f16[i]);
+-}
++}*/
+ #else
+ static inline bool hasFastF16()
+ {
+
+--- a/qtbase/src/gui/painting/painting.pri 2019-12-07 03:27:07.000000000 -0300
++++ b/qtbase/src/gui/painting/painting.pri 2020-01-19 10:07:08.307871293 -0300
+@@ -166,7 +166,7 @@
+ DEFINES += QT_COMPILER_SUPPORTS_SSE4_1 QT_COMPILER_SUPPORTS_SSE4_2
+ SOURCES += painting/qdrawhelper_sse4.cpp painting/qimagescale_sse4.cpp
+ }
+- arm64-v8a {
++ arm64-v8a | armeabi-v7a {
+ SOURCES += painting/qdrawhelper_neon.cpp painting/qimagescale_neon.cpp
+ HEADERS += painting/qdrawhelper_neon_p.h
+ }
+
+--- a/qtbase/src/gui/image/image.pri 2019-12-07 03:27:07.000000000 -0300
++++ b/qtbase/src/gui/image/image.pri 2020-01-19 11:14:07.704965297 -0300
+@@ -97,7 +97,7 @@
+ MIPS_DSPR2_ASM += image/qimage_mips_dspr2_asm.S
+ } else {
+ # see https://developer.android.com/ndk/guides/abis
+- arm64-v8a {
++ arm64-v8a | armeabi-v7a {
+ SOURCES += image/qimage_neon.cpp
+ }
+ x86 | x86_64 {
diff --git a/PKGBUILD b/PKGBUILD
index 0e954dead395..b9f3988c94f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _android_arch=x86
pkgname=android-${_android_arch}-qt5
pkgver=5.14.0
-pkgrel=1
+pkgrel=2
pkgdesc="Qt 5 for Android"
arch=('any')
url='https://www.qt.io'
@@ -65,10 +65,12 @@ _pkgfqn="qt-everywhere-src-${pkgver}"
install="${pkgname}.install"
source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:4}/${pkgver}/single/${_pkgfqn}.tar.xz"
"0001-Support-pkg-config-under-Android.patch"
- "0002-Use-pkg-config-to-find-external-libraries.patch")
+ "0002-Use-pkg-config-to-find-external-libraries.patch"
+ "0003-Fix-neon.patch")
md5sums=('e7ea948ab99a2ef0726db5eac8e4fd8e'
'6af9dcc450ae6c69d8fddccf0680d84a'
- 'f0f5dda8352a675566a08fa0f863a08b')
+ 'f0f5dda8352a675566a08fa0f863a08b'
+ '656c7eec7d37854cef1763c163c1ca98')
prepare() {
cd ${_pkgfqn}
@@ -80,6 +82,14 @@ prepare() {
patch -Np1 -i "../0001-Support-pkg-config-under-Android.patch"
patch -Np1 -i "../0002-Use-pkg-config-to-find-external-libraries.patch"
+ case "$_android_arch" in
+ armv7a-eabi)
+ patch -Np1 -i "../0003-Fix-neon.patch"
+ ;;
+ *)
+ ;;
+ esac
+
sed -i "s/android-21/android-$ANDROID_MINIMUM_PLATFORM/g" qtbase/configure.pri
}