summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--0001-Fix-clang-build.patch24
-rw-r--r--0003-Fix-androiddeployqt-search-paths.patch25
-rw-r--r--PKGBUILD12
5 files changed, 44 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dae4045de664..6c821690afc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# mié nov 28 20:47:03 UTC 2018
+# mié dic 12 02:55:19 UTC 2018
pkgbase = android-x86-qt5
pkgdesc = Qt 5 for Android
- pkgver = 5.11.2
- pkgrel = 2
+ pkgver = 5.12.0
+ pkgrel = 1
url = https://www.qt.io
arch = x86_64
groups = android-qt5
@@ -19,7 +19,7 @@ pkgbase = android-x86-qt5
makedepends = fontconfig
depends = java-runtime-headless>=7
depends = apache-ant
- depends = android-ndk
+ depends = android-ndk>=r18.b
depends = android-platform-22
depends = android-sdk
depends = android-sdk-build-tools
@@ -30,14 +30,14 @@ pkgbase = android-x86-qt5
options = !buildflags
options = staticlibs
options = !emptydirs
- source = http://download.qt-project.org/official_releases/qt/5.11/5.11.2/single/qt-everywhere-src-5.11.2.tar.xz
+ source = http://download.qt-project.org/official_releases/qt/5.12/5.12.0/single/qt-everywhere-src-5.12.0.tar.xz
source = 0001-Fix-clang-build.patch
source = 0002-Disable-mapbox.patch
source = 0003-Fix-androiddeployqt-search-paths.patch
- md5sums = 152a8ade9c11fe33ff5bc95310a1bb64
- md5sums = 511eafcabe9e0c6210f1dc5e26daa5c8
+ md5sums = af569de3eb42da4457b0897e5759dc91
+ md5sums = b30076dddd0a424f8b65bf7ca765ac14
md5sums = 20d8bdd24102e9011b561b7361394728
- md5sums = 549cf284d0cea4d618ad2d49532ea2db
+ md5sums = 90141a931baac77fa608146f32414ead
pkgname = android-x86-qt5
diff --git a/.gitignore b/.gitignore
index 0a5636a9ee5f..b5bc2aa573e1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,4 @@
pkg
src
-android-*-qt5
*.tar.xz
*.tar.gz
diff --git a/0001-Fix-clang-build.patch b/0001-Fix-clang-build.patch
index 431f20e727e1..4dcb9e2d9c8c 100644
--- a/0001-Fix-clang-build.patch
+++ b/0001-Fix-clang-build.patch
@@ -1,7 +1,7 @@
---- a/qtbase/mkspecs/android-clang/qmake.conf 2018-09-13 01:25:10.000000000 -0300
-+++ b/qtbase/mkspecs/android-clang/qmake.conf 2018-09-23 15:53:19.000000000 -0300
-@@ -31,16 +31,17 @@
-
+--- a/qtbase/mkspecs/android-clang/qmake.conf 2018-12-03 08:15:26.000000000 -0300
++++ b/qtbase/mkspecs/android-clang/qmake.conf 2018-12-11 14:07:47.497103671 -0300
+@@ -31,18 +31,19 @@
+
QMAKE_CFLAGS += -gcc-toolchain $$NDK_TOOLCHAIN_PATH
QMAKE_LINK = $$QMAKE_CXX $$QMAKE_CFLAGS -Wl,--exclude-libs,libgcc.a
-QMAKE_CFLAGS += -DANDROID_HAS_WSTRING --sysroot=$$NDK_ROOT/sysroot \
@@ -12,12 +12,14 @@
- -isystem $$NDK_ROOT/sources/cxx-stl/llvm-libc++abi/include
+ -isystem $$NDK_ROOT/sources/cxx-stl/llvm-libc++abi/include \
+ -isystem $$NDK_ROOT/sysroot/usr/include
-
+
ANDROID_SOURCES_CXX_STL_LIBDIR = $$NDK_ROOT/sources/cxx-stl/llvm-libc++/libs/$$ANDROID_TARGET_ARCH
-
+
ANDROID_STDCPP_PATH = $$ANDROID_SOURCES_CXX_STL_LIBDIR/libc++_shared.so
--ANDROID_CXX_STL_LIBS = -lc++
-+ANDROID_CXX_STL_LIBS = -lc++_shared
-
- QMAKE_CFLAGS_OPTIMIZE_SIZE = -Oz
-
+
+ exists($$ANDROID_SOURCES_CXX_STL_LIBDIR/libc++.so): \
+- ANDROID_CXX_STL_LIBS = -lc++
++ ANDROID_CXX_STL_LIBS = -lc++_shared
+ else: \
+ ANDROID_CXX_STL_LIBS = $$ANDROID_SOURCES_CXX_STL_LIBDIR/libc++.so.$$replace(ANDROID_PLATFORM, "android-", "")
+
diff --git a/0003-Fix-androiddeployqt-search-paths.patch b/0003-Fix-androiddeployqt-search-paths.patch
index cf37f39ae6ab..8a49d0704229 100644
--- a/0003-Fix-androiddeployqt-search-paths.patch
+++ b/0003-Fix-androiddeployqt-search-paths.patch
@@ -1,20 +1,29 @@
---- a/qtbase/src/tools/androiddeployqt/main.cpp 2018-09-13 01:25:10.000000000 -0300
-+++ b/qtbase/src/tools/androiddeployqt/main.cpp 2018-11-28 11:01:22.654317806 -0300
-@@ -1629,7 +1629,7 @@
+--- a/qtbase/src/tools/androiddeployqt/main.cpp 2018-12-03 08:15:26.000000000 -0300
++++ b/qtbase/src/tools/androiddeployqt/main.cpp 2018-12-11 13:52:56.700766773 -0300
+@@ -1663,7 +1663,7 @@
rootPath += QLatin1Char('/');
-
+
QStringList importPaths;
- importPaths += shellQuote(options->qtInstallDirectory + QLatin1String("/qml"));
+ importPaths += shellQuote(options->qtInstallDirectory + QLatin1String("/lib/qt/qml"));
importPaths += rootPath;
for (const QString &qmlImportPath : qAsConst(options->qmlImportPaths))
importPaths += shellQuote(qmlImportPath);
-@@ -1760,7 +1760,7 @@
+@@ -1758,7 +1758,7 @@
+ fprintf(stdout, " -- Appending dependency found by qmlimportscanner: %s\n", qPrintable(fileName.absolutePath));
+
+ // Put all imports in default import path in assets
+- fileName.relativePath.prepend(QLatin1String("qml/"));
++ fileName.relativePath.prepend(QLatin1String("lib/qt/qml/"));
+ options->qtDependencies.append(fileName);
+
+ if (fileName.absolutePath.endsWith(QLatin1String(".so"))) {
+@@ -1794,7 +1794,7 @@
return false;
-
+
// Jam in the dependencies of the platform plugin, since the application will crash without it
- if (!readDependenciesFromElf(options, options->qtInstallDirectory + QLatin1String("/plugins/platforms/android/libqtforandroid.so"), &usedDependencies, &remainingDependencies))
+ if (!readDependenciesFromElf(options, options->qtInstallDirectory + QLatin1String("/lib/qt/plugins/platforms/android/libqtforandroid.so"), &usedDependencies, &remainingDependencies))
return false;
-
- QString qtDir = options->qtInstallDirectory + QLatin1Char('/');
+
+ while (!remainingDependencies.isEmpty()) {
diff --git a/PKGBUILD b/PKGBUILD
index 38b4f5412b36..d2feeda81af5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,8 +27,8 @@ if [ -z "${ANDROID_SDK_ROOT}" ]; then
fi
pkgname=android-${_android_arch}-qt5
-pkgver=5.11.2
-pkgrel=2
+pkgver=5.12.0
+pkgrel=1
pkgdesc="Qt 5 for Android"
arch=('x86_64')
url='https://www.qt.io'
@@ -43,7 +43,7 @@ makedepends=('libgl'
'fontconfig')
depends=('java-runtime-headless>=7'
'apache-ant'
- 'android-ndk'
+ 'android-ndk>=r18.b'
"android-platform-$ANDROID_MINIMUM_PLATFORM"
'android-sdk'
'android-sdk-build-tools'
@@ -80,10 +80,10 @@ source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:4}/${pkg
"0001-Fix-clang-build.patch"
"0002-Disable-mapbox.patch"
"0003-Fix-androiddeployqt-search-paths.patch")
-md5sums=('152a8ade9c11fe33ff5bc95310a1bb64'
- '511eafcabe9e0c6210f1dc5e26daa5c8'
+md5sums=('af569de3eb42da4457b0897e5759dc91'
+ 'b30076dddd0a424f8b65bf7ca765ac14'
'20d8bdd24102e9011b561b7361394728'
- '549cf284d0cea4d618ad2d49532ea2db')
+ '90141a931baac77fa608146f32414ead')
_pref=/opt/android-libs/$_android_arch