summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
-rw-r--r--andyetitmovesdemo.desktop10
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8710cac48bef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = andyetitmoves-demo
+ pkgdesc = physics-based platform game (demo)
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = http://www.andyetitmoves.net/
+ arch = i686
+ arch = x86_64
+ license = custom:shareware
+ depends = mesa
+ depends = libxft
+ depends = sdl_image
+ depends = libtheora
+ depends = libvorbis
+ depends = openal
+ depends = libpng12
+ options = !strip
+ source = andyetitmovesdemo.desktop
+ md5sums = 32794af11a18207c0fc1ce5fbd26e30c
+
+pkgname = andyetitmoves-demo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a48e6bf9fc1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: jose <jose1711 [at] gmail (dot) com>
+
+pkgname=andyetitmoves-demo
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="physics-based platform game (demo)"
+arch=('i686' 'x86_64')
+url="http://www.andyetitmoves.net/"
+license=("custom:shareware")
+source=("andyetitmovesdemo.desktop")
+depends=("mesa" "libxft" "sdl_image" "libtheora" "libvorbis" "openal" "libpng12")
+md5sums=('32794af11a18207c0fc1ce5fbd26e30c')
+options=('!strip')
+
+[ "$CARCH" = "i686" ] && source=(${source[@]} "http://www.andyetitmoves.net/demo/andyetitmovesDemo-"$pkgver"_i386.tar.gz")
+[ "$CARCH" = "x86_64" ] && source=(${source[@]} "http://www.andyetitmoves.net/demo/andyetitmovesDemo-"$pkgver"_x86_64.tar.gz")
+[ "$CARCH" = "i686" ] && md5sums=(${md5sums[@]} '93176476d2be3065d2f1fa3b79852702')
+[ "$CARCH" = "x86_64" ] && md5sums=(${md5sums[@]} '47ab38352a95f79d84446dc78aaa7e76')
+
+build() {
+true
+}
+
+package() {
+ cd $srcdir/AndYetItMovesDemo
+ mkdir -p $pkgdir/usr/{share/AndYetItMovesDemo,bin}
+ /bin/tar cf - * | ( cd ../../pkg/usr/share/AndYetItMovesDemo/; tar xfp - )
+ ln -s /usr/share/AndYetItMovesDemo/AndYetItMovesDemo $pkgdir/usr/bin/AndYetItMovesDemo
+ install -D -m644 icons/48x48.png $pkgdir/usr/share/pixmaps/andyetitmovesdemo.png
+ install -D -m644 $srcdir/andyetitmovesdemo.desktop $pkgdir/usr/share/applications/andyetitmovesdemo.desktop
+}
diff --git a/andyetitmovesdemo.desktop b/andyetitmovesdemo.desktop
new file mode 100644
index 000000000000..37a7f3c8d4d6
--- /dev/null
+++ b/andyetitmovesdemo.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=And Yet It Moves (demo)
+Comment=A physics-based platform game
+Exec=AndYetItMovesDemo
+Icon=/usr/share/pixmaps/andyetitmovesdemo.png
+Terminal=false
+Type=Application
+Categories=Game;LogicGame;
+StartupNotify=true