summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD40
2 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ea1f30f1d11..23aca03448fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = animewatch-pyqt5
pkgdesc = An Audio/Video Manager and Front End for mpv/mplayer with special emphasis on Anime Collection
- pkgver = 4.0.0
+ pkgver = 4.2.0
pkgrel = 0
arch = any
license = GPL3
@@ -27,8 +27,8 @@ pkgbase = animewatch-pyqt5
depends = wget
conflicts = animewatch-pyqt4
conflicts = animewatch-pyqt5.git
- source = https://github.com/kanishka-linux/AnimeWatch/releases/download/v4.0.0-0/AnimeWatch-4.0.0-0.tar.bz2
- md5sums = d1800eaf96a49897c224eb1e551abec9
+ source = https://github.com/kanishka-linux/AnimeWatch/releases/download/v4.2.0-0/AnimeWatch-4.2.0-0.tar.bz2
+ md5sums = a19669de2b29db59d3e9959ad7a652dd
pkgname = animewatch-pyqt5
diff --git a/PKGBUILD b/PKGBUILD
index 5c60a2da1a5d..9e1a5ab20936 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
pkgname=animewatch-pyqt5
_pkgname=AnimeWatch
-pkgver=4.0.0
+pkgver=4.2.0
pkgrel=0
pkgdesc="An Audio/Video Manager and Front End for mpv/mplayer with special emphasis on Anime Collection"
arch=(any)
conflicts=('animewatch-pyqt4' 'animewatch-pyqt5.git')
license=('GPL3')
depends=('python' 'qt5-webengine' 'python-pyqt5' 'python-pycurl' 'python-urllib3' 'curl' 'libnotify' 'python-dbus' 'libtorrent-rasterbar'
- 'python-beautifulsoup4' 'python-psutil' 'python-pillow' 'python-lxml' 'mpv' 'mplayer' 'ffmpegthumbnailer' 'sqlite3' 'python-pytaglib'
- 'youtube-dl' 'wget')
+ 'python-beautifulsoup4' 'python-psutil' 'python-pillow' 'python-lxml' 'mpv' 'mplayer' 'ffmpegthumbnailer' 'sqlite3' 'python-pytaglib'
+ 'youtube-dl' 'wget')
#optdepends=('livestreamer' 'youtube-dl' 'wget')
makedepends=('git')
#source=("git+https://github.com/kanishka-linux/AnimeWatch.git")
source=("https://github.com/kanishka-linux/${_pkgname}/releases/download/v${pkgver}-${pkgrel}/${_pkgname}-${pkgver}-${pkgrel}.tar.bz2")
-md5sums=('d1800eaf96a49897c224eb1e551abec9')
+md5sums=('a19669de2b29db59d3e9959ad7a652dd')
_gitname=AnimeWatch-PyQt5
@@ -26,22 +26,22 @@ package() {
install -d "${pkgdir}/usr/share/${_pkgname}/Plugins/"
install -d "${pkgdir}/usr/share/applications/"
install -d "${pkgdir}/usr/bin/"
-
+
for file in "${_bpath}/"*;do
- nm=$(echo $file | rev | cut -d'/' -f1 | rev)
- if [ -d "$file" ];then
- if [ $nm == 'Plugins' ];then
- _plugin_path="$file/"
- for plugins in "${_plugin_path}"*;do
- plugin_name=$(echo $plugins | rev | cut -d'/' -f1 | rev)
- if [ plugin_name != 'installPlugins.py' ];then
+ nm=$(echo $file | rev | cut -d'/' -f1 | rev)
+ if [ -d "$file" ];then
+ if [ $nm == 'Plugins' ];then
+ _plugin_path="$file/"
+ for plugins in "${_plugin_path}"*;do
+ plugin_name=$(echo $plugins | rev | cut -d'/' -f1 | rev)
+ if [ plugin_name != 'installPlugins.py' ];then
echo $plugins
echo 'Plugins copying'
install -Dm755 "$plugins" "${pkgdir}/usr/share/${_pkgname}/Plugins/"
- fi
- done
- fi
- else
+ fi
+ done
+ fi
+ else
if [ $nm == 'AnimeWatch.desktop' ];then
echo $file
echo 'desktop file copying'
@@ -51,14 +51,14 @@ package() {
echo 'anime-watch script'
install -Dm755 "$file" "${pkgdir}/usr/bin/anime-watch"
chmod +x "${pkgdir}/usr/bin/anime-watch"
- else
+ else
if [ $nm != 'install.py' ];then
echo $file
echo 'source files copying'
install -Dm755 "$file" "${pkgdir}/usr/share/${_pkgname}/"
fi
fi
- fi
- done
-
+ fi
+done
+
}