summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD47
-rwxr-xr-xair-generic-launcher.sh15
-rw-r--r--eula.txt165
4 files changed, 244 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3415017f6c54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = anodyne-hib
+ pkgdesc = A top-down action-adventure game
+ pkgver = 1.508
+ pkgrel = 2
+ url = http://www.anodynegame.com/
+ arch = any
+ license = custom
+ depends = adobe-air-sdk
+ source = hib://Anodyne_1_508_Linux-1378683147.zip
+ source = air-generic-launcher.sh
+ source = eula.txt
+ md5sums = 35d5911b9e14e31153767dd983df50f7
+ md5sums = f179eaa5e6e6674b1853cf826fc33c3a
+ md5sums = b9cfbd29fb8a1d605e193311b778d7d8
+
+pkgname = anodyne-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbf2a491a4e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Yaohan Chen <yaohan.chen@gmai.com>
+pkgname=anodyne-hib
+pkgdesc='A top-down action-adventure game'
+url=http://www.anodynegame.com/
+license=('custom')
+pkgver=1.508
+pkgrel=2
+arch=(any)
+depends=('adobe-air-sdk')
+source=(hib://Anodyne_1_508_Linux-1378683147.zip
+ air-generic-launcher.sh
+ eula.txt)
+md5sums=('35d5911b9e14e31153767dd983df50f7'
+ 'f179eaa5e6e6674b1853cf826fc33c3a'
+ 'b9cfbd29fb8a1d605e193311b778d7d8')
+
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+package() {
+ _installdir=/opt/anodyne/share
+
+ cd $srcdir
+ install -Dm755 air-generic-launcher.sh $pkgdir/$_installdir/air-generic-launcher.sh
+ mv linux/share/META-INF $pkgdir/$_installdir
+ mv linux/share/Anodyne.swf $pkgdir/$_installdir
+
+ install -d $pkgdir/usr/bin/
+ ln -s $_installdir/air-generic-launcher.sh $pkgdir/usr/bin/anodyne
+
+ install -Dm644 linux/share/icons/IntraAIR32.png $pkgdir/usr/share/pixmaps/anodyne.png
+
+ install -d $pkgdir/usr/share/applications/
+ cat > $pkgdir/usr/share/applications/anodyne.desktop <<EOF
+[Desktop Entry]
+Name=Anodyne
+Comment=Anodyne
+GenericNAme=Anodyne
+Exec=/usr/bin/anodyne
+Type=Application
+Terminal=false
+Icon=anodyne
+StartupNotify=true
+Categories=Game;
+EOF
+
+ install -Dm644 eula.txt $pkgdir/usr/share/licenses/anodyne/eula.txt
+}
diff --git a/air-generic-launcher.sh b/air-generic-launcher.sh
new file mode 100755
index 000000000000..5271757d3b10
--- /dev/null
+++ b/air-generic-launcher.sh
@@ -0,0 +1,15 @@
+#!/bin/bash
+
+# This is a generic launcher script for AIR applications on Arch Linux
+
+SCRIPT_PATH=`readlink -f $0`
+SCRIPT_DIR=`dirname $SCRIPT_PATH`
+BASE_DIR=`readlink -f $SCRIPT_DIR/..`
+
+if [ "`uname -m`" == "x86_64" ]; then
+ export GTK_PATH=/usr/lib32/gtk-2.0
+ export G_FILENAME_ENCODING=UTF-8
+fi
+
+/opt/adobe-air-sdk/bin/adl -nodebug $BASE_DIR/share/META-INF/AIR/application.xml $BASE_DIR/share -- $*
+
diff --git a/eula.txt b/eula.txt
new file mode 100644
index 000000000000..57164fcadc00
--- /dev/null
+++ b/eula.txt
@@ -0,0 +1,165 @@
+END USER LICENSE AGREEMENT
+
+Important notice to end user:
+
+This is the End User License Agreement (EULA) for "Anodyne". Please read
+through this document carefully. By copying, installing, downloading, or
+otherwise using this game software, you agree that you understand accept, and
+comply with the terms set forth below. Failure to comply with these terms may
+result in enforcement actions against you.
+
+This EULA is the binding legal agreement between you, the individual end user
+("you"), and Analgesic Productions LLC ("Analgesic Productions", "we", "us"), a
+Limited Liability Company, for the download, purchase, and use of the game
+"Anodyne" ("Game"). For purposes of this Agreement the "Game" means
+collectively the interactive video game client "Anodyne" and all applicable
+clint software (including, among other things, installer softare, the game
+client, launcher software, and download management software) that you will or
+have installed on your computer, including all printed materials, digital or
+electronic documentation obtained by you through our website, http://
+www.anodynegame.com/, or by any other distribution channels now known or
+hereafter devised, regardless of the legal standing of that distributor.
+LLIICCEENNSSEE
+
+Analgesic Productions owns all international copyrights in and to the Game
+including but not limited to, all images, code, graphics, data files, game
+elements, trade secrets, proprietary technology, sound effects, story, and
+dialogue. We prohibit any copying, reproduction, and circumvention of
+technology of the Game beyond the terms of this license. The Game is licensed
+to you, as opposed to being sold or assigned to you, and your continued legal
+use of the Game is contingent upon your compliance with this EULA.
+
+Upon payment of applicable license fees, we hereby grant you the non-exclusive,
+non-transferrable, revocable, and limited right to license one copy of the Game
+for your personal, non-commercial use.
+Unless given prior written permission from Analgesic Productions, you may not
+modify, distribute, transmit, display, perform, reproduce (except for one
+archival and backup copy as permitted by applicable laws), publish, license,
+create derivative works from, adapt, translate, sublicense, auction, rent,
+lease or sell all or any part of the Game. Notwithstanding the foregoing, if
+you are the proprietor of an Internet cafe or public gaming room, you may
+operate the Software in a pay-for-play environment, provided that all computers
+used have their own valid and individually licensed copy of the Game installed,
+such Game having been purchased digitally through our website or any other
+distribution mediums existing or hereafter devised. All rights not expressly
+granted are reserved by Us. You agree that you have no interest, monetary or
+otherwise, in any feature, content, or intellectual property contained in the
+Game.
+Absent a valid distribution Agreement between you and Analgesic Productions
+LLC, you may not make the Game available on any third party network, FTP,
+internet website, torrent site, file-sharing service, intranet, or "cloud"
+whereby individuals other than you may download and install the Game. You
+further agree that you will not link to any such third party network, torrent,
+FTP, file-sharing service, intranet, or "cloud" that is not legally owned by
+Analgesic Productions LLC or its distributors.
+You agree that Analgesic Productions LLC may collect personally identifiable
+information from you for purposes related to your use of our products and
+services and that some personally identifiable information provided by you may
+be stored outside the country in which you reside. More info on our privacy
+policy _h_e_r_e.
+We may make available, or authorize others to make available, both official and
+fan/end-user created localization files of the original game subject to the
+terms and conditions set forth in this EULA. These additional files are
+considered Game Assets and are subject to the same license restrictions set
+forth herein. Lawful purchasers of the original Game who elect to enable
+localized versions of the Game are bound to the terms of this EULA regardless
+of whether this EULA itself is localized.
+
+DISCLAIMER:
+
+All characters, events, and portrayals contained in the Game are purely
+fictional and any resemblance to real events or real individuals whether alive
+or dead is purely coincidental. We do not claim any rights or interest in or to
+existing trademarks, trade names, personalities or likenesses that may
+incidentally resemble an existing product, service, or person.
+
+LLIIMMIITTAATTIIOONN OOFF LLIIAABBIILLIITTYY::
+
+All Information, Content, Services, And Material Available In The Game And
+Software Are Provided On An "As Is" Basis. To The Full Extent Applicable By
+Law, We Disclaim Any Warranties Or Representations Of Any Kind, Express Or
+Implied, Including Any Warranty Of Merchantability Or Fitness For A Particular
+Purpose. We Do Not Warrant The Non-Infringement Of Intellectual Property or
+Proprietary Rights.
+Your Purchase And Use Of The Game Is Done So At Your Own Risk. We Do Not
+Warrant That Your Ability To Play The Game Will Be Timely, Secure,
+Uninterrupted, Or Defect-Free. In No Event Will Analgesic Productions LLC
+(Including Its Officers, Directors, Employees, Or Agents) Nor Its Affiliates Be
+Liable For Direct, Indirect, Incidental, Special, Exemplary, Or Consequential
+Damages (Including But Not Limited To Lost Profits, Loss Of Business,
+Procurement Of Substitute Goods Or Services, Loss Of Use Or Loss Of Data, Or
+Business Interruption) However Caused And On Any Theory Of Liability, Whether
+In Contract, Strict Liability, Or Tort Arising In Any Way Out Of Purchase Or
+Use Of The Game.
+In Addition, Analgesic Productions LLC And Its Licensors And Distributors
+Disclaim Any And All Warranties With Respect To The Privacy And Integrity Of
+The Computer Resources You Use To Operate The Software. Neither We Nor Our
+Licensors Or Distributors Shall Be Liable For Any Disruptions, Delays Or Other
+Omissions In Any Connection, Data Exchange Or Other Interaction That You May
+Experience When You Use The Game. Neither We Nor Our Licensors Or Distributors
+Shall Be Responsible For The Conduct Of Any Users Or Computers That Connect,
+Exchange Data, Or Otherwise Interact With You Or Your Computer As A Result Of
+Your Use Of The Game.
+Analgesic Productions LLC Is Not Responsible For Any End User Generated Content
+Such As Mods Or Fan-Produced Localizations Of The Game. Your Use Of Any
+Modified Or Fan-Localized Version Of The Game Is Done At Your Sole Risk. We Are
+Not Responsible For The Cessation Of Any Part Of The Game Due To The
+Implementation Of Any Mod Or Localization.
+
+DISPUTE RESOLUTION POLICY:
+
+You agree to follow this Agreement's dispute resolution policy as set forth
+below in connection with any potential claims or disputes arising from your
+purchase and use of the Game:
+
+Informal Negotiations. Parties to a dispute concerning this Agreement or
+purchase and use of the Game will attempt to informally negotiate a potential
+settlement or resolution to the dispute;
+Online Arbitration. In the event that informal negotiations are unsuccessful,
+the parties agree to follow the American Arbitration Association.s online
+arbitration procedures to resolve the dispute.
+Binding Arbitration. If for any reason online arbitration is unsuccessful or
+unavailable to the parties, parties agree to submit to binding arbitration in
+the jurisdiction of Chicago, Illinois.
+
+Our failure to enforce at any time any of the provisions of this EULA or
+related agreements shall in no way be construed to be a present or future
+waiver of such provisions, nor in any way affect the right of any party to
+enforce each and every such provision. The express waiver by Analgesic
+Productions LLC of any provision, condition or requirement of this EULA or
+related agreements shall not constitute a waiver of any future obligation to
+comply with such provision, condition or requirement. Notwithstanding anything
+else in this EULA, no default, delay or failure to perform on the part of
+Analgesic Productions LLC shall be considered a breach of this EULA if such
+default, delay or failure to perform is shown to be due to causes beyond our
+reasonable control.
+
+MISCELLANEOUS PROVISIONS:
+
+Jurisdiction and Choice of Law. The validity, interpretation, and performance
+of this EULA are governed and controlled by the laws and regulations of the
+state of Illinois. In the event of a dispute you agree to submit to the
+personal and exclusive jurisdiction of the State and Federal Courts of Chicago,
+Illinois.
+Severability. If any portion of this EULA is found invalid by any competent
+Court of Law, the invalidity will not affect other provisions or applications
+of the remainder of this EULA which can be given effect without the invalid
+portion.
+Notification of Changes to this Agreement. We may from time to time change this
+Agreement. You agree that notification to you of these changes will be
+effective upon posting those notifications and changes on the Defender.s Quest
+web site.
+Prior Versions. This EULA, including our Privacy Policy, constitutes the full
+understanding of your agreement with us. Any prior versions of this document
+have no effect on this Agreement.
+Assignment. This EULA, including our Privacy Policy, may be assigned by
+Analgesic Productions LLC to any third party at our sole discretion by
+acquisition of the Game assets or company, or by merger.
+Legal Fees. In the event that either party is required to obtain the assistance
+of an attorney in order to enforce the terms of this Agreement, the Party
+prevailing in such an enforcement action will be entitled to recovery of all
+reasonable attorney.s fees in connection with such action.
+
+_P_r_i_v_a_c_y_ _P_o_l_i_c_y
+
+May 1st, 2013 by Sean Hogan