summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b2afdd91eb7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = anopa
+ pkgdesc = init system/service manager built around s6 supervision suite
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = http://jjacky.com/anopa
+ arch = i686
+ arch = x86_64
+ license = GPL3+
+ makedepends = skalibs
+ depends = execline
+ depends = s6
+ source = http://jjacky.com/anopa/anopa-0.3.0.tar.gz
+ sha256sums = 1f1891c063b5f4fc3a0c42d1e61411c2f6d6bfb64d3b84c4295acc78af85a72a
+
+pkgname = anopa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2c66845be54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: jjacky
+pkgname=anopa
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="init system/service manager built around s6 supervision suite"
+arch=('i686' 'x86_64')
+url="http://jjacky.com/anopa"
+license=('GPL3+')
+depends=('execline' 's6')
+makedepends=('skalibs')
+source=(http://jjacky.com/$pkgname/$pkgname-$pkgver.tar.gz)
+sha256sums=('1f1891c063b5f4fc3a0c42d1e61411c2f6d6bfb64d3b84c4295acc78af85a72a')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --bindir=/usr/bin --libexecdir=/usr/lib/anopa
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: