summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile.patch37
-rwxr-xr-xPKGBUILD23
3 files changed, 56 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa23e8badf88..8594188822c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = antares-git
pkgdesc = A window manager for X
- pkgver = r113.g30e3525
+ pkgver = r164.g0ab7891
pkgrel = 1
url = https://notabug.org/Leon_Plickat/antares
arch = x86_64
@@ -11,7 +11,9 @@ pkgbase = antares-git
provides = antares
conflicts = antares
source = antares::git+https://notabug.org/Leon_Plickat/antares.git
- md5sums = SKIP
+ source = Makefile.patch
+ sha256sums = SKIP
+ sha256sums = 7eb30c4f4f32634ca286bdb6f75b1d5cb473d888ca1b7b4793ff3f6304cb9c9f
pkgname = antares-git
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..41afb9b7b039
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,37 @@
+--- a/Makefile 2019-03-12 17:31:09.000000000 +0100
++++ b/Makefile 2019-03-12 17:40:23.526521565 +0100
+@@ -1,3 +1,5 @@
++WMNAME = antares
++
+ libs = x11 xinerama cairo
+ CFLAGS = $(shell pkg-config --cflags ${libs})
+ LDFLAGS = $(shell pkg-config --libs-only-L ${libs})
+@@ -8,17 +10,23 @@
+ MANPREFIX = $(PREFIX)/share/man
+
+ all:
+- $(CC) $(CFLAGS) $(LDLIBS) -o antares src/antares.c
++ $(CC) $(CFLAGS) $(LDLIBS) -o ${WMNAME} src/antares.c
+
+ debug: CFLAGS += -g
+ debug: all
+
+ clean:
+- $(RM) antares
++ @echo cleaning
++ @rm -fv ${WMNAME}
+
+ install: all
+- install -D -m 755 antares $(BINPREFIX)/antares
+- install -D -m 644 doc/antares.1 $(MANPREFIX)/man1/antares.1
++ @echo installing executable file to ${DESTDIR}${PREFIX}/bin
++ @install -Dm755 ${WMNAME} ${DESTDIR}${PREFIX}/bin/${WMNAME}
++ @echo installing manual page to ${DESTDIR}${MANPREFIX}/man.1
++ @install -Dm644 doc/${WMNAME}.1 ${DESTDIR}${MANPREFIX}/man1/${WMNAME}.1
+
+ uninstall:
+- $(RM) $(BINPREFIX)/antares $(MANPREFIX)/man1/antares.1
++ @echo removing executable file from ${DESTDIR}${PREFIX}/bin
++ @rm -f ${DESTDIR}${PREFIX}/bin/${WMNAME}
++ @echo removing manual page from ${DESTDIR}${MANPREFIX}/man1
++ @rm -f ${DESTDIR}${MANPREFIX}/man1/${WMNAME}.1
diff --git a/PKGBUILD b/PKGBUILD
index 23e3f0a74548..dc7b6e355c23 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor:
pkgname=antares-git
-pkgver=r113.g30e3525
+pkgver=r164.g0ab7891
pkgrel=1
pkgdesc='A window manager for X'
arch=(x86_64)
@@ -12,8 +12,10 @@ depends=(cairo libxinerama)
makedepends=(git)
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-source=("${pkgname%-*}::git+${url}.git")
-md5sums=('SKIP')
+source=("${pkgname%-*}::git+${url}.git"
+ 'Makefile.patch')
+sha256sums=('SKIP'
+ '7eb30c4f4f32634ca286bdb6f75b1d5cb473d888ca1b7b4793ff3f6304cb9c9f')
pkgver() {
cd "${pkgname%-*}"
@@ -22,6 +24,7 @@ pkgver() {
prepare() {
cd "${pkgname%-*}"
+ patch -Np1 -i ../Makefile.patch
if [ -e $startdir/config.h ]; then
msg2 "using custom config.h"
@@ -29,15 +32,19 @@ prepare() {
else
msg2 "using default config.h"
fi
+
+ if [ -e $startdir/keybind_functions.c ]; then
+ msg2 "using custom keybind_functions.c"
+ cp ${startdir}/keybind_functions.c src/keybind_functions.c
+ else
+ msg2 "using default keybind_functions.c"
+ fi
}
build() {
- cd "${pkgname%-*}"
- make
+ make -C "${pkgname%-*}"
}
package() {
- cd "${pkgname%-*}"
- install -D -m 755 antares "$pkgdir"/usr/bin/antares
- install -D -m 644 doc/antares.1 "$pkgdir"/usr/share/man/man1/antares.1
+ make -C "${pkgname%-*}" PREFIX=/usr DESTDIR="$pkgdir/" install
}