summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Change-Makefile-to-enable-ccache-to-work.patch46
-rw-r--r--PKGBUILD19
3 files changed, 8 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da2542a3163f..49a1b4b831d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Tue Mar 22 05:08:04 UTC 2016
pkgbase = anura-git
pkgdesc = A fully-featured game engine, the tech behind the spectacular Frogatto & Friends.
- pkgver = 0.0.2288.g282c8b1
+ pkgver = 0.0.2460.g8e7f329
pkgrel = 1
url = https://github.com/anura-engine/anura
install = anura.install
@@ -12,7 +14,7 @@ pkgbase = anura-git
depends = libgl
depends = mesa
depends = glew
- depends = glm
+ depends = cairo
depends = sdl2
depends = sdl2_image
depends = sdl2_ttf
@@ -23,10 +25,8 @@ pkgbase = anura-git
optdepends = box2d: box2d physics
source = git+https://github.com/anura-engine/anura.git#branch=trunk
source = anura.sh
- source = 0001-Change-Makefile-to-enable-ccache-to-work.patch
md5sums = SKIP
md5sums = 15f4c03c2404bcfd7618b8f9e0c850ba
- md5sums = 63fee48f8260aa1e51f7d4ab9bdb925f
pkgname = anura-git
diff --git a/0001-Change-Makefile-to-enable-ccache-to-work.patch b/0001-Change-Makefile-to-enable-ccache-to-work.patch
deleted file mode 100644
index 54dce7897f01..000000000000
--- a/0001-Change-Makefile-to-enable-ccache-to-work.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 67e2fb107fac7370d1efc27dd4b4bbe1ffebca2e Mon Sep 17 00:00:00 2001
-From: Yaohan Chen <yaohan.chen@gmail.com>
-Date: Wed, 12 Aug 2015 19:00:22 -0400
-Subject: [PATCH 1/2] Change Makefile to enable ccache to work
-
-Replace the -MM flag not supported by ccache with -MMD which is
-supported. This also enables simplification of the compilation
-command line.
-
-See
-http://stackoverflow.com/questions/29703938/ccache-doesnt-work-with-gcc-m-flag
-http://www.microhowto.info/howto/automatically_generate_makefile_dependencies.html
----
- Makefile | 8 +-------
- 1 file changed, 1 insertion(+), 7 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 04803c8..18ff74f 100644
---- a/Makefile
-+++ b/Makefile
-@@ -137,16 +137,11 @@ INCLUDES := $(addprefix -I,$(SRC_DIR))
-
- vpath %.cpp $(SRC_DIR)
-
-+CPPFLAGS += -MMD -MP
- define cc-command
- $1/%.o: %.cpp
- @echo "Building:" $$<
- @$(CCACHE) $(CXX) $(BASE_CXXFLAGS) $(CXXFLAGS) $(CPPFLAGS) $(INC) $(INCLUDES) -c -o $$@ $$<
-- @$(CXX) $(BASE_CXXFLAGS) $(CXXFLAGS) $(CPPFLAGS) $(INC) $(INCLUDES) -MM $$< > $$@.d
-- @mv -f $$@.d $$@.d.tmp
-- @sed -e 's|.*:|$$@:|' < $$@.d.tmp > $$@.d
-- @sed -e 's/.*://' -e 's/\\$$$$//' < $$@.d.tmp | fmt -1 | \
-- sed -e 's/^ *//' -e 's/$$$$/:/' >> $$@.d
-- @rm -f $$@.d.tmp
- endef
-
- .PHONY: all checkdirs clean
-@@ -180,4 +175,3 @@ $(foreach bdir,$(BUILD_DIR),$(eval $(call cc-command,$(bdir))))
-
- # pull in dependency info for *existing* .o files
- -include $(OBJ:.o=.o.d)
--
---
-2.5.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 67981f57408f..385abca70938 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
pkgname=anura-git
-pkgver=0.0.2288.g282c8b1
+pkgver=0.0.2460.g8e7f329
pkgrel=1
pkgdesc="A fully-featured game engine, the tech behind the spectacular Frogatto & Friends."
arch=(i686 x86_64)
url="https://github.com/anura-engine/anura"
license=('GPL')
-depends=(libgl mesa glew glm sdl2 sdl2_image sdl2_ttf sdl2_mixer libpng boost-libs)
+depends=(libgl mesa glew cairo sdl2 sdl2_image sdl2_ttf sdl2_mixer libpng boost-libs)
optdepends=('frogatto-git: the default game module'
'box2d: box2d physics')
makedepends=(git boost)
source=('git+https://github.com/anura-engine/anura.git#branch=trunk'
- anura.sh
- 0001-Change-Makefile-to-enable-ccache-to-work.patch)
+ anura.sh)
md5sums=('SKIP'
- '15f4c03c2404bcfd7618b8f9e0c850ba'
- '63fee48f8260aa1e51f7d4ab9bdb925f')
+ '15f4c03c2404bcfd7618b8f9e0c850ba')
install=anura.install
_gitname=anura
@@ -32,15 +30,6 @@ pkgver() {
fi
}
-prepare() {
- cd $_gitname
-
- git apply ../0001-Change-Makefile-to-enable-ccache-to-work.patch
-
- # use system boost headers
- rm -r external/include/boost
-}
-
build() {
cd $_gitname