summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD60
-rw-r--r--anura.install16
-rw-r--r--anura.sh5
4 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7ce75239b57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = anura-git
+ pkgdesc = A fully-featured game engine, the tech behind the spectacular Frogatto & Friends.
+ pkgver = 0.0.700.g84ac3cd
+ pkgrel = 1
+ url = https://github.com/anura-engine/anura
+ install = anura.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = boost
+ depends = libgl
+ depends = mesa
+ depends = glew
+ depends = glm
+ depends = sdl2
+ depends = sdl2_image
+ depends = sdl2_ttf
+ depends = sdl2_mixer
+ depends = libpng
+ depends = boost-libs
+ optdepends = frogatto-git: the default game module
+ optdepends = box2d: box2d physics
+ source = git+https://github.com/anura-engine/anura.git
+ source = anura.sh
+ md5sums = SKIP
+ md5sums = 15f4c03c2404bcfd7618b8f9e0c850ba
+
+pkgname = anura-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58ca5592a42c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
+pkgname=anura-git
+pkgver=0.0.700.g84ac3cd
+pkgrel=1
+pkgdesc="A fully-featured game engine, the tech behind the spectacular Frogatto & Friends."
+arch=(i686 x86_64)
+url="https://github.com/anura-engine/anura"
+license=('GPL')
+depends=(libgl mesa glew glm sdl2 sdl2_image sdl2_ttf sdl2_mixer libpng boost-libs)
+optdepends=('frogatto-git: the default game module'
+ 'box2d: box2d physics')
+makedepends=(git boost)
+source=(git+https://github.com/anura-engine/anura.git
+ anura.sh)
+md5sums=('SKIP'
+ '15f4c03c2404bcfd7618b8f9e0c850ba')
+install=anura.install
+
+_gitname=anura
+
+pkgver() {
+ cd $_gitname
+ if _tag=$(git describe 2>/dev/null)
+ then
+ # Use the tag of the last commit
+ echo $_tag | sed 's|-|.|g'
+ else
+ # The project currently has no tags yet
+ echo 0.0.$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)
+ fi
+}
+
+prepare() {
+ cd $_gitname
+
+ sed -i -e 's/-lSDL2main//' Makefile
+}
+
+build() {
+ cd $_gitname
+
+ # USE_CCACHE=no to honor makepkg's ccache setting.
+ make USE_CCACHE=no
+}
+
+package() {
+ install -D -m755 anura.sh $pkgdir/usr/bin/anura-git
+ cd $_gitname
+
+ install -D -m755 anura $pkgdir/usr/lib/anura-git/anura
+
+ _installdir=$pkgdir/usr/share/anura-git
+ mkdir -p $_installdir
+ cp -r data $_installdir
+ cp -r images $_installdir
+ cp -r music $_installdir
+ cp -r modules $_installdir
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/anura.install b/anura.install
new file mode 100644
index 000000000000..2eace418cb93
--- /dev/null
+++ b/anura.install
@@ -0,0 +1,16 @@
+post_install() {
+ chgrp users /usr/share/anura-git/modules
+ chmod g+w /usr/share/anura-git/modules
+
+ cat <<EOF
+Note: By default, anura will try to launch the frogatto module, which
+ can be installed through the frogatto-git package. Use the
+ --module= option to switch module. Modules are installed in
+ /usr/share/anura-git/modules. This directory is made user writeable
+ to allow the in-game editor's "new module" command to work.
+EOF
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/anura.sh b/anura.sh
new file mode 100644
index 000000000000..47fb40059f59
--- /dev/null
+++ b/anura.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd /usr/share/anura-git
+/usr/lib/anura-git/anura $*
+