summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--fix_boost_uuid_detail_sha1_path.patch26
3 files changed, 35 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ccf32e23876..a9e15a1fc5a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri Sep 7 09:50:55 UTC 2018
pkgbase = anura-git
pkgdesc = A fully-featured game engine, the tech behind the spectacular Frogatto & Friends.
- pkgver = 0.0.3587.g448569e2
+ pkgver = 0.0.3603.gd8e7ff8a
pkgrel = 1
url = https://github.com/anura-engine/anura
install = anura.install
@@ -27,10 +25,12 @@ pkgbase = anura-git
source = git+https://github.com/sweetkristas/imgui.git
source = anura.sh
source = fix_redefine_have_m_pi_error.patch
+ source = fix_boost_uuid_detail_sha1_path.patch
md5sums = SKIP
md5sums = SKIP
md5sums = 15f4c03c2404bcfd7618b8f9e0c850ba
md5sums = bfdf31856d06c69ef13ee76f0a67242b
+ md5sums = 6a929113d76065841c1cb87bf4798f58
pkgname = anura-git
diff --git a/PKGBUILD b/PKGBUILD
index d33e2d2a7d87..a4f39cc9f1dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
pkgname=anura-git
-pkgver=0.0.3587.g448569e2
+pkgver=0.0.3603.gd8e7ff8a
pkgrel=1
pkgdesc="A fully-featured game engine, the tech behind the spectacular Frogatto & Friends."
arch=(i686 x86_64)
@@ -13,11 +13,13 @@ makedepends=(git boost)
source=('git+https://github.com/anura-engine/anura.git#branch=trunk'
'git+https://github.com/sweetkristas/imgui.git'
anura.sh
- fix_redefine_have_m_pi_error.patch)
+ fix_redefine_have_m_pi_error.patch
+ fix_boost_uuid_detail_sha1_path.patch)
md5sums=('SKIP'
'SKIP'
'15f4c03c2404bcfd7618b8f9e0c850ba'
- 'bfdf31856d06c69ef13ee76f0a67242b')
+ 'bfdf31856d06c69ef13ee76f0a67242b'
+ '6a929113d76065841c1cb87bf4798f58')
install=anura.install
_gitname=anura
@@ -29,6 +31,7 @@ prepare() {
git submodule update
git apply "$srcdir/fix_redefine_have_m_pi_error.patch"
+ git apply "$srcdir/fix_boost_uuid_detail_sha1_path.patch"
}
pkgver() {
diff --git a/fix_boost_uuid_detail_sha1_path.patch b/fix_boost_uuid_detail_sha1_path.patch
new file mode 100644
index 000000000000..415a171f505a
--- /dev/null
+++ b/fix_boost_uuid_detail_sha1_path.patch
@@ -0,0 +1,26 @@
+diff --git a/src/formula_function.cpp b/src/formula_function.cpp
+index 6ad07c92..40ccb0b8 100644
+--- a/src/formula_function.cpp
++++ b/src/formula_function.cpp
+@@ -28,7 +28,7 @@
+
+ #include <boost/format.hpp>
+ #include <boost/lexical_cast.hpp>
+-#include <boost/uuid/sha1.hpp>
++#include <boost/uuid/detail/sha1.hpp>
+ #include <boost/algorithm/string.hpp>
+ #include <boost/exception/diagnostic_information.hpp>
+ #include <boost/exception_ptr.hpp>
+diff --git a/src/preferences.cpp b/src/preferences.cpp
+index d8a0cbbd..3c4afcb2 100644
+--- a/src/preferences.cpp
++++ b/src/preferences.cpp
+@@ -28,7 +28,7 @@
+
+ #include <boost/regex.hpp>
+ #include <boost/lexical_cast.hpp>
+-#include <boost/uuid/sha1.hpp>
++#include <boost/uuid/detail/sha1.hpp>
+
+ #include "asserts.hpp"
+ #include "controls.hpp"