summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0002-Fix-a-Linux-compilation-error.patch42
-rw-r--r--PKGBUILD9
3 files changed, 7 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7ce75239b57..da2542a3163f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = anura-git
pkgdesc = A fully-featured game engine, the tech behind the spectacular Frogatto & Friends.
- pkgver = 0.0.700.g84ac3cd
+ pkgver = 0.0.2288.g282c8b1
pkgrel = 1
url = https://github.com/anura-engine/anura
install = anura.install
@@ -21,10 +21,12 @@ pkgbase = anura-git
depends = boost-libs
optdepends = frogatto-git: the default game module
optdepends = box2d: box2d physics
- source = git+https://github.com/anura-engine/anura.git
+ source = git+https://github.com/anura-engine/anura.git#branch=trunk
source = anura.sh
+ source = 0001-Change-Makefile-to-enable-ccache-to-work.patch
md5sums = SKIP
md5sums = 15f4c03c2404bcfd7618b8f9e0c850ba
+ md5sums = 63fee48f8260aa1e51f7d4ab9bdb925f
pkgname = anura-git
diff --git a/0002-Fix-a-Linux-compilation-error.patch b/0002-Fix-a-Linux-compilation-error.patch
deleted file mode 100644
index 073ed2d60235..000000000000
--- a/0002-Fix-a-Linux-compilation-error.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From a51e39291a5a83909e6b4cac080dd8cfc358ae8f Mon Sep 17 00:00:00 2001
-From: Yaohan Chen <yaohan.chen@gmail.com>
-Date: Wed, 12 Aug 2015 19:16:46 -0400
-Subject: [PATCH 2/2] Fix a Linux compilation error
-
-A comparison between boost::optional and nullptr in src/tiled/tmx_reader.cpp
-causes compilation to fail with boost version 1.58. This fixes it by
-comparing with boost::none instead, which works in both the latest boost
-and the bundled version.
-
-Although this fix is not necessary for the bundled boost in the
-compilation stage, on a Linux system the linking may fail because the
-boost library on the system doesn't match the bundled boost headers.
----
- src/tiled/tmx_reader.cpp | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/tiled/tmx_reader.cpp b/src/tiled/tmx_reader.cpp
-index 3409d12..60c8e0f 100644
---- a/src/tiled/tmx_reader.cpp
-+++ b/src/tiled/tmx_reader.cpp
-@@ -139,7 +139,7 @@ namespace tiled
- void TmxReader::parseMapElement(const boost::property_tree::ptree& pt)
- {
- auto attributes = pt.get_child_optional("<xmlattr>");
-- ASSERT_LOG(attributes != nullptr, "map elements must have a minimum number of attributes: 'version', 'orientation', 'width', 'height', 'tilewidth', 'tileheight'");
-+ ASSERT_LOG(attributes != boost::none, "map elements must have a minimum number of attributes: 'version', 'orientation', 'width', 'height', 'tilewidth', 'tileheight'");
- auto version = attributes->get_child("version").data();
- auto orientation = attributes->get_child("orientation").data();
- map_->setOrientation(convert_orientation(orientation));
-@@ -201,7 +201,7 @@ namespace tiled
- void TmxReader::parseTileset(const boost::property_tree::ptree& pt)
- {
- auto attributes = pt.get_child_optional("<xmlattr>");
-- ASSERT_LOG(attributes != nullptr, "tileset elements must have a minimum number of attributes: 'firstgid'");
-+ ASSERT_LOG(attributes != boost::none, "tileset elements must have a minimum number of attributes: 'firstgid'");
- int firstgid = attributes->get<int>("firstgid");
- TileSet ts(firstgid);
-
---
-2.5.0
-
diff --git a/PKGBUILD b/PKGBUILD
index adec0e34e5c0..67981f57408f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
pkgname=anura-git
-pkgver=0.0.2160.gaada7d7
+pkgver=0.0.2288.g282c8b1
pkgrel=1
pkgdesc="A fully-featured game engine, the tech behind the spectacular Frogatto & Friends."
arch=(i686 x86_64)
@@ -12,12 +12,10 @@ optdepends=('frogatto-git: the default game module'
makedepends=(git boost)
source=('git+https://github.com/anura-engine/anura.git#branch=trunk'
anura.sh
- 0001-Change-Makefile-to-enable-ccache-to-work.patch
- 0002-Fix-a-Linux-compilation-error.patch)
+ 0001-Change-Makefile-to-enable-ccache-to-work.patch)
md5sums=('SKIP'
'15f4c03c2404bcfd7618b8f9e0c850ba'
- '63fee48f8260aa1e51f7d4ab9bdb925f'
- '39a6636cdfe007beb20b754820618601')
+ '63fee48f8260aa1e51f7d4ab9bdb925f')
install=anura.install
_gitname=anura
@@ -38,7 +36,6 @@ prepare() {
cd $_gitname
git apply ../0001-Change-Makefile-to-enable-ccache-to-work.patch
- git apply ../0002-Fix-a-Linux-compilation-error.patch
# use system boost headers
rm -r external/include/boost