summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD8
3 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da49e6dda9e4..3bd2f75b7977 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = apache-jena
pkgdesc = Java framework for building Semantic Web and Linked Data applications
- pkgver = 3.14.0
+ pkgver = 5.0.0
pkgrel = 1
url = https://jena.apache.org/
arch = any
license = Apache
- depends = java-runtime
- source = http://www-us.apache.org/dist/jena/binaries/apache-jena-3.14.0.tar.gz
- sha512sums = ba2e966df3ff2c8727b02f95771aa9f9953687fadbd51a95fff3709bb342ca64c1ac54bc25c9e24432b038c14737979c48fad5885e5841d6c15cc4967859b037
+ depends = java-runtime>=17
+ source = https://downloads.apache.org/jena/binaries/apache-jena-5.0.0.tar.gz
+ sha512sums = 5bbb9a3b613eadcd75beb11671b2d797794b578eea2f0e68b57ba7fd402ca789c7ea3c71206baace8c662581e8e615a22d40d3b5f9461823a8603dd6ee40d912
pkgname = apache-jena
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3372492e0b3b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# source
+/*.tar.gz
+
+# build
+/src/
+/pkg/
+
+# package
+/*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
index 96678112761a..c77db3c29ac1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Lucas Werkmeister <mail@lucaswerkmeister.de>
# TODO improve installation per https://wiki.archlinux.org/index.php/Java_package_guidelines – several of the dependencies have their own packages
pkgname=apache-jena
-pkgver=3.15.0
+pkgver=5.0.0
pkgrel=1
pkgdesc='Java framework for building Semantic Web and Linked Data applications'
arch=('any')
url='https://jena.apache.org/'
license=('Apache')
-depends=('java-runtime')
-source=("http://www-us.apache.org/dist/${pkgname/apache-/}/binaries/${pkgname}-${pkgver}.tar.gz")
-sha512sums=('56091cb84ce1d5f2a7441b63f077393b28bc56485be31aaf77b54754e1b1ce4f8df638e08fd4838c8feda42b7eafc3b36281c10520b107522bfeeb70f4af25c7')
+depends=('java-runtime>=17')
+source=("https://downloads.apache.org/${pkgname/apache-/}/binaries/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('5bbb9a3b613eadcd75beb11671b2d797794b578eea2f0e68b57ba7fd402ca789c7ea3c71206baace8c662581e8e615a22d40d3b5f9461823a8603dd6ee40d912')
package() {
cd "$pkgname-$pkgver"