summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--Makefile.am.patch76
-rw-r--r--PKGBUILD39
-rw-r--r--ca-oc.t1x.patch38
-rw-r--r--configure.ac.patch34
-rw-r--r--oc-ca.t1x.patch20
6 files changed, 232 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b192d08c2a65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = apertium-oc-ca
+ pkgdesc = Apertium language data for the Occitan-Catalan translator.
+ pkgver = 1.0.5
+ pkgrel = 2
+ url = http://apertium.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ makedepends = autoconf
+ depends = lttoolbox>=3.0
+ depends = apertium>=3.0
+ source = http://downloads.sourceforge.net/sourceforge/apertium/apertium-oc-ca-1.0.5.tar.gz
+ source = Makefile.am.patch
+ source = configure.ac.patch
+ source = ca-oc.t1x.patch
+ source = oc-ca.t1x.patch
+ md5sums = 902a96a35ae43d3f9437ae92f812459e
+ md5sums = 38067f63d1bce99f424d3c49b86f2a6f
+ md5sums = 3ade075d16b703044bde8bbd8d5d4ff3
+ md5sums = 10de3a78ace592fd2d38dec074d3ec85
+ md5sums = 4cd0d20adb084351c6ee04078c22fc25
+
+pkgname = apertium-oc-ca
+
diff --git a/Makefile.am.patch b/Makefile.am.patch
new file mode 100644
index 000000000000..47228537706e
--- /dev/null
+++ b/Makefile.am.patch
@@ -0,0 +1,76 @@
+--- ../apertium-oc-ca-1.0.5/Makefile.am 2008-07-21 13:02:56.000000000 +0200
++++ apertium-oc-ca-1.0.5/Makefile.am 2010-09-15 16:32:22.000000000 +0200
+@@ -19,7 +19,7 @@
+ $(PREFIX2).autogen.bin $(PREFIX2b).autogen.bin \
+ $(PREFIX1).autopgen.bin $(PREFIX1b).autopgen.bin \
+ $(PREFIX2).autopgen.bin $(PREFIX2b).autopgen.bin modes
+-
++
+ TARGETS = $(TARGETS_COMMON) $(PREFIX1).t1x.bin $(PREFIX1).t2x.bin $(PREFIX1).t3x.bin \
+ $(PREFIX1b).t1x.bin $(PREFIX1b).t2x.bin $(PREFIX1b).t3x.bin \
+ $(PREFIX2).t1x.bin $(PREFIX2).t2x.bin $(PREFIX2).t3x.bin \
+@@ -72,7 +72,7 @@
+
+ .deps/$(LANG2b).post.dix: $(BASENAME).post-$(LANG2).dix
+ xsltproc --stringparam alt $(LANG1b) alt.xsl $(BASENAME).post-$(LANG2).dix >$@
+-
++
+ $(PREFIX1).automorf.bin: .deps/$(LANG1).dix
+ apertium-validate-dictionary .deps/$(LANG1).dix
+ lt-comp lr .deps/$(LANG1).dix $@
+@@ -136,7 +136,7 @@
+ $(PREFIX2b).autopgen.bin: .deps/$(LANG1b).post.dix
+ apertium-validate-dictionary .deps/$(LANG1b).post.dix
+ lt-comp lr .deps/$(LANG1b).post.dix $@
+-
++
+ $(PREFIX1).t1x: $(BASENAME).$(PREFIX1).t1x
+ xsltproc --stringparam alt $(LANG1) alt.xsl $(BASENAME).$(PREFIX1).t1x > $@
+ apertium-validate-transfer $@
+@@ -168,7 +168,7 @@
+ $(PREFIX2b).t2x: $(BASENAME).$(PREFIX2).t2x
+ xsltproc --stringparam alt $(LANG1b) alt.xsl $(BASENAME).$(PREFIX2).t2x > $@
+ apertium-validate-interchunk $@
+-
++
+ $(PREFIX1).t3x: $(BASENAME).$(PREFIX1).t3x
+ xsltproc --stringparam alt $(LANG1) alt.xsl $(BASENAME).$(PREFIX1).t3x > $@
+ apertium-validate-postchunk $@
+@@ -233,19 +233,18 @@
+ $(BASENAME).$(PREFIX1).t1x $(BASENAME).$(PREFIX2).t1x \
+ $(BASENAME).$(PREFIX1).t2x $(BASENAME).$(PREFIX2).t2x \
+ $(BASENAME).$(PREFIX1).t3x $(BASENAME).$(PREFIX2).t3x
+-
+-
++
+ modes: modes.xml Makefile.am
+ apertium-gen-modes modes.xml
+ @cp *.mode modes
+-
++
+ $(INSTALL_MODES): modes.xml Makefile.am
+ apertium-gen-modes modes.xml
+ @cp *.mode modes
+
+ apertium_oc_cadir=$(prefix)/share/apertium/apertium-$(PREFIX1)/
+ apertium_oc_camodesdir=$(prefix)/share/apertium/modes/
+-
++
+ apertium_oc_ca_DATA=$(PREFIX1).automorf.bin $(PREFIX2).automorf.bin \
+ $(PREFIX1).autobil.bin $(PREFIX2).autobil.bin \
+ $(PREFIX1).autogen.bin $(PREFIX2).autogen.bin \
+@@ -267,9 +266,9 @@
+
+ install-data-local:
+ apertium-gen-modes modes.xml apertium-$(PREFIX1)
+- $(INSTALL_DATA) oc-ca.mode $(apertium_oc_camodesdir)
+- $(INSTALL_DATA) ca-oc.mode $(apertium_oc_camodesdir)
+- $(INSTALL_DATA) oc_aran-ca.mode $(apertium_oc_camodesdir)
+- $(INSTALL_DATA) ca-oc_aran.mode $(apertium_oc_camodesdir)
+-
++ $(INSTALL_DATA) oc-ca.mode $(DESTDIR)$(apertium_oc_camodesdir)
++ $(INSTALL_DATA) ca-oc.mode $(DESTDIR)$(apertium_oc_camodesdir)
++ $(INSTALL_DATA) oc_aran-ca.mode $(DESTDIR)$(apertium_oc_camodesdir)
++ $(INSTALL_DATA) ca-oc_aran.mode $(DESTDIR)$(apertium_oc_camodesdir)
++
+ CLEANFILES = -r $(TARGETS)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..044fdf86fc34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: Kevin Brubeck Unhammer <unhammer@gmail.com>
+# Maintainer: Kevin Brubeck Unhammer <unhammer@gmail.com>
+pkgname=apertium-oc-ca
+pkgver=1.0.5
+pkgrel=2
+pkgdesc="Apertium language data for the Occitan-Catalan translator."
+url="http://apertium.org"
+license=('GPL')
+makedepends=('pkgconfig' 'autoconf')
+depends=('lttoolbox>=3.0' 'apertium>=3.0')
+arch=('i686' 'x86_64')
+source=("http://downloads.sourceforge.net/sourceforge/apertium/${pkgname}-${pkgver}.tar.gz"
+ "Makefile.am.patch"
+ "configure.ac.patch"
+ "ca-oc.t1x.patch"
+ "oc-ca.t1x.patch")
+md5sums=('902a96a35ae43d3f9437ae92f812459e'
+ '38067f63d1bce99f424d3c49b86f2a6f'
+ '3ade075d16b703044bde8bbd8d5d4ff3'
+ '10de3a78ace592fd2d38dec074d3ec85'
+ '4cd0d20adb084351c6ee04078c22fc25')
+
+build() {
+ patch -p0 < Makefile.am.patch
+ patch -p0 < configure.ac.patch
+
+ patch -p0 < ca-oc.t1x.patch # this didn't compile when it was released even...
+ patch -p0 < oc-ca.t1x.patch
+
+ mkdir -p "$pkgdir/usr/share/apertium/modes"
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ autoreconf -i
+
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir/" install || return 1
+}
diff --git a/ca-oc.t1x.patch b/ca-oc.t1x.patch
new file mode 100644
index 000000000000..23cb4fedbcbf
--- /dev/null
+++ b/ca-oc.t1x.patch
@@ -0,0 +1,38 @@
+--- ../apertium-oc-ca-1.0.5/apertium-oc-ca.ca-oc.t1x 2008-07-21 13:02:56.000000000 +0200
++++ apertium-oc-ca-1.0.5/apertium-oc-ca.ca-oc.t1x 2010-09-21 16:29:10.240738777 +0200
+@@ -987,7 +987,7 @@
+ </choose>
+ <choose><!-- aquests no són ref-->
+ <when>
+- <test>
++ <test><and>
+ <equal caseless="yes">
+ <clip pos="2" side="sl" part="pers"/>
+ <lit-tag v="p3"/>
+@@ -996,7 +996,7 @@
+ <clip pos="2" side="sl" part="nbr"/>
+ <lit-tag v="sg"/>
+ </equal>
+- </test>
++ </and></test>
+ <choose>
+ <when><!-- m'ha passat-> m'a arribat-->
+ <test>
+@@ -1202,7 +1202,7 @@
+ </choose>
+ <choose><!-- aquests no són ref-->
+ <when>
+- <test>
++ <test><and>
+ <equal caseless="yes">
+ <clip pos="2" side="sl" part="pers"/>
+ <lit-tag v="p3"/>
+@@ -1211,7 +1211,7 @@
+ <clip pos="2" side="sl" part="nbr"/>
+ <lit-tag v="sg"/>
+ </equal>
+- </test>
++ </and></test>
+ <choose>
+ <when><!-- m'ha passat-> m'a arribat-->
+ <test>
diff --git a/configure.ac.patch b/configure.ac.patch
new file mode 100644
index 000000000000..54847cb1bfc7
--- /dev/null
+++ b/configure.ac.patch
@@ -0,0 +1,34 @@
+--- ../apertium-oc-ca-1.0.5/configure.ac 2008-07-21 13:02:56.000000000 +0200
++++ apertium-oc-ca-1.0.5/configure.ac 2010-09-15 16:41:22.000000000 +0200
+@@ -11,7 +11,7 @@
+ AC_PROG_AWK
+ AC_CONFIG_HEADER([config])
+
+-AC_DEFUN(PKG_CHECK_APERTIUM, [
++AC_DEFUN([PKG_CHECK_APERTIUM], [
+ APERTIUM_VER=0
+ PKG_CHECK_MODULES(APERTIUM, apertium-1.0 >= 1.0.0,
+ [
+@@ -23,8 +23,20 @@
+ APERTIUM_VER=20
+ ],
+ [
+- PKG_CHECK_MODULES(APERTIUM, apertium-3.0 >= 3.0.0)
+- APERTIUM_VER=30
++ PKG_CHECK_MODULES(APERTIUM, apertium-3.0 >= 3.0.0,
++ [
++ APERTIUM_VER=30
++ ],
++ [
++ PKG_CHECK_MODULES(APERTIUM, apertium-3.1 >= 3.1.0,
++ [
++ APERTIUM_VER=31
++ ],
++ [
++ PKG_CHECK_MODULES(APERTIUM, apertium-3.2 >= 3.2.0)
++ APERTIUM_VER=32
++ ])
++ ])
+ ])
+ ])
+ AC_SUBST(APERTIUM_VER)
diff --git a/oc-ca.t1x.patch b/oc-ca.t1x.patch
new file mode 100644
index 000000000000..1d4371478401
--- /dev/null
+++ b/oc-ca.t1x.patch
@@ -0,0 +1,20 @@
+--- ../apertium-oc-ca-1.0.5/apertium-oc-ca.oc-ca.t1x 2008-07-21 13:02:56.000000000 +0200
++++ apertium-oc-ca-1.0.5/apertium-oc-ca.oc-ca.t1x 2010-09-15 16:49:14.000000000 +0200
+@@ -1282,7 +1282,7 @@
+ </choose>
+ <choose><!-- aquests no són ref-->
+ <when>
+- <test>
++ <test><and>
+ <equal caseless="yes">
+ <clip pos="2" side="sl" part="pers"/>
+ <lit-tag v="p3"/>
+@@ -1291,7 +1291,7 @@
+ <clip pos="2" side="sl" part="nbr"/>
+ <lit-tag v="sg"/>
+ </equal>
+- </test>
++ </and></test>
+ <choose>
+ <when>
+ <test>