summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md12
-rw-r--r--PKGBUILD4
3 files changed, 17 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5d26b21f090..ad070a82280e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = apollo-rover
pkgdesc = CLI for Apollo's suite of GraphQL developer productivity tools
- pkgver = 0.5.0
+ pkgver = 0.5.1
pkgrel = 1
url = https://github.com/apollographql/rover
install = rover.install
@@ -12,7 +12,7 @@ pkgbase = apollo-rover
depends = zlib
replaces = apollo-rover-fed2
options = !lto
- source = apollo-rover-0.5.0.tar.gz::https://github.com/apollographql/rover/archive/v0.5.0.tar.gz
- sha256sums = 560708b3018ddbe2bafff2c26e312fdeb3842f41ed4671e54e2faef9d93b25fc
+ source = apollo-rover-0.5.1.tar.gz::https://github.com/apollographql/rover/archive/v0.5.1.tar.gz
+ sha256sums = 5382cbafbfae451a12dc43c0d6ddc529199e5bea9272e2a4fad13ed44c388c44
pkgname = apollo-rover
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 5f734341ba05..f880d876f4bf 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -18,6 +18,18 @@ This project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.htm
## 📚 Documentation -->
+# [0.5.1] - 2022-04-11
+
+## 🐛 Fixes
+
+- **Return a hard error in CI when the ELv2 license is not accepted instead of hanging for eternity - @EverlastingBugstopper, #1082 fixes #1081**
+
+ If you ran `rover supergraph compose` with `federation_version: 2` in CI - it would prompt you to accept the ELv2 license and hang waiting for the input for eternity. This is no longer the case and you will get a helpful error message detailing exactly what you need to do to never see the error again. For more details on the license, see our [FAQ](https://www.apollographql.com/docs/resources/elastic-license-v2-faq/).
+
+- **Removes extraneous debug statement - @EverlastingBugstopper, #1079**
+
+ In my rush this morning I missed the removal of an `eprintln` statement. It's gone now.
+
# [0.5.0] - 2022-04-11
> Important: X breaking changes below, indicated by **❗ BREAKING ❗**
diff --git a/PKGBUILD b/PKGBUILD
index ae9f9249f8fd..2a8c154de625 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=apollo-rover
-pkgver=0.5.0
+pkgver=0.5.1
pkgrel=1
pkgdesc="CLI for Apollo's suite of GraphQL developer productivity tools"
arch=('x86_64')
@@ -14,7 +14,7 @@ options=('!lto')
install=rover.install
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('560708b3018ddbe2bafff2c26e312fdeb3842f41ed4671e54e2faef9d93b25fc')
+sha256sums=('5382cbafbfae451a12dc43c0d6ddc529199e5bea9272e2a4fad13ed44c388c44')
prepare() {
cd "rover-$pkgver"