summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
-rw-r--r--applebloom.install20
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c8f44d18b4c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = applebloom
+ pkgdesc = Apple Bloom the pony dictionary
+ pkgver = 1396811847
+ pkgrel = 1
+ url = https://github.com/GNU-Pony/applebloom
+ install = applebloom.install
+ arch = any
+ license = AGPL3
+ makedepends = make
+ makedepends = coreutils
+ makedepends = sed
+ makedepends = texinfo
+ makedepends = gzip
+ depends = bash
+ depends = coreutils
+ source = https://github.com/GNU-Pony/applebloom/archive/1396811847.tar.gz
+ sha256sums = 899e6cc9ccdb3143158e43b8f0bedcb3babdb89533ad575eb72e339f183cc7bc
+
+pkgname = applebloom
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c925b31a418
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=applebloom
+pkgver=1396811847
+pkgrel=1
+pkgdesc="Apple Bloom the pony dictionary"
+url="https://github.com/GNU-Pony/applebloom"
+arch=(any)
+license=(AGPL3)
+depends=(bash coreutils)
+makedepends=(make coreutils sed texinfo gzip)
+install=applebloom.install
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(899e6cc9ccdb3143158e43b8f0bedcb3babdb89533ad575eb72e339f183cc7bc)
+
+_prefix=/usr
+
+
+build() {
+ cd "${srcdir}/applebloom-${pkgver}"
+ make PREFIX="${_prefix}" PKGNAME="${pkgname}" DESTDIR="${pkgdir}" default
+}
+
+package() {
+ cd "${srcdir}/applebloom-${pkgver}"
+ make PREFIX="${_prefix}" PKGNAME="${pkgname}" DESTDIR="${pkgdir}" install
+ _dir="${pkgdir}${_prefix}/share/licenses/${pkgname}"
+ ln -sf -- "/usr/share/licenses/common/AGPL3" "${_dir}/LICENSE"
+}
+
diff --git a/applebloom.install b/applebloom.install
new file mode 100644
index 000000000000..0480eb1544fd
--- /dev/null
+++ b/applebloom.install
@@ -0,0 +1,20 @@
+_file="applebloom"
+
+infodir="usr/share/info"
+file="${_file}.info"
+
+
+post_install() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info --delete -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+