summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--cmake.extra.install.dirs.remove.patch11
3 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6828ce9b318e..b5d711191366 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -25,10 +25,8 @@ pkgbase = appleseed-git
conflicts = appleseed
source = appleseed-git::git+https://github.com/appleseedhq/appleseed.git
source = cmake.extra.install.dirs.remove.patch
- source = https://github.com/appleseedhq/appleseed/pull/2526.diff
md5sums = SKIP
- md5sums = 1cc8d927665c126dde4d1135e500c0dc
- md5sums = 0414eb9eae969118a118c82ac9d47512
+ md5sums = 667700dcf5d0e135ad17109877001ade
pkgname = appleseed-git
diff --git a/PKGBUILD b/PKGBUILD
index 4dcbc47c917c..e2daed955f3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,11 +15,10 @@ makedepends=(git cmake)
options=()
source=("${pkgname}::git+https://github.com/appleseedhq/appleseed.git${_fragment}"
"cmake.extra.install.dirs.remove.patch"
- "https://github.com/appleseedhq/appleseed/pull/2526.diff"
)
md5sums=('SKIP'
- '1cc8d927665c126dde4d1135e500c0dc'
- '0414eb9eae969118a118c82ac9d47512')
+ '667700dcf5d0e135ad17109877001ade'
+ )
#_pyver=$(python -c "from sys import version_info; print(\"%d.%d\" % (version_info[0],version_info[1]))")
#_pyver=$(pacman -Sddp --print-format %v python|grep -oP ^[0-9.]{3})
@@ -43,7 +42,7 @@ pkgver() {
prepare() {
cd ${pkgname}
git apply -v ${srcdir}/cmake.extra.install.dirs.remove.patch
- git apply -v ${srcdir}/*.diff
+# git apply -v ${srcdir}/*.diff
grep -q avx /proc/cpuinfo && CMAKE_FLAGS="${CMAKE_FLAGS} -DUSE_AVX=ON"
grep -q avx2 /proc/cpuinfo && CMAKE_FLAGS="${CMAKE_FLAGS} -DUSE_AVX2=ON"
grep -q f16c /proc/cpuinfo && CMAKE_FLAGS="${CMAKE_FLAGS} -DUSE_F16C=ON"
diff --git a/cmake.extra.install.dirs.remove.patch b/cmake.extra.install.dirs.remove.patch
index a885460bbf84..c07767661983 100644
--- a/cmake.extra.install.dirs.remove.patch
+++ b/cmake.extra.install.dirs.remove.patch
@@ -1,15 +1,16 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 55bc83209..cfa5542e1 100644
+index cb8bfa958..8d8a4e5be 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -673,10 +673,6 @@ install (
- DESTINATION .
+@@ -756,11 +756,6 @@ install (
+ DESTINATION schemas
)
-install (
- CODE "FILE (MAKE_DIRECTORY ${CMAKE_INSTALL_PREFIX}/images)"
- CODE "FILE (MAKE_DIRECTORY ${CMAKE_INSTALL_PREFIX}/images/autosave)"
-)
-
- if (WITH_SAMPLES)
+-
+ if (INSTALL_HEADERS)
install (
+ DIRECTORY src/appleseed/foundation