summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c0ddaf77026..d6d05d74dedd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = appleseed-git
- pkgdesc = physically-based global illumination rendering engine primarily designed for animation and visual effects.
- pkgver = 2.1.0.beta.r267.gabb612f03
+ pkgdesc = Physically-based global illumination rendering engine primarily designed for animation and visual effects (development vesion).
+ pkgver = 2.1.0.beta.r275.g390d5cda9
pkgrel = 1
epoch = 1
url = https://appleseedhq.net
diff --git a/PKGBUILD b/PKGBUILD
index 70148c287386..06aebc314ec4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
-#!/bin/bash
+#!/hit/bash
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
#_fragment="#branch=2.0.5-beta-maintenance"
pkgname=appleseed-git
-pkgver=2.1.0.beta.r267.gabb612f03
+pkgver=2.1.0.beta.r275.g390d5cda9
pkgrel=1
epoch=1
-pkgdesc="physically-based global illumination rendering engine primarily designed for animation and visual effects. "
+pkgdesc="Physically-based global illumination rendering engine primarily designed for animation and visual effects (development vesion)."
arch=(i686 x86_64)
url="https://appleseedhq.net"
license=('MIT')
@@ -43,7 +43,7 @@ build() {
_pyver=$(python -c "from sys import version_info; print(\"%d.%d\" % (version_info[0],version_info[1]))")
CMAKE_FLAGS=( -DWITH_EMBREE=ON
-DCMAKE_BUILD_TYPE=Ship
- -DCMAKE_INSTALL_PREFIX="/opt/appleseed"
+ -DCMAKE_INSTALL_PREFIX=/opt/appleseed
-DWITH_DISNEY_MATERIAL=ON
-DWITH_PYTHON3_BINDINGS=ON
-DUSE_STATIC_EMBREE=OFF
@@ -55,13 +55,15 @@ CMAKE_FLAGS=( -DWITH_EMBREE=ON
-DWARNINGS_AS_ERRORS=OFF
-DWITH_BENCH=OFF
-DPYTHON3_INCLUDE_DIR="/usr/include/python${_pyver}"
+ -Wno-dev
)
grep -q avx /proc/cpuinfo && CMAKE_FLAGS+=(-DUSE_AVX=ON)
grep -q avx2 /proc/cpuinfo && CMAKE_FLAGS+=(-DUSE_AVX2=ON)
grep -q f16c /proc/cpuinfo && CMAKE_FLAGS+=(-DUSE_F16C=ON)
grep -q sse4_2 /proc/cpuinfo && CMAKE_FLAGS+=(-DUSE_SSE42=ON)
- cmake ${CMAKE_FLAGS[*]} -S "${srcdir}/${pkgname}" -B build -G Ninja
+ cmake "${CMAKE_FLAGS[@]}" -S "${srcdir}/${pkgname}" -B build -G Ninja
+# shellcheck disable=SC2086 # allow MAKEFLAGS to carry multiple flags
ninja -C build ${MAKEFLAGS:--j1}
}