summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD31
2 files changed, 17 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25ba84cf62b4..65dd23f6f04a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = aptpac
pkgdesc = a pacman wrapper with syntax from debian's apt
- pkgver = 3.0.1
+ pkgver = 3.3.0
pkgrel = 1
url = https://github.com/FascodeNet/aptpac
arch = any
license = WTFPL
- makedepends = git
- depends = sudo
conflicts = apt
conflicts = apt-git
conflicts = aptpac-git
- source = https://github.com/FascodeNet/aptpac/archive/v3.0.1.zip
+ source = https://github.com/FascodeNet/aptpac/archive/v3.3.0.zip
md5sums = SKIP
pkgname = aptpac
-
diff --git a/PKGBUILD b/PKGBUILD
index 548c33438559..1a7bfd6b94fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
-# Maintaoner: Yamada Hayao <development@fascode.net>
-# Maintainer: Abraham Levine <echo iue@trnspljc.890 | tr ietursnpl890jc acprlsurecomed>
+# Maintainer: Yamada Hayao <development@fascode.net>
+# Contributor: Abraham Levine <echo iue@trnspljc.890 | tr ietursnpl890jc acprlsurecomed>
-pkgname=aptpac
-pkgver=3.0.1
-pkgrel=1
+_gitname='aptpac'
+pkgname="aptpac"
pkgdesc="a pacman wrapper with syntax from debian's apt"
+pkgver="3.3.0"
+pkgrel="1"
+
arch=('any')
url="https://github.com/FascodeNet/aptpac"
license=('WTFPL')
-depends=('sudo')
-makedepends=('git')
-source=("${url}/archive/v${pkgver}.zip")
-md5sums=('SKIP')
-_gitname='aptpac'
conflicts=('apt' 'apt-git' 'aptpac-git')
+source=("${url}/archive/v${pkgver}.zip")
+md5sums=('SKIP')
package() {
- cd "${_gitname}-${pkgver}" &&
- install -m 755 -D aptpac "${pkgdir}/usr/bin/aptpac"
- install -m 755 -D LICENSE "${pkgdir}/usr/share/licenses/aptpac/LICENSE"
- cd "${pkgdir}/usr/bin/"
- ln -s "aptpac" "apt"
- ln -s "aptpac" "apt-get"
+ cd "${_gitname}-${pkgver}"
+ install -m 755 -D aptpac "${pkgdir}/usr/bin/aptpac"
+ install -m 755 -D LICENSE "${pkgdir}/usr/share/licenses/aptpac/LICENSE"
+ cd "${pkgdir}/usr/bin/"
+ ln -s "aptpac" "apt"
+ ln -s "aptpac" "apt-get"
}