summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c74aced6ade8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = aptpik
+ pkgdesc = a pikaur wrapper with syntax from debian's apt
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/daemonspudguy/aptpik
+ arch = any
+ license = WTFPL
+ makedepends = git
+ depends = sudo
+ depends = pikaur
+ conflicts = apt
+ conflicts = apt-git
+ conflicts = aptpac-git
+ conflicts = aptpac
+ source = https://github.com/daemonspudguy/aptpik/releases//download/1.0/v1.0.zip
+ md5sums = SKIP
+
+pkgname = aptpik
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f06251fd0de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jacob A. Tice <jacob.a.tice@gmail.com>
+
+pkgname=aptpik
+pkgver=1.0
+pkgrel=1
+pkgdesc="a pikaur wrapper with syntax from debian's apt"
+arch=('any')
+url="https://github.com/daemonspudguy/aptpik"
+license=('WTFPL')
+depends=('sudo' 'pikaur')
+makedepends=('git')
+source=("${url}/releases//download/${pkgver}/v${pkgver}.zip")
+md5sums=('SKIP')
+_gitname='aptpik'
+conflicts=('apt' 'apt-git' 'aptpac-git' 'aptpac')
+
+
+package() {
+ cd "${_gitname}-v${pkgver}" &&
+ install -m 755 -D aptpik "${pkgdir}/usr/bin/aptpik"
+ cd "${pkgdir}/usr/bin/"
+ ln -s "aptpik" "apt"
+ ln -s "aptpik" "apt-get"
+}